VectorLinux

The nuts and bolts => Installation & Updates => Topic started by: Silent Music on September 14, 2009, 02:04:42 pm

Title: [SOLVED] Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: Silent Music on September 14, 2009, 02:04:42 pm
Hi,
After a gap not using VLL on my old machine, I am back to using it again. I would like to install LXDE on version 6.0. I know I should really have installed Vector Linux Standard 6.0 in the first place to get LXDE, but I didn't and I don't want to lose the customisation I have already done on VLL.
Using Gslapt, I installed:
lxappearance
lxde-common
lxnm
lxpanel
lxsession-lite
lxtask
openbox
However, LXDE does not appear as an option in the "Session" menu at the login window. Openbox does, but that's not much use.
Am I missing a package or something? Do I have to configure something somewhere to get LXDE to work?
Any help would be appreciated. Thanks.
Title: Re: Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: Daniel on September 14, 2009, 02:29:24 pm
I know I should really have installed Vector Linux Standard 6.0 in the first place to get LXDE

VL 6 Standard comes with XFCE, not LXDE.

Using Gslapt, I installed:
lxappearance
lxde-common
lxnm
lxpanel
lxsession-lite
lxtask
openbox
However, LXDE does not appear as an option in the "Session" menu at the login window. Openbox does, but that's not much use.
Am I missing a package or something? Do I have to configure something somewhere to get LXDE to work?

It looks to me that you are missing the "lxde" package. All the packages you listed look like lxde packages but I think you need the main "lxde" package. (without the quotes)
Title: Re: Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: Silent Music on September 14, 2009, 03:02:06 pm
Yes I thought that, but it is not available in the repository. My Gslapt does not list it.
slapt-get --install lxde   returns:
no such package: lxde
Title: Re: Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: GrannyGeek on September 14, 2009, 03:34:24 pm
You are correct that VL6 Standard comes with LXDE. It is the non-default desktop environment.

According to /etc/X11/xinit/xinitrc.lxde, the command to start lxde is
/usr/bin/startlxde

At the end of that /usr/bin/startlxde file is this:
# Start the LXDE session
exec /usr/bin/lxsession -s LXDE

It seems there is no lxde command or program as such. Play around with these and see if it starts. I've started it just once, so I don't remember any details, but it did start.
--GrannyGeek
Title: Re: Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: newt on September 14, 2009, 04:24:33 pm
You can grab the lxde.tlz package that's included in VL6StandardGold here: http://www.mediafire.com/?oyzt2yoglym
Title: Re: Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: Daniel on September 14, 2009, 05:33:54 pm
You are correct that VL6 Standard comes with LXDE. It is the non-default desktop environment.

I stand corrected. Didn't realize Standard had LXDE.
Title: Re: Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: Silent Music on September 15, 2009, 02:53:19 am
I am having internet connection problems with Vector LL today, and I am having to reply using Zenwalk Linux, which is on the other hard drive of my old machine.
I logged into the forum using "Opera" and immediately got this warning:

Site not secure
The content of forum.vectorlinux.com is insecure and should not be used to exchange sensitive information.
The communication is done in plain text and there is no way to guarantee the identity of the server.

Probably just an Opera annoyance, but thought I'd mention it.

Anyway, thanks newt for the link. I have downloaded LXDE.tlz to the Desktop. Excuse my ignorance, but what is the best way to proceed now? I can code in a terminal:
unlzma LXDE.tlz
This changes the LXDE.tlz file into an archive, (LXD), which is an archive that Xarchiver can now handle. I could extract the parent folders inside the archive, (etc, usr, var) onto the desktop and then, as root, mv their contents into the relevant folders of the root folder /. But this would be laborious. Is there a safer and easier procedure?

Granny Geek it seems that you were wrong. The "lxde" package is missing in the repository, packaged presumably as lxde.tlz, and this is vital to get LXDE up and running, but thanks for your help. Please would the repository maintainers look into why this essential package for LXDE is not there.

Daniel, yes, I was advised that I should have installed Vector Linux Standard if I wanted LXDE, but I had already downloaded the iso for Vector Linux Light 6.0, assuming LXDE was there, (as it was in VLL5.9), burnt the CD, installed VLL and done some customisation for IceWM. I would like to add LXDE to this distro, rather than go to the trouble of downloading another iso and reinstalling everything. I think LXDE and IceWM would make a nice combination, and if I can get LXDE running I will delete JWM. It is just not as good.
Title: Re: Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: nightflier on September 15, 2009, 06:11:32 am
To extract/install an archive to your system, as root, issue command:
Code: [Select]
cd /
lzma -cd /path/to/the/file/lxde.tlz | tar xp
Title: Re: Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: GrannyGeek on September 15, 2009, 01:06:20 pm
Granny Geek it seems that you were wrong. The "lxde" package is missing in the repository, packaged presumably as lxde.tlz, and this is vital to get LXDE up and running, but thanks for your help. Please would the repository maintainers look into why this essential package for LXDE is not there.

It's entirely possible that I'm wrong. HOWEVER...
I did check /var/log/packages on my VL6 Standard and there is no such package as lxde installed. And yet, LXDE can be started and does work. So I'm not sure lxde.tlz gives you any more than what are already in the repos.

Just to see what would happen, I booted to text mode and tried to start LXDE with startlxde and /usr/bin/lxsession -s LXDE . Neither command worked. I got a message about a missing library. Then I remembered what I was told when I asked how to start LXDE on this forum some months ago. You have to start VASM as user, then XWMSET, then pick lxde as your default window manager. Then you type startx at a prompt and LXDE will start. No rebooting necessary. Seems like a lot of work to be able to start LXDE, but that's what you do in Standard.

I wondered the same thing you did: if someone wants to install LXDE in Light or the new KDE Classic VectorLinux, why isn't the lxde.tlz package in the repos if it's necessary? And now I'm wondering why you'd have to extract the package. Generally, you install a tlz package by typing as root at a prompt:
installpkg lxde.tlz

Is there something different about this package?

Let us know if/when you get it going and what you had to do.
--GrannyGeek

By the way, I always log in to this forum with Opera 10 and I don't recall seeing the message you got.
Title: Re: Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: M0E-lnx on September 15, 2009, 01:14:44 pm
Just my 2 cents here.
the file you guys are looking for is "lxde.tlz" and will most certainly not be in the repositories. Allow me to explain.
Packages in the repository follow the naming scheme "foo-var-0.1-i586-1vl60.tlz"

You may obtain this package from a install CD or ISO image only.

The fact that "lxde.tlz" does not follow that should tell you this is what we call a BULK package for installation via the Vectorlinux installer. It is a collection that includes all the packages needed for a working lxde environment. And no... it is not "vital" to get lxde to work.

If you install lxde from gslapt, that should give you the desktop environment. Now, depending on which version of VL you are running, which login manager you use, the location of your lxde.Desktop may need to change also.

Because this is no ordinary package, you dont want to install it using "installpkg" but rather using the following command
Code: [Select]
lzmadec < lxde.tlz | tar -xp -C /
After that, move or copy the xinitrc.lxde to the appropriate location for your login manager.
Title: Re: Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: GrannyGeek on September 15, 2009, 05:50:35 pm
Thanks for the explanation. I never would have guessed any of that.
--GrannyGeek
Title: Re: Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: Pita on September 15, 2009, 07:59:15 pm
I am a fluxbox aficionado with a xfce4-panel and somehow I must have installed
or did it come with VL-6-Light. Anyhow I just type in the xterm startlxde and it started
right on top of fluxbox like a skin which I can even move. I am not aware of others
like xfce4 or gnome that this can be done. They need a new X. (-- :2)
Title: Re: Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: Silent Music on September 16, 2009, 02:39:26 am
Thanks for the useful suggestions everyone who has contributed. This is a helpful forum.

Without installing the LXDE.tlz file, I am able to start LXDE by choosing the "failsafe" option from the "Session Type" or "Session" menu drop-down-list at the login screen. I then get an xterm console. If I code, (as normal user), /usr/bin/startlxde then LXDE starts. By the way, gdm is my login manager, (and the theme used is the "std" Vectorlinux theme, rather attractive IMHO). Obviously, since I have started the desktop with a console, the LX desktop environment disappears if I inadvertently close xterm, and I am back to the login screen.

I stand corrected therefore, GrannyGeek and MOE-lnx are right - I don't need the lxde.tlz package to operate LXDE. Installing lxde from gslapt should give you a working LXDE. The problem is that lxde is not showing up as one of the "Session Type" options in the drop-down-list, (Keyboard shortcut Alt+T). What I want is to be able to choose LXDE from among the various "Session Type" options and not have to start LXDE with with a "failsafe" console, which is a bit hammy.

GrannyGeek, you are using Vectorlinux Standard and said:
Quote
According to /etc/X11/xinit/xinitrc.lxde, the command to start lxde is
/usr/bin/startlxde
Well after installing the LXDE components with gslapt no /etc/X11/xinit/xinitrc.lxde file was created. In VLL there are such files for IceWM and JWM - /etc/X11/xinit/xinitrc.icewm and /etc/X11/xinit/xinitrc.jwm respectively. So I tried to create an xinitrc.lxde file in the same folder by modifying the xinitrc.icewm file and changing everything that said icewm into lxde. Then I coded: updatedb so that the system would see this new file. It is now seen for locate xinitrc.lxde purposes, but gdm is not seeing this file.
GrannyGeek please could you post the contents of your /etc/X11/xinit/xinitrc.lxde file, so that I can compare. Thanks in advance.

MOE-lnx you wrote:
Quote
If you install lxde from gslapt, that should give you the desktop environment. Now, depending on which version of VL you are running, which login manager you use, the location of your lxde.Desktop may need to change also.
I am not sure what you intend I should do here. Given that I am using VLL6.0 and gdm as my login manager, please could you suggest what might be changed or moved where.

Quote
After that, move or copy the xinitrc.lxde to the appropriate location for your login manager.
As I said above, no /etc/X11/xinit/xinitrc.lxde file was created for me when I installed the VLL components from gslapt. I need to check that I have got the xinitrc.lxde file that I created configured correctly, but it contains at the end the all important command:
exec /usr/bin/startlxde
which is what I am doing when I start lxde in a "failsafe" console.
Which file in gdm reads /etc/X11/xinit/xinitrc.lxde (and the xinitrc.icewm and xinitrc.jwm in the same folder, which presumably are being read because IceWM and JWM appear as options in the "Session" drop-down-list)? Which file or files do I need to modify so that I can get LXDE to appear there as a viable option as well?




Title: Re: Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: GrannyGeek on September 16, 2009, 10:22:04 am
Here are the contents of the /etc/X11/xinit/xinitrc.lxde file on VectorLinux 6 Standard:

Code: [Select]
#!/bin/sh
# $Xorg: xinitrc.cpp,v 1.3 2000/08/17 19:54:30 cpqbld Exp $

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/usr/lib/X11/xinit/.Xresources
sysmodmap=/usr/lib/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then
    /usr/bin/xrdb -merge $sysresources
fi

if [ -f $sysmodmap ]; then
    /usr/bin/xmodmap $sysmodmap
fi

if [ -f $userresources ]; then
    /usr/bin/xrdb -merge $userresources
fi

if [ -f $usermodmap ]; then
    /usr/bin/xmodmap $usermodmap
fi

exec /usr/bin/startlxde

I don't know if that will help. Let us know what happens.
--GrannyGeek
Title: Re: Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: Pita on September 16, 2009, 04:48:17 pm
If you start LXDE from xterm end the command with an & (ambersand).
 /usr/bin/startlxde &.
I think you should not need the /usr/bin even may be in failsafe.

Then in xterm type exit and press enter, that wil close xterm and LXDE will stay.
Title: Re: Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: Silent Music on September 16, 2009, 05:18:47 pm
Thank you GrannyGeek for that /etc/X11/xinit/xinit/xinitrc.lxde file. It was the same as the one that I created. I am sorry to say that it will not now be needed, because, I have to admit:
CORRECTION: my login manager is kdm, not gdm, and kdm does things in a different way. I was confused into thinking that gdm is my login manager, because both gdm and kdm are installed with VectorLinux Light 6.0, and gdm is obvious in /etc/X11 folder, whereas kdm is hidden and scattered throughout the /usr/share folder. I don't remember choosing kdm over gdm during the VLL6.0 installation, but I suppose I must have done.

Thank you Pita for that useful tip. I will investigate that after a good night's sleep.

The great news is that I have solved this problem. I will explain how tomorrow morning, or rather later today, because it is late, very late here in the UK, and I must get some much needed sleep.
Title: Re: Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: Pita on September 16, 2009, 08:38:17 pm

Thank you Pita for that useful tip. I will investigate that after a good night's sleep.

The great news is that I have solved this problem. I will explain how tomorrow morning, or rather later today, because it is late, very late here in the UK, and I must get some much needed sleep.

Hope you had a good rest. Well, I just found that my suggestion does not work in failsafe, exiting xterm kills LXDE.
It does work when I try it in fluxbox.
Title: Re: Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: M0E-lnx on September 17, 2009, 07:04:36 am
If you use KDM as login manger, then you need to create a .desktop file in /usr/share/apps/kdm/sessions
name it lxde.desktop

You can just copy one of the existing files, and edit it to change the following properties
Code: [Select]
Exec=startlxde -p LXDE
Name=LXDE
You can change more if you want, but those are the vital parts for your lxde to show up in the kdm session manager.
Title: Re: Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: Silent Music on September 17, 2009, 02:33:54 pm
Yes. That is what I discovered. Having finally realised that I was working with kdm and not gdm, (it's confusing having both installed), the problem was simply solved. The repository's LXDE packages installed by Gslapt give you a LXDE.desktop file in: /usr/share/xsessions
You have to move or copy this file to: /usr/share/apps/kdm/sessions/LXDE.desktop
If you don't find one you can create one modelled on /usr/share/apps/kdm/sessions/icewm.desktop, leaving out all the unnecessary locale comments. (I wonder how much hard drive space we'd save if we stripped all the un-needed locale customisation from Linux files? When I stripped the ICEWM.desktop file of un-needed code the size went down from 4.8kb to 149bytes) Logout and then login again, and you can start LXDE by selecting it from the Sessions menu, and not by using the console.

If you are working with gdm as your login manager, then you need to create an executable file /etc/X11/xinit/xinitrc.lxde  I found that this was not provided by the installation of the LXDE packages with gslapt. The xinitrc.lxde file can be modelled on an example file in the same directory - "xinitrc_example", or you can use GrannyGeek's file posted earlier in this thread. If you use the example file, save it in the same directory as:  xinitrc.lxde and remember to make it executable after saving it - code:
chmod +x /etc/X11/xinit/xinitrc.lxde
This file and the others like them in this folder (xinitrc.icewm, xinitrc.jwm, etc. ) can now be picked up by a sub-routine in the shell script: /etc/X11/gdm/Xsession and the desktop or window managers should display in the Session menu of your login screen.

I am pleased to have LXDE up and running on VectorLinux Light. It is worth having. I don't think it is any more resource hungry than IceWM and it is easier to customise. I will mark this thread as solved, but before I do, can anyone help with one niggling problem that remains with this installation of LXDE? The menu has a logout button. Clicking it just gives you the option to logout. You don't get a menu of options - Reboot, Shutdown, etc. as you do with IceWM. You have to logout to the login screen and reboot or shutdown from there. Surely this wasn't intended?
Can this be changed so that you can reboot or shutdown in one operation?


Title: Re: Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: Silent Music on September 23, 2009, 05:25:38 am
At the moment, I still cannot see how to solve the niggling problem I mentioned in my last post. There is some configuration somewhere in VLL6.0 which is preventing all the options showing when I click the logout button in the menu options. I cannot find what it is.

I have the same version of LXDE installed on Zenwalk Linux on the other hard drive of this machine. It does not have the same problem. All the options show when you click the logout button in the main menu. I replaced /usr/bin/lxde-logout and /usr/bin/lxsession-logout on the VLL6.0 hard drive with the same files from the same location on the Zenwalk Linux hard drive, but it did not make any difference. So the fault cannot have been with the original "lxde-logout" and lxsession-logout" files.

What can it be that is limiting their operation, principally the operation of /usr/bin/lxsession-logout?

As a temporary measure I copied ~/.icewm/shutdown-dialog.sh to ~/.config/shutdown-dialog.sh and revised this copied file to logout from LXDE rather than IceWM. I then created a shudown.desktop file in /usr/share/applications/ to point to ~/.config/shutdown-dialog . I then added this application.desktop file to the Application Launch Bar of lxpanel. This gives shutdown, reboot and logout options which work, but it is not a very neat solution and not one found within LXDE.
Title: Re: Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: M0E-lnx on September 23, 2009, 05:48:22 am
That is because you're not starting it correctly.
The LXDE environment includes lxde-session-lite which takes care of the logout dialog.

you should be doing something like startlxde -p LXDE
Title: Re: Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: Silent Music on September 23, 2009, 05:00:58 pm
Thanks for the suggestion, but I don't see how it can be that.
At the kdm login screen I choose an LXDE session. The first file to be read after login is /usr/share/apps/kdm/sessions/LXDE.desktop.
Here are the contents of my LXDE.desktop file:

Quote
[Desktop Entry]
Encoding=UTF-8
Type=Application
Exec=startlxde -p LXDE
Name=LXDE

So the next file to be read is /usr/bin/startlxde
Here are the contents of my startlxde file:

Quote
#!/bin/sh

if [ -z "$XDG_CONFIG_HOME" ]; then
    export XDG_CONFIG_HOME="$HOME/.config"
fi

# Ensure the existance of pcmanfm config file
PCMANFM_CONF_DIR="$XDG_CONFIG_HOME/pcmanfm"
if [ ! -f "$PCMANFM_CONF_DIR/main.lxde" ]; then
    mkdir -p "$PCMANFM_CONF_DIR"
    cp /usr/share/lxde/pcmanfm/main.lxde "$PCMANFM_CONF_DIR/main.lxde"
fi

# Ensure the existance of openbox config file
OPENBOX_CONF_DIR="$XDG_CONFIG_HOME/openbox"
if [ ! -f "$OPENBOX_CONF_DIR/lxde-rc.xml" ]; then
    mkdir -p "$OPENBOX_CONF_DIR"
    cp /usr/share/lxde/openbox/rc.xml "$OPENBOX_CONF_DIR/lxde-rc.xml"
fi

# Enable GTK+2 integration for OpenOffice.org, if available.
export SAL_USE_VCLPLUGIN=gtk

# Start the LXDE session
exec /usr/bin/lxsession -s LXDE


There is nothing out of order there, is there?
lxsession is a binary, so I can't touch that, but it should as you say take care of the logout dialogue - only it doesn't. For some reason, which I still can't fathom, the logout dialogue is truncated to the logout option only, instead of the 6 or 7 options that there should be.
I've swapped a new "lxsession" file over from Zenwalk Linux, where it works normally, but it doesn't correct this faulty behaviour in VLL.
Title: Re: Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: newt on September 23, 2009, 07:22:54 pm
I was having a similar problem last week in XFCE (logout was only option I could choose, others were grayed out). Turned out to be a group related issues - I had inadvertently removed my user from all groups but one. As soon as I put my user back into it's normal groups I was set.

Have a look at:
/etc/group
and make sure your user is in the groups it should be.

disk,lp,floppy,audio,video,cdrom,games,slocate,plugdev,scanner,users(,wheel)
Title: Re: Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: M0E-lnx on September 24, 2009, 05:38:02 am
Do you have lxsession installed?
Look at the very last line of the startlxde script.
Title: Re: Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: Silent Music on September 24, 2009, 02:18:53 pm
Yes, Newt, I am a member of all those groups you mention, I have checked /etc/group. It is not that the shutdown, reboot, switch user, hibernate, suspend, lock screen options are greyed out in my LXDE when I click the logout button, they are simply not there. Only the logout option is there, and reboot and shutdown have to be done in two stages - logout to the login and screen and then reboot or shutdown from there.

Yes, MOE. I have lxsession installed. Working in IceWM, I copied the lxsession file in Zenwalk Linux over to /usr/bin in VLL and then quarantined the lxsession-lite file installed on VLL, but it made no difference. The rest of LXDE works fine, there is just this niggling little problem.
Title: Re: Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: M0E-lnx on September 24, 2009, 02:20:04 pm
check out the docs for lxsession-lite
it needs HAL running
make sure HAL is running
Title: Re: Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: Silent Music on September 24, 2009, 04:35:55 pm
#modprobe hald
returns:
Module hald not found
so: presumably hal is not running. Which file do I have to edit, and how, go get the hal module loaded when VLL starts?
VASM is not showing up in the menu in LXDE, and under IceWM I cannot get the HAL daemon choice to stick.
Title: Re: Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: Silent Music on September 25, 2009, 05:28:27 am
CORRECTION
I realise that hald is not a kernel module, that is why the command # modprobe hald returned:
FATAL: module hald not found.
The correct command to see if hald is running should be:
# ps -A | grep hald
which should return several lines of text concerning hald, if hald is running, or:
# ps aux | grep hald
which returns several lines besides the grep call to hald
Using either of these commands in the terminal as root user show that hald is running.

I am wondering if this problem is caused by the fact that I am using kdm and not gdm as my login manager. Does LXDE work better with gdm?
Title: Re: Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: M0E-lnx on September 25, 2009, 05:39:39 am
lxsession uses either GDM or HAL whichever is available.
Title: Re: Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: Silent Music on September 25, 2009, 06:39:58 am
YESSSSSSS!!! Cracked it!!
I was using KDM as my login manager, and for some reason LXDE doesn't like that??!!
I changed my login manager to GDM and then clicking the Login button in the menu gave me all the options except HIBERNATE, but I can live with that, as I've never told a computer to hibernate in my life!!

In order to change your login manager to GDM from KDM, you should edit as root /etc/rc.d/rc.X    ## (note that is a capital letter X)
Find the line which says:
DISPLAY_MANAGER=KDM
change KDM to GDM
Save the /etc/rc.d/rc.X file and then reboot.
GDM is now the login manager, and changing from KDM to GDM solved my problem.

I shall now mark this thread as solved. I should like to thank all the other contributors to this thread for their helpful suggestions.
Title: Re: [SOLVED] Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: M0E-lnx on September 25, 2009, 06:47:28 am
Glad you got it working
Try slapt-get -i pm-utils and make sure your lilo is setup for resuming/suspending.
That should give you suspend/resume I think
I know they use HAL for a lot of that stuff too, but it's worth a shot.
Title: Re: [SOLVED] Problem getting LXDE to work with Vector Linux Light v 6.0
Post by: Silent Music on September 26, 2009, 01:43:54 am
Thanks, MOE for the suggestions.
LXDE on the Zenwalk drive has Shutdown, Reboot, Hibernate, Suspend, Switch User and Logout buttons when you click the Logout button in the Menu, and they all work.
LXDE on VectorLinux Light is missing the Hibernate button/option when you click the Menu's Logout button, and nothing happens when you click the Suspend button, although all the other buttons work.

You mean I should edit /etc/lilo.conf? Zenwalk uses lilo too. Comparing the /etc/lilo.conf file on both hard-drives, I see that Zenwalk's lilo.conf file has a line at the top which is missing in VLL's lilo.conf file:
append="resume=/dev/sda5 splash=silent "
/dev/sda5 is the "swap" partition on Zenwalk Linux. The swap partition on VLL is /dev/hdb6, so I added the line:
append="resume=/dev/hdb6 splash=silent "
to VLL's /etc/lilo.conf file, at the top, immediately under # Start LILO global section.

Unfortunately Suspend is still not working in VLL. What more must I do? This is a slightly academic question as far as I am concerned, as I rarely use the Suspend feature, but for the benefit of other VLL users who may be following this thread and would like to add LXDE as an option to their OS and get it running properly, as well increasing my own knowledge and understanding of Linux, I should like to know the answer.