VectorLinux

The nuts and bolts => Hardware & Drivers => Topic started by: JonnieR on October 16, 2009, 02:54:21 pm

Title: Sound not working
Post by: JonnieR on October 16, 2009, 02:54:21 pm
Hi,

So far I am very pleased with VL6.0 standard.  It got my wireless and webcam unlike some more well known distros, and it is quite speedy.

I have an ACER Aspire One which has a Realtek HD audio under Windows but when running Alsaconf it reports back as snd_hda_intel so I guess that must be the chipset built onboard.  It has worked on other distros with Pulseaudio, but I cannot get it to work with VL and Alsa.

A quick search of the forum didn't yield any eureka moments.  I have even reinstalled the alsa files int he package manager.  Things have got better as I can now get Alsamixer and Mixer to work, but still no sound.

cat /proc/asound/modules reports snd_hda_intel on device 0, but still no joy.

I have tried VLC, MPlayer and XMMS. All with an .m4a(aac) audio file.

Thanks,


Jon.
Title: **** SOLVED **** Re: Sound not working
Post by: JonnieR on October 20, 2009, 08:19:04 am
I now have sound!! ;D

Realtek have a linux driver for their HD Audio cards.

http://www.realtek.com.tw/downloads/downloadsCheck.aspx?Langid=1&PNid=14&PFid=24&Level=4&Conn=3&DownTypeID=3&GetDown=false

This link was playing up today when I tried again but who knows it may be their server playing up.

The driver is version 5.13 and is available for 2.4 amd 2.6 kernels.

Jon.
Title: Re: Sound not working
Post by: netgem on December 02, 2009, 12:12:25 pm
Hello Jon (or anyone else)
How do I install that realtek driver? I've downloaded it, what next? Please be gentle, I've only been using vector for 4 weeks. Have I got to write something in that scary looking terminal window thing?