VectorLinux

Vectorbie Station => Vectorbie Questions => Topic started by: 666lawyer on October 20, 2009, 04:55:38 am

Title: xforwarding
Post by: 666lawyer on October 20, 2009, 04:55:38 am
   
I tried configuring with ssh xforwarding as follows:

on the local machine: xhost +
on the remote machine: export DISPLAY = "10.1.37.52:0.0"

10.1.37.52 is the local ip and 0.0 is the display

Then I connect to the remote with:
ssh-X shiva@10.1.1.110

run xclock and then says:
I can not open display ?????. Any ideas
Title: Re: xforwarding [solved]
Post by: 666lawyer on October 20, 2009, 05:01:06 am
   
I tried configuring with ssh xforwarding as follows:

on the local machine: xhost +
on the remote machine: export DISPLAY = "10.1.37.52:0.0"

10.1.37.52 is the local ip and 0.0 is the display

Then I connect to the remote with:
ssh-X shiva@10.1.1.110

run xclock
Title: Re: xforwarding
Post by: hata_ph on October 20, 2009, 05:40:36 am
try this...

http://forum.vectorlinux.com/index.php?topic=7196.0
Title: Re: xforwarding
Post by: 666lawyer on October 22, 2009, 07:45:44 am
 I tried to run xhost + on the remote machine (vector linux) but says:
  xhost +
xhost: unable to open display ""

 ???


Title: Re: xforwarding
Post by: 666lawyer on November 03, 2009, 05:39:46 am
Do not export the DISPLAY varialble and no longer gives that error, but the remote machine  (vector linux) that I am from ubuntu using ssh-X shiva@10.1.1.113 run xclock and is done in the same in a process that is with ps-e, but if I run firefox & it runs on the local machine (Ubuntu) because I realize this is in Spanish and one in English. You seem to run randomly because sometimes running firefox from the remote. Any ideas ????. What am I doing wrong???
Title: Re: xforwarding
Post by: M0E-lnx on November 03, 2009, 05:54:47 am
All you need is to enable Xforwarding in your server's ssh config file

ON THE SERVER
/etc/ssh/sshd_config
Code: [Select]
#AllowTcpForwarding yes 
#X11Forwarding yes
#X11DisplayOffset 10     
#X11UseLocalhost yes     

Restart the ssh server

ON THE CLIENT
Code: [Select]
ssh -X -Y user@your.server.ip
That should be enough for what you need.
Title: Re: xforwarding [solved]
Post by: 666lawyer on November 03, 2009, 05:57:23 am
Its. works! thank ;D
Title: Re: xforwarding
Post by: 666lawyer on November 03, 2009, 07:07:57 am
   
continues to behave in a random ???
Title: Re: xforwarding
Post by: M0E-lnx on November 03, 2009, 08:10:30 am
On your client box, try executing xhost+ command
and then try the ssh connection.

if that solves it, your problem is at the client machine.
Title: Re: xforwarding
Post by: 666lawyer on November 03, 2009, 08:55:16 am
   

Not solve it, remains the same :(    
xlclock wonder what it runs on the server??
Title: Re: xforwarding
Post by: M0E-lnx on November 03, 2009, 09:02:01 am
xhost+ has to be ran as user, not root.
Title: Re: xforwarding
Post by: 666lawyer on November 03, 2009, 09:18:19 am
   
I ran it as user. But apparently the problem is in the ssh, if I run it like ssh-X-Y shiva@10.1.1.113 works (apparently) only if I run ssh-Y .... does not work.
Title: Re: xforwarding
Post by: M0E-lnx on November 03, 2009, 10:06:12 am
the -X flag tells it to forward X using X's auth. You need this.

see man ssh
Title: Re: xforwarding
Post by: 666lawyer on November 03, 2009, 10:11:06 am
Solved. Thank very much!!! ;D
Title: Re: xforwarding
Post by: 666lawyer on November 04, 2009, 03:58:46 am
even with ssh-X-Y shiva@10.1.1.113 and configuration and ssd_config sshd_config on the server, is still behaving randomly ????? (run the client firefox, not so the xclock or xcalc)


pd: leo muy poco ingles y no hay manuales en español, disculpen. ???
Title: Re: xforwarding
Post by: M0E-lnx on November 04, 2009, 06:38:57 am
Para probar, intentalo del otro modo.
Configura la maquina que estas usando ahora como cliente para servidor, y conectate desde la otra maquina.

Yo llevo mucho tiempo haciendo esto, y se que no necesitas mas.
Title: Re: xforwarding
Post by: 666lawyer on November 04, 2009, 09:13:22 am
configurando el cliente como servidor y conectando desde la otra maquina funciona correctamente, probe tambien nuevamente en la maquina cliente original y aparentemente ahora funciona correctamente, mañana confirmo. gracias
Title: Re: xforwarding
Post by: 666lawyer on November 06, 2009, 03:53:26 am
Probando Vector Linux como cliente y ubuntu como servidor funciona correctamente, no asi ubuntu como cliente y vector linux como servidor.  Alguna idea????
Title: Re: xforwarding
Post by: 666lawyer on November 06, 2009, 05:29:19 am
Probe vector linux como cliente y funciona correctamente, ubuntu como servidor.  a la inversa funciona en forma aleatoria?????