VectorLinux

The nuts and bolts => Hardware & Drivers => Topic started by: budulay on January 18, 2010, 01:40:13 pm

Title: [Finally working]GIGABYTE AirCruiser N300 GN-WS30N-RH wlan(Ralink rt2860)
Post by: budulay on January 18, 2010, 01:40:13 pm
Hi
Couple weeks ago I bought a new laptop, and put a Gigabyte ws30n wireless card in it, since oxfordtech.com said it is supported in linux.
Well, this card kept me busy for a week. I tried ndiswrapper(the win xp driver is caller rt2860 and could be downloaded from the Gigabyte website (http://www.gigabyte.de/Support/Communication/Driver_DownloadFile.aspx?FileType=Driver&FileID=4393)), without much luck. It kept freezing when trying to connect to my wireless router.

This card is based on Ralink RT2860 chipset, so I decided to try their drivers(version 2.2.0.0, could be downloaded from the Ralink website (http://www.ralinktech.com/support.php?s=2)). While they do have opensource drivers for this card, they are rather outdated and only compile with 2.6.29 kernels and older.

At this point I was almost ready to give up. Hovewer, I thought I would check maybe it would work in other distros. I installed ubuntu and sure enough the card worked out of the box. I was almost ready to cry.
It was using rt2860sta module. After comparing ubuntu and vector kernel config files I found that the staging drivers for this card were disabled in the VL kernel.


After that it was just a matter of enabling them:
Device Drivers ---> Staging Drivers --->uncheck Exclude stading drivers from being build
Device Drivers ---> Staging Drivers --->check Ralink 2860 wireless support

After compiling the kernel, the module loaded without problems and the card worked flawlessly ever since. :D



Note:
I also run into a problem with wicd - it was stuck on "Obtaining IP Adress" and not connecting to my 2wire at&t router
What solved it is changing WEP(Passphrase) to WEP(HEX) in the advanced settings.


Second Note:
lspci output for the card:
Code: [Select]
03:00.0 Network controller: RaLink Unknown device 0681