VectorLinux

The nuts and bolts => Hardware & Drivers => Topic started by: Thera on July 16, 2010, 12:09:48 am

Title: Belkin F6D4050 v1 (RT2870 drivers) Wireless
Post by: Thera on July 16, 2010, 12:09:48 am
Hello,i have one problem with this driver in VL. When i want to use Xp drivers in Ndiswrapper it do this:

Code: [Select]
elektron:/~
root:# cd XP_2K
elektron:/~/XP_2K
root:# ndiswrapper
install/manage Windows drivers for ndiswrapper

usage: ndiswrapper OPTION
-i inffile       install driver described by 'inffile'
-a devid driver  use installed 'driver' for 'devid' (dangerous)
-r driver        remove 'driver'
-l               list installed drivers
-m               write configuration for modprobe
-ma              write module alias configuration for all devices
-mi              write module install configuration for all devices
-v               report version information

where 'devid' is either PCIID or USBID of the form XXXX:XXXX,
as reported by 'lspci -n' or 'lsusb' for the card
elektron:/~/XP_2K
root:# ndiswrapper -i rt2870.inf
installing rt2870 ...
elektron:/~/XP_2K
root:# ndiswrapper -l
rt2870 : driver installed
device (050D:935A) present
elektron:/~/XP_2K
root:# ndiswrapper -m
adding "alias wlan0 ndiswrapper" to /etc/modprobe.d/ndiswrapper ...
elektron:/~/XP_2K
root:# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

elektron:/~/XP_2K
root:# ifconfig wlan0 up
wlan0: ERROR while getting interface flags: No such device
elektron:/~/XP_2K
root:#
 
What im doing wrong?
PS:And sorry for my english..
Title: Re: Belkin F6D4050 v1 (RT2870 drivers) Wireless
Post by: bigpaws on July 16, 2010, 04:15:20 am
Did you use modprobe for ndiswrapper?

The command is (As root):

modprobe ndiswrapper

Did you check to see for ndiswrapper using lsmod?

Bigpaws
Title: Re: Belkin F6D4050 v1 (RT2870 drivers) Wireless
Post by: nightflier on July 16, 2010, 04:52:23 am
I managed to get a similar chipset working using native drivers. This may be of help:
http://forum.vectorlinux.com/index.php?topic=11843
Title: Re: Belkin F6D4050 v1 (RT2870 drivers) Wireless
Post by: M0E-lnx on July 16, 2010, 07:50:37 am
You may also need firmware
Title: Re: Belkin F6D4050 v1 (RT2870 drivers) Wireless
Post by: Thera on July 17, 2010, 02:36:45 am
Did you use modprobe for ndiswrapper?

The command is (As root):

modprobe ndiswrapper

Yes
Code: [Select]
root:# ndiswrapper -m
adding "alias wlan0 ndiswrapper" to /etc/modprobe.d/ndiswrapper ...

Did you check to see for ndiswrapper using lsmod?
Code: [Select]
root:# lsmod
Module                  Size  Used by

ndiswrapper           185500  0
Title: Re: Belkin F6D4050 v1 (RT2870 drivers) Wireless
Post by: Thera on July 17, 2010, 02:41:39 am
You may also need firmware

When i use drivers and firmware from Ralink:

Code: [Select]
elektron:/~/LINUXSTA/os/linux
root:# insmod rt2870sta.ko
elektron:/~/LINUXSTA/os/linux
root:# ifconfig ra0 up   
ra0: ERROR while getting interface flags: No such device

Why i still cant bring up the interface?..
Title: Re: Belkin F6D4050 v1 (RT2870 drivers) Wireless
Post by: Thera on July 17, 2010, 02:45:47 am
And maybe this can help..Dmesg output
Code: [Select]
sda: sda1
sd 2:0:0:0: [sda] Attached SCSI removable disk
sd 2:0:0:0: Attached scsi generic sg0 type 0
usb-storage: device scan complete
usb 1-1: USB disconnect, address 3
usb 1-1: new full speed USB device using uhci_hcd and address 4
usb 1-1: configuration #1 chosen from 1 choice
usb 1-1: reset full speed USB device using uhci_hcd and address 4
ndiswrapper (import:242): unknown symbol: ntoskrnl.exe:'MmGetSystemRoutineAddress'
ndiswrapper (load_sys_files:206): couldn't prepare driver 'rt2870'
ndiswrapper (load_wrap_driver:108): couldn't load driver rt2870; check system log for messages from 'loadndisdriver'
Title: Re: Belkin F6D4050 v1 (RT2870 drivers) Wireless
Post by: bigpaws on July 17, 2010, 06:47:38 am
There is kernel support for this Wireless chipset from kernel
version 2.6.30.5.

If you have this kernel you probably do not need ndisdwrapper
which may be having a conflict.

Check uname -r

Bigpaws
Title: Re: Belkin F6D4050 v1 (RT2870 drivers) Wireless
Post by: Thera on July 18, 2010, 07:33:21 am
There is kernel support for this Wireless chipset from kernel
version 2.6.30.5.

If you have this kernel you probably do not need ndisdwrapper
which may be having a conflict.

Check uname -r

Bigpaws

Code: [Select]
root:# uname -r
2.6.27.12
Title: Re: Belkin F6D4050 v1 (RT2870 drivers) Wireless
Post by: bigpaws on July 18, 2010, 09:34:54 am
Please post the output of lsmod


Bigpaws
Title: Re: Belkin F6D4050 v1 (RT2870 drivers) Wireless
Post by: Thera on July 20, 2010, 05:26:38 am
Please post the output of lsmod


Code: [Select]
LSMOD Output:

root:# lsmod
Module                  Size  Used by
radeon                141472  0
drm                    70824  1 radeon
ndiswrapper           185500  0
lp                     10372  0
snd_seq_dummy           3716  0
snd_seq_oss            31872  0
snd_seq_midi_event      6912  1 snd_seq_oss
snd_seq                48368  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          7436  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            37408  0
snd_mixer_oss          15104  1 snd_pcm_oss
speedstep_lib           4740  0
acpi_cpufreq            7948  0
freq_table              4352  1 acpi_cpufreq
8139too                23936  0
snd_intel8x0           29980  2
mii                     5376  1 8139too
snd_ac97_codec         99492  1 snd_intel8x0
rtc_cmos               10144  0
rtc_core               15132  1 rtc_cmos
ac97_bus                2432  1 snd_ac97_codec
rtc_lib                 3328  1 rtc_core
snd_pcm                67972  3 snd_pcm_oss,snd_intel8x0,snd_ac97_codec
snd_timer              19976  2 snd_seq,snd_pcm
serio_raw               6020  0
snd                    51492  14 snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
soundcore               7008  1 snd
snd_page_alloc          8840  2 snd_intel8x0,snd_pcm
shpchp                 29716  0
iTCO_wdt               10916  0
pci_hotplug            27040  1 shpchp
parport_pc             35908  1
irda                  108984  0
parport                31724  2 lp,parport_pc
crc_ccitt               2688  1 irda
video                  17040  0
output                  3456  1 video
asus_laptop            16376  0
led_class               4484  1 asus_laptop
joydev                 10048  0
evdev                  10144  7
Title: Re: Belkin F6D4050 v1 (RT2870 drivers) Wireless
Post by: Thera on July 20, 2010, 08:40:00 am
heh,i have one idea...

maybe when i will reinstall VectorLinux and install newest kernel for VL (kernel-2.6.31.8 from http://vectorlinux.osuosl.org/veclinux-6.0/kernels/)...maybe it can solve my problem?...
Title: Re: Belkin F6D4050 v1 (RT2870 drivers) Wireless
Post by: nightflier on July 20, 2010, 12:35:20 pm
Kernel 2.6.31.8 does not have the modules included. Did you try using the native drivers as I mentioned in my post above?
Title: Re: Belkin F6D4050 v1 (RT2870 drivers) Wireless
Post by: Thera on July 21, 2010, 08:12:43 am
Kernel 2.6.31.8 does not have the modules included. Did you try using the native drivers as I mentioned in my post above?

Yes,i followed the instructions correctly but i still dont see any wlan0 or ra0 in iwconfig output and i cant still cant bring up the interface...
Title: Re: Belkin F6D4050 v1 (RT2870 drivers) Wireless
Post by: nightflier on July 21, 2010, 10:07:53 am
If you installed the native drivers plus ndiswrapper, that would probably lead to a conflict.
Try some manual troubleshooting; as root, in a terminal:
Code: [Select]
modprobe -r ndiswrapper
modprobe -r rt2800usb
modprobe rt2870sta
VLwifi
Title: Re: Belkin F6D4050 v1 (RT2870 drivers) Wireless
Post by: Thera on July 22, 2010, 12:38:00 am
If you installed the native drivers plus ndiswrapper, that would probably lead to a conflict.
Try some manual troubleshooting; as root, in a terminal:
Code: [Select]
modprobe -r ndiswrapper
modprobe -r rt2800usb
modprobe rt2870sta
VLwifi

Dont work...:(

Code: [Select]
root:# VLwifi
cat: /etc/wifi-radar/wifi-radar.conf: No such file or directory
cp: cannot stat `/etc/wifi-radar/wifi-radar.conf': No such file or directory
2010-07-22 09:18:40: ERROR: Could not find Intel PRO/Wireless 3945ABG Network Connection
Invalid parameter 1: -.

Then vlwifi ask me that i want to use xp drivers in ndiswrapper...cancel...no wireless cards found..
Title: Re: Belkin F6D4050 v1 (RT2870 drivers) Wireless
Post by: Thera on July 22, 2010, 12:46:28 am
Last night i tried Xubuntu it runs a bit slower that VL ...and i found this post about my belkin..i followed the instructions and my wifi works http://ubuntuforums.org/showthread.php?t=1509403 (post #2)

But Xubuntu is very slow on my 128mb ram computer so i decided to install VL again...

And what about new VL 7.0 core alpha it have rt2870 modules and drivers?..