VectorLinux

The nuts and bolts => Networking & Security => Topic started by: hyperfreak on September 14, 2010, 02:43:59 pm

Title: Setting up an internet conection.|Problem|
Post by: hyperfreak on September 14, 2010, 02:43:59 pm
Everything was fine but when it come the part to get internet access it gone bad...I have adsl modem the model model is DSL-360R.This is how i create a internet access in windows.I open con.panel go to network conections and there is a local area conection icon.Right click/properties the select Internet protocol(TCP/IP) and click install i enter thoose numbers(given by my net provider) Ip address: 192.168.1.2 and etc...(If you need the other numbers i will tell you.).
Then i create a new conection.I use a manual login i have username like
myusername@mt.net.mk and password like 2003.I need to get internet on my linux.I aredy called the support of my operator but thoose noobs said they dont support linux and the man was kindly and said somethink about drivers and said to try somethink with spconfig or somethink like that i dont remember all i know it didnt worked.That is it i tell you all i know and i hope that u can help me and tell me how to create a new conection.Did i need to download some drivers if yes where to find them try to help me as simple as posilible since iam noob at this.
I tryed my self to enter hostname,dns server and etc but it doesnt work :(
Everytime i open the browser i get error and cant open any page :(
Here how it looks like in win.
(http://pic.mk/images/untitl1284501700.jpg)
I used the same numbers for linux and still cant get it working.
If you know anythink that could help, please post it because most of the time ian online and i aredy exploired and tested everythink on Vector Linux, i realy need to set up the conection :)
~Thanks

Title: Re: Setting up an internet conection.|Problem|
Post by: hata_ph on September 14, 2010, 05:24:21 pm
First, make your VL can recognize your network card...
go to terminal and run below command as root and show us the output
Quote
ifconfig
ifconfig -a
lsmod

PS: What version of VL you are using?
Title: Re: Setting up an internet conection.|Problem|
Post by: hyperfreak on September 15, 2010, 02:59:42 am
Code: [Select]
You are working as root
Frequently used programs:
Configuration  : vasm
Package manager: slapt-get, pkg
Network tools  : ifconfig, host, ping, nmap, iptables
File manager   : mc (press F2 for useful menu)
Editor         : mcedit, nano, vi
Multimedia     : alsamixer, play
localuser:root being added to access control list
cikasna:/~
root:# ifconfig
lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

cikasna:/~
root:# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:16:17:9c:f2:2e 
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:3540 (3.4 KiB)
          Interrupt:23 Base address:0xe000

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

cikasna:/~
root:# lsmod
Module                  Size  Used by
snd_seq_dummy           3716  0
snd_seq_oss            31872  0
snd_seq_midi_event      6912  1 snd_seq_oss
snd_seq                48368  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_pcm_oss            37408  1
snd_mixer_oss          15104  1 snd_pcm_oss
p4_clockmod             4900  0
speedstep_lib           4740  1 p4_clockmod
freq_table              4352  1 p4_clockmod
fuse                   53788  2
snd_via82xx            23576  3
rtc_cmos               10144  0
gameport               11020  1 snd_via82xx
rtc_core               15132  1 rtc_cmos
snd_ac97_codec         99492  1 snd_via82xx
rtc_lib                 3328  1 rtc_core
ac97_bus                2432  1 snd_ac97_codec
snd_pcm                67972  3 snd_pcm_oss,snd_via82xx,snd_ac97_codec
snd_timer              19976  2 snd_seq,snd_pcm
snd_page_alloc          8840  2 snd_via82xx,snd_pcm
snd_mpu401_uart         7680  1 snd_via82xx
snd_rawmidi            19872  1 snd_mpu401_uart
via_rhine              21768  0
snd_seq_device          7436  4 snd_seq_dummy,snd_seq_oss,snd_seq,snd_rawmidi
mii                     5376  1 via_rhine
snd                    51492  16 snd_seq_dummy,snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_via82xx,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore               7008  2 snd
i2c_viapro              8340  0
i2c_core               21268  1 i2c_viapro
shpchp                 29716  0
pci_hotplug            27040  1 shpchp
via_agp                 8832  1
parport_pc             35908  0
parport                31724  1 parport_pc
evdev                  10144  4
cikasna:/~
root:#
That is what i got.I recently had a problem with my boot menu so i re-formated my partritions, this time i wont touch anythink on my self and will waith for your answer.
About  version i use Vector Linux 6.0 Standard Final version :)
Title: Re: Setting up an internet conection.|Problem|
Post by: toothandnail on September 15, 2010, 05:34:20 pm
<snip>
I used the same numbers for linux and still cant get it working.
If you know anythink that could help, please post it because most of the time ian online and i aredy exploired and tested everythink on Vector Linux, i realy need to set up the conection :)
~Thanks



When you say you used the same numbers for Linux, how did you use them? Where did you enter them?

Also, can you run '/sbin/lspci' from a command prompt and paste the results. From the ifconfig output you provided, it looks as though Linux is seeing your ethernet card, but there is no information as to what driver is being used for the hardware - that may also help.

I can't find any technical information on the Dlink DSL-360R. Is it a modem, or a router? Also, how does it connect to your PC?

Paul.


Title: Re: Setting up an internet conection.|Problem|
Post by: nightflier on September 16, 2010, 05:16:08 am
I think your ethernet module is "via_rhine". It should work.
First try the easy way: VASM. In a terminal, use commands:
Code: [Select]
su
<password>
vasm > network > netconf

While you're there, look around and familiarize yourself with all the options.

Alternative approach, configure it manually. In a terminal, use the following commands (you can copy each line, then copy into your terminal with key combination Shift-Insert):
Code: [Select]
su
<password>
ifconfig eth0 down
ifconfig eth0 192.168.1.2 netmask 255.255.255.0 up
route add default gw 192.168.1.1
echo "nameserver 62.162.32.5" > /etc/resolv.conf
If only manual works, you can make the settings permanent by changing config files, let us know.
Title: Re: Setting up an internet conection.|Problem|
Post by: hyperfreak on September 16, 2010, 11:05:15 am
I also cant find details about the modem.Yes its modem.So far i know it used only at my country.It is very simular to the 360T but i read some on the web that i cant configure it :(
I googled a little and foun this info>
Code: [Select]
To set up the modem:

1.

Open Applications → Accessories → Terminal
2.

In the terminal type:

sudo pppoeconf

3.

A text-based menu program will guide you through the next steps, which are:

1. Confirm that your Ethernet card is detected.
2. Enter your username.
3. Enter your password.
4. If you already have a PPPoE Connection configured, you will be asked if it may be modified.
5. Popular options: you are asked if you want the “noauth” and “defaultroute” options and to remove “nodetach” - choose Yes.
6. Use peer DNS - choose Yes.
7. Limited MSS problem - choose Yes.
8. When you are asked if you want to connect at start up, you will probably want to say yes.
9. Finally you are asked if you want to establish the connection immediately.


4.

Once you have finished these steps, your connection should be working.

To start your ADSL connection on demand, in a terminal type:

sudo pon dsl-provider

To stop your ADSL connection, in a terminal type:

sudo poff dsl-provider
I will try to configure it and if doesnt work i will paste what i will get from the /sbin/lspci command :)
Title: Re: Setting up an internet conection.|Problem|
Post by: hyperfreak on September 16, 2010, 11:34:25 am
Code: [Select]
hyperfreak:$ /sbin/lspci
00:00.0 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. PT890 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.7 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
00:0f.0 IDE interface: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [KT600/K8T800/K8T890 South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)
01:00.0 VGA compatible controller: VIA Technologies, Inc. UniChrome Pro IGP (rev 01)
That is what i got.I tryed the tut that i found on the web but it is not working :(
Anyway i tryed the command but iam wrong or it foesnt work.I copy the commands and i get this(Manual instail):







Code: [Select]
You are working as root
Frequently used programs:
Configuration  : vasm
Package manager: slapt-get, pkg
Network tools  : ifconfig, host, ping, nmap, iptables
File manager   : mc (press F2 for useful menu)
Editor         : mcedit, nano, vi
Multimedia     : alsamixer, play
localuser:root being added to access control list
mt:/~
root:# <password>
bash: syntax error near unexpected token `newline'
mt:/~
root:# ifconfig eth0 down
mt:/~
root:# ifconfig eth0 192.168.1.2 netmask 255.255.255.0 up
mt:/~
root:# route add default gw 192.168.1.1
mt:/~
root:# echo "nameserver 62.162.32.5" > /etc/resolv.con
:( And again, no internet :(
Title: Re: Setting up an internet conection.|Problem|
Post by: newt on September 16, 2010, 01:10:52 pm
Your last line (in the quote box) says:
root:# echo "nameserver 62.162.32.5" > /etc/resolv.con

This command adds the nameserver to the resolve configuration file.  The filename you specified (/etc/resolv.con) is not correct. It should be "/etc/resolv.conf" - you missed the 'f' at the end of the name in your previous attempt.

Overall, it sounds like your problem should be fairly easy to resolve. It's just a matter of going through the steps and once it's be set up correctly it generally stays that way.

EDIT:
One last observation that may not be relevant. I noticed that in your screenshot it show 192.162.1.xxx and the instructions provided by nightflier are to set up your network card to 192.168.1.x.  I typically see what nightflier has suggested (168) but perhaps the unusual number (162) is somehow important?
Title: Re: Setting up an internet conection.|Problem|
Post by: nightflier on September 16, 2010, 06:58:40 pm
Good eyes, newt. I didn't look closely enough at his screenshot.
192.162.x.x is registered to "RIPE Network Coordination Centre" in Amsterdam .. it is a real network.

When I said <password>, that did not mean for you to type that literally. The idea was to first issue command "su", and then give your root password when it was asked for.

Now, if you have an ADSL modem that requires PPPoE, that changes things. Did you have to install any additional software to use it under Windows?
Title: Re: Setting up an internet conection.|Problem|
Post by: hyperfreak on September 17, 2010, 02:12:49 am
I dont have to instail any other software under windows.
 I will try to corect the numbers and see what will happen.
Will say what i had done soon :)
Title: Re: Setting up an internet conection.|Problem|
Post by: hyperfreak on September 17, 2010, 03:03:15 am
Code: [Select]
You are working as root
Frequently used programs:
Configuration  : vasm
Package manager: slapt-get, pkg
Network tools  : ifconfig, host, ping, nmap, iptables
File manager   : mc (press F2 for useful menu)
Editor         : mcedit, nano, vi
Multimedia     : alsamixer, play
localuser:root being added to access control list
mt:/~
root:# su
You are working as root
Frequently used programs:
Configuration  : vasm
Package manager: slapt-get, pkg
Network tools  : ifconfig, host, ping, nmap, iptables
File manager   : mc (press F2 for useful menu)
Editor         : mcedit, nano, vi
Multimedia     : alsamixer, play
localuser:root being added to access control list
mt:/~
root:# <password>
bash: syntax error near unexpected token `newline'
mt:/~
root:# ifconfig eth0 down
mt:/~
root:# ifconfig eth0 192.168.1.2 netmask 255.255.255.0 up
mt:/~
root:# route add default gw 192.162.1.1
SIOCADDRT: Network is unreachable
mt:/~
root:# echo "nameserver 62.162.32.5" > /etc/resolv.conf
Ok, i think i entered it ok now but still somethink makes me a problem.
I asked my isp provider for link/adress where i can find details about my modem but i didnt get answer from them.They just said its basic modem and somethink that i dont know how to translate to englich :(
it  seems that modem have no configurable features at all.The moden is  D-LINK DSL-360R but when i search i only see topic from forums where people have problem with it.
Does the thing that everytime when i need to connect i have to double click on the desktop icon(in win.) makes some problem?Or its that that i have bad modem and nothink works :(
Title: Re: Setting up an internet conection.|Problem|
Post by: hata_ph on September 17, 2010, 04:36:36 am
1. Use VASM to configure static IP to your VL system.

Quote
su
<password>
vasm > network > netconf

2. Restart and run ifconfig as root in terminal. Give us the output. If it still show lo only, type ifconfig eth0 up, type ifconfig again and show us the output again. Once it show eth0 with your static IP. Try to ping out to internet, try to ping 202.188.0.133 (my ISP DNS).
Title: Re: Setting up an internet conection.|Problem|
Post by: nightflier on September 17, 2010, 05:29:26 am
Code: [Select]
root:# <password>
bash: syntax error near unexpected token `newline'

The error shows that you typed "<password>" literally. The intent is for you to wait for the prompt that requests the root password, type it in (nothing will show on the screen), then press Enter. However, your printout shows you working as root, so you must be using the Root Terminal launcher, in which case you don't need to use su.

If you have to double-click on a desktop icon in Windows to connect, that tells me this is not a regular ethernet connection with dhcp. My guess is PPPoE. When in Windows, try to right-click this desktop icon, select "Properties", then click the button for "Find Target". What do you see highlighted?

Title: Re: Setting up an internet conection.|Problem|
Post by: hyperfreak on September 17, 2010, 10:38:05 am
It shows me the icon, my created conection.To be more clear there are 2 icons, first is Local Area Conection and second is ADSl(Same as desktop icon:)Under the name(adsl) it show: Conected,Firewalled,WANminiport,PPPOE
Hope this helps :)
Edit: Should i do what hata_ph or to waith for answer?I will waith for answer, if i need to do it (again) tell me i will do it.And yes i use root user coz i know that i can do anythin kwith it.Normal account has limits so that is why i log in as root when i make changes :)
Title: Re: Setting up an internet conection.|Problem|
Post by: newt on September 17, 2010, 04:05:58 pm
Edit: Should i do what hata_ph or to waith for answer?I will waith for answer, if i need to do it (again) tell me i will do it.And yes i use root user coz i know that i can do anythin kwith it.Normal account has limits so that is why i log in as root when i make changes :)

No. What hata_ph suggests is for router-type internet scenario. You situation requires PPPOE which means you will need to use a different utility to establish your internet connection (i.e. a dialer of sorts).  I don't recall which one is included in VL6Std but you will probably find it listed in the main menu (start menu) under network - some kind of dialer perhaps with ppoe in the name.
Title: Re: Setting up an internet conection.|Problem|
Post by: hyperfreak on September 18, 2010, 01:21:34 pm
yes yes... :)
I aredy tryed( i think) that.First i set up the domains and then i didnt saw where i can enter username and password so then i looked in the options and i saw what you are saying about.The vl wasnt able to reconaise my modem so i selected dialphone or somethink simular(not sure how it was writen) coz i have internet throught my phone(not mobile phone).I was asked to set up ip adress i wasnt sure what i should write so left the default setting, entered my username,password and all other what i was asked for.I tryed that first and it didnt worked.That is why i asked here for help :(
Title: Re: Setting up an internet conection.|Problem|
Post by: hata_ph on September 18, 2010, 04:58:29 pm
I do want to make myself clear is, do you need to type username and password when you make connection in windows? If no, then my method is correct. If yes, I believe you need a pppoe dialer app to make the connection.

You mention your adsl modem is dsl-360r, what brand is that?

Is this your modem?

http://forum.cafemontenegro.com/showthread.php?t=52932

for pppoe setting in vl

6.5.5. MODEM

Purpose: Utility for configuring a dial-up connection to an ISP. You need to know a number of things about your ISP (phone number, authentication method, etc.) and your modem (device, baud rate, init string, etc.)

Command Line: /sbin/vmodemset

Walk Through: If you select this menu item, you will be given a list of serial ports. Select the port where your modem is attached. The ports included are those used by a Linmodem, but this script does not install or setup these modems. If you know what COM device it was under Windows, you can select the listed equivalent. Otherwise, you can try the autodetect or you might have to do some experimenting. The best course is to start at ttyS0 and work your way down the list.

Next you will be asked for the user name and password for your ISP's connection for PPP dialers such as X-ISP. You can skip this if you are using GkDial or KPPP, which you will have to configure yourself.
Title: Re: Setting up an internet conection.|Problem|
Post by: nightflier on September 19, 2010, 07:13:12 am
VL comes with the rp-pppoe "Roaring Penguin" package for managing these kinds of connections. Anyone used that one?
Title: Re: Setting up an internet conection.|Problem|
Post by: hata_ph on September 19, 2010, 08:04:50 am
If your modem is a router adsl modem, there is a webui to manage pppoe connection
Title: Re: Setting up an internet conection.|Problem|
Post by: hyperfreak on September 19, 2010, 01:13:18 pm
This modem has no webui if it has a webui it whoukd be very very easy to set up conection.In windows when i connect my username and password is aredy written pic:
(http://pic.mk/images/untitl1284928147.jpg)
Anyway how i should know whitch is he port  where my modem is attached?
How i should know what COM device it was under Windows?
Autodetect doesnt work, i aredy tryed that.
How i should know did i use GkDial or KPPP or somethink other?
I know too much questions, but this is my first time trying to configure internet cionection under linux and it is all new to me.
Title: Re: Setting up an internet conection.|Problem|
Post by: hata_ph on September 19, 2010, 05:59:13 pm
Can you find chestnut dialer in your VL? Try using that :)
Title: Re: Setting up an internet conection.|Problem|
Post by: bigpaws on September 19, 2010, 06:20:40 pm
Chestnut dialer is a front end for pppoe

Open a terminal as root and type:

pppoe-setup

Answer the questions.

Here is a link to get things going. I browsed the article and all seems good.

http://wiki.foresightlinux.org/display/docs/PPPOE+Configuration (http://wiki.foresightlinux.org/display/docs/PPPOE+Configuration)

HTH

Bigpaws
Title: Re: Setting up an internet conection.|Problem|
Post by: hyperfreak on September 20, 2010, 12:15:50 pm
Code: [Select]
You are working as root
Frequently used programs:
Configuration  : vasm
Package manager: slapt-get, pkg
Network tools  : ifconfig, host, ping, nmap, iptables
File manager   : mc (press F2 for useful menu)
Editor         : mcedit, nano, vi
Multimedia     : alsamixer, play
localuser:root being added to access control list
mt:/~
root:# pppoe-setup
Welcome to the Roaring Penguin PPPoE client setup.  First, I will run
some checks on your system to make sure the PPPoE client is installed
properly...

Looks good!  Now, please enter some information:

USER NAME

>>> Enter your PPPoE user name (default cikasna@mt.net.mk): cikasna@mt.net.mk

INTERFACE

>>> Enter the Ethernet interface connected to the DSL modem
For Solaris, this is likely to be something like /dev/hme0.
For Linux, it will be ethn, where 'n' is a number.
(default eth0): dev/modem

Do you want the link to come up on demand, or stay up continuously?
If you want it to come up on demand, enter the idle time in seconds
after which the link should be dropped.  If you want the link to
stay up permanently, enter 'no' (two letters, lower-case.)
NOTE: Demand-activated links do not interact well with dynamic IP
addresses.  You may have some problems with demand-activated links.
>>> Enter the demand value (default 50): no

DNS

Please enter the IP address of your ISP's primary DNS server.
If your ISP claims that 'the server will provide DNS addresses',
enter 'server' (all lower-case) here.
If you just press enter, I will assume you know what you are
doing and not modify your DNS setup.
>>> Enter the DNS information here: 62.162.32.5
Please enter the IP address of your ISP's secondary DNS server.
If you just press enter, I will assume there is only one DNS server.
>>> Enter the secondary DNS server address here: 62.162.32.6

PASSWORD

>>> Please enter your PPPoE password:   
>>> Please re-enter your PPPoE password:

FIREWALLING

Please choose the firewall rules to use.  Note that these rules are
very basic.  You are strongly encouraged to use a more sophisticated
firewall setup; however, these will provide basic security.  If you
are running any servers on your machine, you must choose 'NONE' and
set up firewalling yourself.  Otherwise, the firewall rules will deny
access to all standard servers like Web, e-mail, ftp, etc.  If you
are using SSH, the rules will block outgoing SSH connections which
allocate a privileged source port.

The firewall choices are:
0 - NONE: This script will not set any firewall rules.  You are responsible
          for ensuring the security of your machine.  You are STRONGLY
          recommended to use some kind of firewall rules.
1 - STANDALONE: Appropriate for a basic stand-alone web-surfing workstation
2 - MASQUERADE: Appropriate for a machine acting as an Internet gateway
                for a LAN
>>> Choose a type of firewall (0-2): 0

** Summary of what you entered **

Ethernet Interface: dev/modem
User name:          cikasna@mt.net.mk
Activate-on-demand: No
Primary DNS:        62.162.32.5
Secondary DNS:      62.162.32.6
Firewalling:        NONE

>>> Accept these settings and adjust configuration files (y/n)? y
Adjusting /etc/ppp/pppoe.conf
Adjusting /etc/resolv.conf
  (But first backing it up to /etc/resolv.conf-bak)
Adjusting /etc/ppp/pap-secrets and /etc/ppp/chap-secrets
  (But first backing it up to /etc/ppp/pap-secrets-bak)
  (But first backing it up to /etc/ppp/chap-secrets-bak)



Congratulations, it should be all set up!

Type 'pppoe-start' to bring up your PPPoE link and 'pppoe-stop' to bring
it down.  Type 'pppoe-status' to see the link status.
mt:/~
root:# pppoe-start
................TIMED OUT
/usr/sbin/pppoe-start: line 191:  4081 Terminated              $CONNECT "$@" >/dev/null 2>&1
mt:/~
root:#

I think i made somethink wrong with
INTERFACE
Code: [Select]
>>> Enter the Ethernet interface connected to the DSL modem
For Solaris, this is likely to be something like /dev/hme0.
For Linux, it will be ethn, where 'n' is a number.
(default eth0): dev/modem
Is dev/modem right locaction?If not how i can find the right locaction?What i should enter there?
Title: Re: Setting up an internet conection.|Problem|
Post by: newt on September 20, 2010, 01:01:52 pm
If your DLink DSL modem is plugged into your computers network card then you entered the incorrect interface. It should be 'eth0' without the quotes and using the number zero.
Title: Re: Setting up an internet conection.|Problem|
Post by: hyperfreak on September 21, 2010, 02:19:13 am
Code: [Select]
mt:/~
root:# pppoe-setup
Welcome to the Roaring Penguin PPPoE client setup.  First, I will run
some checks on your system to make sure the PPPoE client is installed
properly...

Looks good!  Now, please enter some information:

USER NAME

>>> Enter your PPPoE user name (default cikasna@mt.net.mk): cikasna@mt.net.mk

INTERFACE

>>> Enter the Ethernet interface connected to the DSL modem
For Solaris, this is likely to be something like /dev/hme0.
For Linux, it will be ethn, where 'n' is a number.
(default eth0): eth0

Do you want the link to come up on demand, or stay up continuously?
If you want it to come up on demand, enter the idle time in seconds
after which the link should be dropped.  If you want the link to
stay up permanently, enter 'no' (two letters, lower-case.)
NOTE: Demand-activated links do not interact well with dynamic IP
addresses.  You may have some problems with demand-activated links.
>>> Enter the demand value (default no): no

DNS

Please enter the IP address of your ISP's primary DNS server.
If your ISP claims that 'the server will provide DNS addresses',
enter 'server' (all lower-case) here.
If you just press enter, I will assume you know what you are
doing and not modify your DNS setup.
>>> Enter the DNS information here: 62.162.32.5
Please enter the IP address of your ISP's secondary DNS server.
If you just press enter, I will assume there is only one DNS server.
>>> Enter the secondary DNS server address here: 62.162.32.6

PASSWORD

>>> Please enter your PPPoE password:   
>>> Please re-enter your PPPoE password:

FIREWALLING

Please choose the firewall rules to use.  Note that these rules are
very basic.  You are strongly encouraged to use a more sophisticated
firewall setup; however, these will provide basic security.  If you
are running any servers on your machine, you must choose 'NONE' and
set up firewalling yourself.  Otherwise, the firewall rules will deny
access to all standard servers like Web, e-mail, ftp, etc.  If you
are using SSH, the rules will block outgoing SSH connections which
allocate a privileged source port.

The firewall choices are:
0 - NONE: This script will not set any firewall rules.  You are responsible
          for ensuring the security of your machine.  You are STRONGLY
          recommended to use some kind of firewall rules.
1 - STANDALONE: Appropriate for a basic stand-alone web-surfing workstation
2 - MASQUERADE: Appropriate for a machine acting as an Internet gateway
                for a LAN
>>> Choose a type of firewall (0-2): 0

** Summary of what you entered **

Ethernet Interface: eth0
User name:          cikasna@mt.net.mk
Activate-on-demand: No
Primary DNS:        62.162.32.5
Secondary DNS:      62.162.32.6
Firewalling:        NONE

>>> Accept these settings and adjust configuration files (y/n)? y
Adjusting /etc/ppp/pppoe.conf
Adjusting /etc/resolv.conf
  (But first backing it up to /etc/resolv.conf-bak)
Adjusting /etc/ppp/pap-secrets and /etc/ppp/chap-secrets
  (But first backing it up to /etc/ppp/pap-secrets-bak)
  (But first backing it up to /etc/ppp/chap-secrets-bak)



Congratulations, it should be all set up!

Type 'pppoe-start' to bring up your PPPoE link and 'pppoe-stop' to bring
it down.  Type 'pppoe-status' to see the link status.
mt:/~
root:# pppoe-start
. Connected!
mt:/~
root:# pppoe-status
pppoe-status: Link is up and running on interface ppp0
ppp0      Link encap:Point-to-Point Protocol 
          inet addr:77.29.208.214  P-t-P:77.29.200.1  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:7 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:582 (582.0 B)  TX bytes:37 (37.0 B)

mt:/~
root:#
I open opera and try to open google.mk and google.com and it doesnt open :( Trying the same in mozzila its the same again :( i checked that muabe i work offline but its fine, browser says i dont work offline :(
Anyidea what could be the problem?
Title: Re: Setting up an internet conection.|Problem|
Post by: bigpaws on September 21, 2010, 03:08:13 am
First make sure that your pppoe connection is up.

As root type:

ifconfig pppoe

If that does not exist then type:

pppoe-start

Check ifconfig again.

Now that a link is established, let's test for DNS

ping -c 3 yahoo.com

If response you are online and good to go.

Should there be no response to the ping the try this:

ping -c 3 69.147.125.65

If there is a response then DNS is not working or there is no
connection. You could also try pinging your DNS server as
well.

Bigpaws
Title: Re: Setting up an internet conection.|Problem|
Post by: hyperfreak on September 22, 2010, 11:41:17 am
It gives me error somethink device is not found :( First i try it says conected i try ifconf and it gives me error, i try to ping yahoo with yahoo.com domain it says no host yahoo.com found.I try the ipadress and it sends but doesnt get reply and it has 100% loss :(
Title: Re: Setting up an internet conection.|Problem|
Post by: hata_ph on September 22, 2010, 05:20:35 pm
Can you capture the error message?
Title: Re: Setting up an internet conection.|Problem|
Post by: hyperfreak on September 25, 2010, 01:27:45 pm
Code: [Select]
You are working as root
Frequently used programs:
Configuration  : vasm
Package manager: slapt-get, pkg
Network tools  : ifconfig, host, ping, nmap, iptables
File manager   : mc (press F2 for useful menu)
Editor         : mcedit, nano, vi
Multimedia     : alsamixer, play
localuser:root being added to access control list
mt:/~
root:# ifconfig pppoe
pppoe: error fetching interface information: Device not found
mt:/~
root:# pppoe-start
.
 Connected!
mt:/~
root:#
mt:/~
root:# ifconfig pppoe
pppoe: error fetching interface information: Device not found
mt:/~
root:# ping -c 3 yahoo.com
ping: unknown host yahoo.com
mt:/~
root:# ping -c 3 69.147.125.65
PING 69.147.125.65 (69.147.125.65) 56(84) bytes of data.
ping: sendmsg: Operation not permitted
ping: sendmsg: Operation not permitted
ping: sendmsg: Operation not permitted

--- 69.147.125.65 ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 1999ms

mt:/~
root:#
Hope that will help :)
~Sorry for late reply :(
Title: Re: Setting up an internet conection.|Problem|
Post by: hyperfreak on September 27, 2010, 02:55:26 pm
aaaAaa anyone?
Title: Re: Setting up an internet conection.|Problem|
Post by: newt on September 27, 2010, 03:58:41 pm
First, I need to state that I've never dealt with pppoe connections in linux ever before. The last time I had a pppoe connection was before I knew what linux was.

However, there are a couple things we can try.

1) I'd like to see what your 'ifconfig -a' looks like after a fresh reboot.

2) Next, I'd like to see what your 'ifconfig -a' looks like after you've attempted to start the pppoe interface (i.e. pppoe-start).

3) The output from your routing table before and after would also be nice (route -n)

What I'm thinking is that perhaps you are ending up with what your system sees as two possible network connections (e.g. eth0 and pppoe) and your system is attempting to use the more common eth0 connection. It may also just be a routing issue.

Last, perhaps changing the subject line of your original to something more specific will gain the attention of someone who has a similar internet connection as your. A subject like "Help setting up PPPOE internet connection" would probably help others quickly identify the specific help needed.