VectorLinux

The nuts and bolts => Web & Internet => Topic started by: Siggy on December 18, 2010, 09:37:26 pm

Title: Newbie - Wireless Wont Hookup
Post by: Siggy on December 18, 2010, 09:37:26 pm
I took a HP laptop with bad hard drive, installed new hard drive & loaded Vector Linux 6.0 Standard.  The system will located my wireless but I can't get it to hook up to it.  Have internet no problem when hard wired.   I find the wireless, enter the password but it either searches for ever - no hook up or just flashes & no hook up.  I have tried every wep password, 1/2 password, no luck.  Can someone give me an idea what it happening?

Sig
Title: Re: Newbie - Wireless Wont Hookup
Post by: bigpaws on December 18, 2010, 11:37:14 pm
What is the make model and version number of your
wireless card?

Are you using encryption for your router?

If so have you tried a connection without encryption
to see if the card is working?

Bigpaws
Title: Re: Newbie - Wireless Wont Hookup
Post by: Siggy on December 19, 2010, 09:54:31 am
Can you help on how I find the make model of the wireless card, I am new to VL, In windows xp I can find it but can't seem to find the area in VL that shows my hardware.  I have not tried taking the incriprion out of the wireless router. The wireless card does find the router's name when I search for wireless in the area.   I do appreciate the assistance
Title: Re: Newbie - Wireless Wont Hookup
Post by: newt on December 19, 2010, 10:19:28 am
The output from these commands would be useful. Generally these are entered in a terminal/shell, and you may need to be root (administrator) for many of the commands:

ifconfig -a
iwconfig
lspci
lsusb
lsmod
Title: Re: Newbie - Wireless Wont Hookup
Post by: Siggy on December 19, 2010, 03:05:09 pm
so I go to a terminal, it will not recognize any of those commands. So logged into VASMCC as administrator, brought up terminal, still none of the commands were recognized.  It is also funny, I type the commands, see nothing being typed until hit enter, then they show up -

Vector:/~
siggy:$ ifconfig-a
bash: ifconfig-a: command not found
Vector:/~
siggy:$ ifconfig -a
bash: ifconfig: command not found
Vector:/~
siggy:$ Ispci
bash: Ispci: command not found
Vector:/~
siggy:$ iwconfig
bash: iwconfig: command not found
Vector:/~
siggy:$ Isusb
bash: Isusb: command not found
Vector:/~
siggy:$ Ismod
bash: Ismod: command not found
Vector:/~


cant get the $ to go away either.
Title: Re: Newbie - Wireless Wont Hookup
Post by: Siggy on December 19, 2010, 03:41:34 pm
ok, so finally got to this with 1smod

siggy:$ lsmod
Module                  Size  Used by
rfkill_input            5376  0
snd_seq_dummy           3716  0
snd_seq_oss            31872  0
snd_seq_midi_event      6912  1 snd_seq_oss
snd_seq                48368  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          7436  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            37408  0
snd_mixer_oss          15104  1 snd_pcm_oss
p4_clockmod             4900  1
speedstep_lib           4740  1 p4_clockmod
freq_table              4352  1 p4_clockmod
arc4                    2688  2
ecb                     3584  2
crypto_blkcipher       16516  1 ecb
cryptomgr               3712  0
b43                   116764  0
rfkill                  8984  3 rfkill_input,b43
mac80211              155548  1 b43
cfg80211               23688  1 mac80211
led_class               4484  1 b43
input_polldev           4232  1 b43
rtc_cmos               10144  0
snd_atiixp             16524  2
rtc_core               15132  1 rtc_cmos
rtc_lib                 3328  1 rtc_core
8139too                23936  0
snd_ac97_codec         99492  1 snd_atiixp
ssb                    29956  1 b43
mii                     5376  1 8139too
ac97_bus                2432  1 snd_ac97_codec
snd_pcm                67972  3 snd_pcm_oss,snd_atiixp,snd_ac97_codec
snd_timer              19976  2 snd_seq,snd_pcm
snd                    51492  14 snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_atiixp,snd_ac97_codec,snd_pcm,snd_timer
soundcore               7008  1 snd
snd_page_alloc          8840  2 snd_atiixp,snd_pcm
serio_raw               6020  0
i2c_piix4               8592  0
i2c_core               21268  1 i2c_piix4
parport_pc             35908  0
parport                31724  1 parport_pc
video                  17040  0
output                  3456  1 video
wmi                     6568  0
shpchp                 29716  0
pci_hotplug            27040  1 shpchp
ati_agp                 7564  1
joydev                 10048  0
evdev                  1014
Title: Re: Newbie - Wireless Wont Hookup
Post by: newt on December 19, 2010, 04:10:14 pm
Looks like you have a broadcom chipset wireless device as indicated by the 'b43' module being loaded, however this does not guarantee anything. We will still the output from the previously mentioned commands.  Try this:

-Open a terminal
-type 'su'
-hit ENTER
-enter your root/administrator password when prompted
-then enter the commands I mentioned earlier and post the output here

Let us know if you continue to have troubles.
Title: Re: Newbie - Wireless Wont Hookup
Post by: GrannyGeek on December 19, 2010, 04:21:01 pm
Before you run the commands in a terminal, do
su
Then type in your root password.

The prompt should now indicate you are running as root, like this:
root:#

Now type each command and report the results. When you're finished, type
exit
at the prompt to return to being user.

You have to run ifconfig and iwconfig as root. DON'T log in as root. Simply do su and your root password to become root and exit back to user as soon as you finish your root business.

You can run lsmod as user. You can run the other two as user like this:
/sbin/lspci
/sbin/lsusb

The commands won't be found if you omit /sbin before the commands. I suggested running them all as root because they will all work just by typing the name.

If I understand what you did with VASMCC, I think you may be confused. Running VASMCC as superuser does not give you root privileges for anything else. It's just for running VASMCC. When you open a terminal, you will be opening it as user. Do the su thing above and work as root for the commands you run in the terminal until you exit back to user or close the terminal.
--GrannyGeek
Title: Re: Newbie - Wireless Wont Hookup
Post by: Siggy on December 19, 2010, 04:31:00 pm
I found your posted How to Recipes. that is where I go to the above.  But can't get it to do any of the other commands. Went to VASM to try to get to hardware but when VASM comes up it only gives : PASSWD Change password, XWMSET setup default manager, SKEL reset default settings, SUPER run super VSAM (root password needed) EXIT bye, see you later.  Nothing as a menu to Hardware --to get to HWCONF.  Also the password though checked to save never does.  So may be showing my No knowlege of what is going on, but figure that is the only way I am going to learn. 
Title: Re: Newbie - Wireless Wont Hookup
Post by: Siggy on December 19, 2010, 04:39:46 pm
So I can't get my root password to work. IS there a way to change it?
Title: Re: Newbie - Wireless Wont Hookup
Post by: Siggy on December 19, 2010, 04:46:00 pm
finally it took the root password.will post shortly
Title: Re: Newbie - Wireless Wont Hookup
Post by: Siggy on December 19, 2010, 04:47:26 pm
Vector://home/siggy
root:# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:0f:b0:40:00:e3 
          inet addr:192.168.2.103  Bcast:192.168.2.255  Mask:255.255.255.0
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4064 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4647 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1786282 (1.7 MiB)  TX bytes:1183837 (1.1 MiB)
          Interrupt:19 Base address:0xa000

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:100 (100.0 B)  TX bytes:100 (100.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:90:4b:99:f6:b3 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wmaster0  Link encap:UNSPEC  HWaddr 00-90-4B-99-F6-B3-00-00-00-00-00-00-00-00-00-00 
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:
Title: Re: Newbie - Wireless Wont Hookup
Post by: Siggy on December 19, 2010, 04:48:29 pm
Vector://home/siggy
root:# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:"FRONTIER" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Tx-Power=27 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B   
          Encryption key:5AAB-7F5D-A2   Security mode:open
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Title: Re: Newbie - Wireless Wont Hookup
Post by: Siggy on December 19, 2010, 04:49:29 pm
Vector://home/siggy
root:# lspci
00:00.0 Host bridge: ATI Technologies Inc Radeon 9100 IGP Host Bridge (rev 02)
00:01.0 PCI bridge: ATI Technologies Inc Radeon 9100 IGP AGP Bridge
00:13.0 USB Controller: ATI Technologies Inc OHCI USB Controller #1 (rev 01)
00:13.1 USB Controller: ATI Technologies Inc OHCI USB Controller #2 (rev 01)
00:14.0 SMBus: ATI Technologies Inc SMBus (rev 16)
00:14.1 IDE interface: ATI Technologies Inc Dual Channel Bus Master PCI IDE Controller
00:14.3 ISA bridge: ATI Technologies Inc Unknown device 434c
00:14.4 PCI bridge: ATI Technologies Inc IXP200 3COM 3C920B Ethernet Controller
00:14.5 Multimedia audio controller: ATI Technologies Inc IXP150 AC'97 Audio Controller
00:14.6 Modem: ATI Technologies Inc IXP AC'97 Modem (rev 01)
01:05.0 VGA compatible controller: ATI Technologies Inc RS300M AGP [Radeon Mobility 9100IGP]
02:02.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)
02:03.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:04.0 CardBus bridge: Texas Instruments PCI1520 PC card Cardbus Controller (rev 01)
02:04.1 CardBus bridge: Texas Instruments PCI1520 PC card Cardbus Controller (rev 01)
02:07.0 USB Controller: NEC Corporation USB (rev 43)
02:07.1 USB Controller: NEC Corporation USB (rev 43)
02:07.2 USB Controller: NEC Corporation USB 2.0 (rev 04)
Vector://home/siggy
Title: Re: Newbie - Wireless Wont Hookup
Post by: Siggy on December 19, 2010, 04:50:20 pm
Vector://home/siggy
root:# lsusb
Bus 004 Device 002: ID 046e:556e Behavior Tech. Computer Corp.
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Vector://home/siggy
root:#
Title: Re: Newbie - Wireless Wont Hookup
Post by: Siggy on December 19, 2010, 04:51:19 pm
Vector://home/siggy
root:# lsmod
Module                  Size  Used by
rfkill_input            5376  0
snd_seq_dummy           3716  0
snd_seq_oss            31872  0
snd_seq_midi_event      6912  1 snd_seq_oss
snd_seq                48368  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          7436  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            37408  0
snd_mixer_oss          15104  1 snd_pcm_oss
p4_clockmod             4900  1
speedstep_lib           4740  1 p4_clockmod
freq_table              4352  1 p4_clockmod
arc4                    2688  2
ecb                     3584  2
crypto_blkcipher       16516  1 ecb
cryptomgr               3712  0
b43                   116764  0
rfkill                  8984  3 rfkill_input,b43
mac80211              155548  1 b43
cfg80211               23688  1 mac80211
led_class               4484  1 b43
input_polldev           4232  1 b43
rtc_cmos               10144  0
snd_atiixp             16524  2
rtc_core               15132  1 rtc_cmos
rtc_lib                 3328  1 rtc_core
8139too                23936  0
snd_ac97_codec         99492  1 snd_atiixp
ssb                    29956  1 b43
mii                     5376  1 8139too
ac97_bus                2432  1 snd_ac97_codec
snd_pcm                67972  3 snd_pcm_oss,snd_atiixp,snd_ac97_codec
snd_timer              19976  2 snd_seq,snd_pcm
snd                    51492  14 snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_atiixp,snd_ac97_codec,snd_pcm,snd_timer
soundcore               7008  1 snd
snd_page_alloc          8840  2 snd_atiixp,snd_pcm
serio_raw               6020  0
i2c_piix4               8592  0
i2c_core               21268  1 i2c_piix4
parport_pc             35908  0
parport                31724  1 parport_pc
video                  17040  0
output                  3456  1 video
wmi                     6568  0
shpchp                 29716  0
pci_hotplug            27040  1 shpchp
ati_agp                 7564  1
joydev                 10048  0
evdev                  10144  7
Vector://home/s
Title: Re: Newbie - Wireless Wont Hookup
Post by: Siggy on December 19, 2010, 05:00:09 pm
so is the ethernet card?

00:14.4 PCI bridge: ATI Technologies Inc IXP200 3COM 3C920B Ethernet Controller
Title: Re: Newbie - Wireless Wont Hookup
Post by: Siggy on December 19, 2010, 05:55:47 pm

So is this the wirless card?

02:02.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)
Title: Re: Newbie - Wireless Wont Hookup
Post by: Siggy on December 19, 2010, 06:10:36 pm
So is this on the right track?

http://linuxwireless.org/en/users/Drivers/b43

Title: Re: Newbie - Wireless Wont Hookup
Post by: bigpaws on December 19, 2010, 06:15:36 pm
02:02.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)
02:03.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

These are you ethernet cards. The modules (drivers) are loaded.

Did you setup the encryption keys for the wireless network in VASM? Or perhaps easier
double click on the computers in the lower left hand corner. That should open up the
area to setup the encryption.

FRONTIER is your essid as in Frontier commnuications?

Big
Title: Re: Newbie - Wireless Wont Hookup
Post by: bigpaws on December 19, 2010, 06:16:43 pm
Quote
So is this on the right track?

http://linuxwireless.org/en/users/Drivers/b43

No it is not.

Your firmware (which is what that article is doing) is already installed
in Vector Linux.

Bigpaws
Title: Re: Newbie - Wireless Wont Hookup
Post by: Siggy on December 19, 2010, 06:26:51 pm
Frontier is the name of my business. So it evidently has FRONIER left in it from before the hard drive crashed & I put the new hard drive in. I don't have 2 computer screens in the lower left corner of the task bar.  I have desktop & Monitor screen which is the terminal.  The wirless router does not have FRONTIER in it anywhere.
Title: Re: Newbie - Wireless Wont Hookup
Post by: Siggy on December 19, 2010, 06:31:37 pm
Ok I have 2 screens on the right side if double clicked brings up Wicd Manager I didn't set up any password or encrypton keys in VSAM
Title: Re: Newbie - Wireless Wont Hookup
Post by: Siggy on December 19, 2010, 06:37:04 pm
ok logged in to root, then typed VASM so now brought up the screen with auto set up, user,xwindow, service,network, hardware,filesystem, exit.  So do I need to go in there to check for something or add/change something?
Title: Re: Newbie - Wireless Wont Hookup
Post by: bigpaws on December 19, 2010, 06:41:18 pm
SEE NOTE

According to this:

Quote
Personal Message (Online)
   
   
Re: Newbie - Wireless Wont Hookup
« Reply #12 on: Today at 07:48:29 pm »
   Reply with quoteQuote
Vector://home/siggy
root:# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:"FRONTIER"  

Your ESSID was set as FRONTIER or you entered it.

Open a terminal and then type su, now enter the root
password.

That will log you in as root.

Now typ: wicd-client

That should open up a window where you ca configure your
wireless settings. Also not that the properties box is where you
can enter the essid and encryption type.

NOTE you can enter the information under the network section if you
do not use the above.

Bigpaws
Title: Re: Newbie - Wireless Wont Hookup
Post by: Siggy on December 19, 2010, 07:33:55 pm
So you will have to take this horse to water,  I always able to open Wicd Manager, that is what opened when I did as posted.  However what is it I need to change.  I typed the IEEE 802.11bg in & then took back out.  Before it would regonize the wireless in the area, now it finds none, even though I changed it back. Now got it back to where it recognizes.  Sorry but where in preferences do I change what.  I have WPA supplicant drivrer:  ndiswrapper  wireless interface: wlan0   wired interface: eth0, checked boxes are always show wired interface, always reconnect on disconnect, enable debug mode, use dbmode to measure signal strength.

Under advanced use encryption --- wep Shared/restricted & have the password for the router (which is not FRONTIER) do we need to change the FRONTIER out of this wireless card?  I have nothing in the scripts.
Title: Re: Newbie - Wireless Wont Hookup
Post by: bigpaws on December 19, 2010, 07:58:21 pm
Why are you using ndiswrapper? Is that something you installed?

This will create a conflict for the wireless card.

Quote
Now got it back to where it recognizes.

recognizes what?

Are you able to see the essid of the rotuer?

Bigpaws
Title: Re: Newbie - Wireless Wont Hookup
Post by: Siggy on December 19, 2010, 08:06:44 pm
ndiswrapper is in the preferences of wicd manager, others in the drop down menu are wext, hostap, madwifi, atmel, ipw, ralink legacy. Nothing I installed.

As far as recognized, was  seeing all the wireless networks in the area. I cannot see the essid of the router.  I don't see FRONTIER on anything I look at.
Title: Re: Newbie - Wireless Wont Hookup
Post by: bigpaws on December 19, 2010, 08:11:28 pm
wext is what you should be using,

Then scan for networks.

After that if your router shows up then in the Properties
button is where you out the wpa settings.

Bigpaws
Title: Re: Newbie - Wireless Wont Hookup
Post by: Siggy on December 19, 2010, 08:41:47 pm
OK, finally.  I changed Preferences to wext.  then refreshed, when my wireless showed up went to advanced settings, I checked box "Use these settings for all networks sharing these essid  & checked box "use encrypton",  then used WPA 1/2 passphrase (not WEP passphrase) & HOLY Crap it hooked up. 

Now I must admit I went to VASM through Terminal / us/password for root# then VASM to autodetect dhcp. Don't know if that helped any. 

Bigpaws I certainly appreciate your patience & assistance.  Seemed like a round the pa pa patch, but I understand we had to make sure it was all installed.  You have been patient with a Newbie.  Thanks again

Siggy
Title: Re: Newbie - Wireless Wont Hookup
Post by: Siggy on December 19, 2010, 09:03:30 pm
Also since all your help the VASM Control Panel now populates with all the icon, where before it did not. So using just the VASM (red screwdriver icon on task bar) found Network & Wireless which then shows the essid & passphrase all the questions you had asked.

So for some reason not all the VASM was loaded in the system.   I also learned a lot in reference to terminal commands.

Again I thank you for the assistance.

Sig
Title: Re: Newbie - Wireless Wont Hookup (SOLVED)
Post by: Siggy on December 19, 2010, 09:05:01 pm
Thanks for the help   ;D
Title: Re: Newbie - Wireless Wont Hookup
Post by: bigpaws on December 19, 2010, 09:05:54 pm
You have it running?

Bigpaws
Title: Re: Newbie - Wireless Wont Hookup
Post by: Siggy on December 19, 2010, 09:11:07 pm
Yes sir, it hooks up great.