VectorLinux

Cooking up the Treats => Distro development => Topic started by: pierce.jason on April 04, 2011, 05:39:08 pm

Title: [VL7] Few packages need dependency changes.
Post by: pierce.jason on April 04, 2011, 05:39:08 pm
xine-ui 0.99.6-i586-1vl70 should list xine-lib as a dep.

xine-lib 1.1.19-i586-2vl70 has a listed dependency of "ffmpeg >= 20090725". In the repo there is only ffmpeg 0.6-i586-1vl70. xine-lib works fine with version 0.6. I recommend removing the ">= 20090725" part and depending only on "ffmpeg".

google-chrome 04042011-i586-1vl should list ORBit2 as a dep.

Title: Re: [VL7] Few packages need dependency changes.
Post by: stretchedthin on April 04, 2011, 06:59:59 pm
hi pierce.jason

I've corrected as suggested the dependencies on xine-lib and google-chrome.

As far as I can see xine-ui does list xine-lib as a dependency already. 

Bet some users didn't even know google-chrome was available, I never announced that I had packaged it yet, as still need to tweek the slack-desc.
But to those who want to try it out please do.

You probably won't see above changed take effect for about an hour.
stretch'
Title: Re: [VL7] Few packages need dependency changes.
Post by: pierce.jason on April 04, 2011, 08:26:46 pm
Aaaaaah, sorry about that stretchedthin. I see my mistake there now :P

xine-ui wanted a different aalib than I had available so I --ignore-dep'd it. And it therefore didn't install the other deps either.

xine-ui was wanting "aalib >= 1.4.0" and all I could find in repos was "aalib 1.4rc5".
Title: Re: [VL7] Few packages need dependency changes.
Post by: stretchedthin on April 04, 2011, 08:48:20 pm
Aaaaaah, sorry about that stretchedthin. I see my mistake there now :P

xine-ui wanted a different aalib than I had available so I --ignore-dep'd it. And it therefore didn't install the other deps either.

xine-ui was wanting "aalib >= 1.4.0" and all I could find in repos was "aalib 1.4rc5".

OK, I'll tend to that.
Got a question for you, being the arch guru like you are.  I tried to use the abs system to build libreoffice, but get stuck when building openjdk6.  I was wondering if you wouldn't mind taking a look.
Title: Re: [VL7] Few packages need dependency changes.
Post by: pierce.jason on April 04, 2011, 09:51:18 pm
Would
I tried to use the abs system to build libreoffice, but get stuck when building openjdk6. 

Willing to bet money that you can use sun java jdk or any other 1.6 jdk. But sure, I'll take a peek and see what I do see.
Title: Re: [VL7] Few packages need dependency changes.
Post by: pierce.jason on April 04, 2011, 09:57:22 pm
Couldn't get vasm to run inside X, from minimal install. Through strace's I found out I was missing Xdialog. Well duh, I should have thought of that right off the bat!

There's trouble installing xdialog though. It is looking for "gtk2" as a dependency. Of course gtk2 is in the repositories, but it is listed as "gtk+2".

In addition to xdialog, there is galculator with the same issue. I haven't actually tried installing galculator, but I did a grep of the package_data and this is the only other package I found that depends on "gtk2".
Title: Re: [VL7] Few packages need dependency changes.
Post by: uelsk8s on April 04, 2011, 10:00:40 pm
I built libreoffice here from abs a while back and I had to build all of these
Code: [Select]
apache-ant/
beanshell/
cppunit/
fastjar/
graphite/
hdf5/
hsqldb-java/
java-sun/
junit/
libreoffice/
lpsolve/
lucene/
rasqal/
redland/
unixodbc/
vigra/

I have all the pkgs if you want them, let me know
Title: Re: [VL7] Few packages need dependency changes.
Post by: stretchedthin on April 05, 2011, 11:24:06 am
I built libreoffice here from abs a while back and I had to build all of these
Code: [Select]
apache-ant/
beanshell/
cppunit/
fastjar/
graphite/
hdf5/
hsqldb-java/
java-sun/
junit/
libreoffice/
lpsolve/
lucene/
rasqal/
redland/
unixodbc/
vigra/

I have all the pkgs if you want them, let me know
Crap :P
Title: Re: [VL7] Few packages need dependency changes.
Post by: JM on June 11, 2012, 07:53:27 pm
Aaaaaah, sorry about that stretchedthin. I see my mistake there now :P

xine-ui wanted a different aalib than I had available so I --ignore-dep'd it. And it therefore didn't install the other deps either.

xine-ui was wanting "aalib >= 1.4.0" and all I could find in repos was "aalib 1.4rc5".
¿How to solve this problem? Xine-ui dont work in a fresh installation of Vector Soho 7.0
Thanks.
Title: Re: [VL7] Few packages need dependency changes.
Post by: stretchedthin on June 11, 2012, 10:35:58 pm

Looks like you are right. 
This just might be my problem to solve.
I've got  aalib >= 1.4.0 to put in extra in the repo to satify dep.

Update gslapt, or slapt-get (whichever your preference) then..
Let me know if it works for you now.
Title: Re: [VL7] Few packages need dependency changes.
Post by: JM on June 12, 2012, 06:51:14 am

Looks like you are right. 
This just might be my problem to solve.
I've got  aalib >= 1.4.0 to put in extra in the repo to satify dep.

Update gslapt, or slapt-get (whichever your preference) then..
Let me know if it works for you now.
Updated aalib to 1.4.0 with Gslapt and reinstalled xine-ui, but xine-libs ask for a missing dep. "ffmpeg 20090725" . Xine still dont work (unsuported codec...etc)
Thank you very much for your help.
Title: Re: [VL7] Few packages need dependency changes.
Post by: stretchedthin on June 12, 2012, 08:13:37 am
That's another find.  Can I ask if you did a modified install. You are installing a number of things that would have been installed by default with Std or Soho.
Just want to do the same on my testing virtual machine, so I can recreate the situation you are in.
Title: Re: [VL7] Few packages need dependency changes.
Post by: JM on June 12, 2012, 11:01:41 am
No, not a modified install - Soho 7.0, fresh and full install + "Ati catalyst propietary drivers 12.4" and "Kradio4 from slack 13.37" (gnomeradio dont work anymore whit v4l2). But xine dont work before the new video driver and kradio4.
Thank you very much for your help
Title: Re: [VL7] Few packages need dependency changes.
Post by: JM on June 21, 2012, 05:28:11 pm
¿Can you tell me if "/usr/lib/codecs" is the wright route for Xine in Vector Soho 7?
Thank you very much for your help

Title: Re: [VL7] Few packages need dependency changes.
Post by: stretchedthin on June 21, 2012, 10:51:08 pm
Could you give me the link to kradio4 that you installed.  Just want to test it.

I've down two virtualbox installs of vectorlinux 7.0 soho and xine works everytime.  Only if I uninstall xine and it's components first can I duplicate the trouble you had during the reinstalling of xine.  A new xine-ui and xine-lib is in testing and will be moved soon to extra repository, if you want to try it out.
Title: Re: [VL7] Few packages need dependency changes.
Post by: JM on June 22, 2012, 01:02:42 pm
Link to Kradio4:
Code: [Select]
http://www.slacky.eu/asche/pkgs/index.php?ver=15&pkg=1126I'll try the new packages.
The partition where I installed Soho 7 is EXT3 with inode size: 128 (detected as EXT2)formatted with gparted. ·"/home" is ext3 - not formatted-
Previous S.O installed in the partition "/": Slackware 13.11 and Vector 7 Gold. Maybe some settings or files were not deleted during formatting.
I checked the md5 of both CDs of Soho.
Excuse my Tarzan English.
Thank you very much for your help.
Title: Re: [VL7] Few packages need dependency changes.
Post by: JM on June 22, 2012, 02:31:38 pm
Upgraded packages to : Xine-lib 1.2.1-i586-2vl70 and xine-ui 0.99.7-i586-3vl70, but dont work, xine ask for: "libavutil.so.50: cannot open shared object file: No such file or directory". Then: "ln -s /usr/lib/libavutil.so.51 /usr/lib/libavutil.so.50" . Run xine again and: " /usr/lib/libavutil.so.50: version `LIBAVUTIL_50' not found (required by /usr/lib/libxine.so.2)"
Thank you very much for your help.

Title: Re: [VL7] Few packages need dependency changes.
Post by: Pita on June 22, 2012, 08:46:08 pm
After reading these posts I tested xine in my new VL7-SOHO install and it runs flawlessly on first try.
No hick-ups whatsoever.
I have now a brand new mobo with 2.8 GHz duo processor, 500 GB SATA drive and 2 GB Ram card.
No idea what to do with all those Giga-Gigantic powers. ;)