The nuts and bolts => Networking & Security => Topic started by: seaken on September 04, 2011, 02:05:13 pm

Title: VL6 wireless and HP Mini 110-3735DX
Post by: seaken on September 04, 2011, 02:05:13 pm
I'm disappointed. I thought I could figure this out. After all I have managed to tinker and get VL working several times before. But it seems that Linux is still too confusing for me and I continue to struggle to find the right places to put things and I get lost and wonder if I have made too many errors or messed up a critical setting.

Once again I am attempting an install of VL, this time version 6 Standard. I have this new HP Mini 110-3735DX netbook which comes with Win7 Starter pre-installed. I was hoping I could install a Linux OS and since VL has always been my favorite I decided to attempt installing VL6. I have also tried Kubuntu and Mint since the Ubuntu varieties seem to be popular on these machines. I have had some success with all of these but none of these distros has worked with the wireless or wired network interfaces. So, I decided I would try to get VL6 working since I had some experience with this distro in the past.

Here's what I have done so far.

The equipment is coming up as a Realtek RTL8101E using lspci -nn with a code of 10ec:8136 for the ethernet and 8176 for the wireless. Windows see's it as a RTL8188CE.

I attempted to use NDISWRAPPER to install the windows XP driver. The driver loaded but I could not get a connection using VASM.

I found a driver direct from Realtek named r8192ce_pci and I used the MAKE and INSTALL commands to install it.

I removed the Ndiswrapper driver I had previously installed and I rebooted.

I used lsmod and I have the r8169 and the r8192ce_pci modules loaded. In modprobe.conf I have:
alias eth0 r8169
alias wlan0 r8192ce_pci

I actually had success for a few minutes and I was surfing the internet. I used a static IP address and was connected to the internet through my router. At this point I had both the wired and wireless interfaces connected. I decided to shut down and unplug the wired ethernet connection since I want the wireless working so I can roam from location to location.

As of now, I cannot get the wireless interface to work. I am now so confused I am coming here for help and hopefully someone can help me clear my head.

I thought maybe it had something to do with using the tag "wlan0" instead of "eth1". NDISWRAPPER used the wlan0 tag when it installed the windows driver. After I changed the driver to the Realtek driver I had the same tag but it was now aliased to the new driver module.

I have tried changing settings in the VASM several times. I can't select any "inet" interfaces except eth0 or wlan0. When I used VLwifi it says it see's the wlan0 interface and says "let's set it up". In the end it says no wireless interface.

I just wish this was easier. I don't mind learning and sometimes I like digging deep. This is not a critical system so I can afford to risk failure. But I am floundering. I have read so much about modules, /etc, lsmod, ifconfig, VLwifi, VASM, and more and more. I am so
confused I don't know what to do next. I think I am close. But the confusion is blocking me from making progress.

What is the relationship of the alias entries in modprobe.conf and the inet settings in VASM? What could be blocking the success of the VASM settings? Why does VLwifi seem to find and want to use "wlan0" but then cannot find an interface?

What files is VASM supposed to be changing? Can I manually open these files and make the changes needed?

Title: Re: VL6 wireless and HP Mini 110-3735DX
Post by: seaken on September 05, 2011, 08:06:28 am
I tried Mint and Kubuntu again and I was able to get the wireless working on each distro by simply using the default network manager in each.

I checked the drivers being used using lsmod and saw the following modules loaded

rtl8192ce, rtlwifi, mac80211, cfg80211

I figured this was due to a newer kernel than is used in VL6.

So, I tried installing VL7RC2 which uses the newer kernel. After I got it installed I checked the modules using lsmod. All the same modules are installed in VL7 as are installed with Mint and Kubuntu.

But,when using WiCD I could not connect the wireless.

I tried using VASM to set up the wireless. I again got a notice that wlan0 was found and it proceeded to set it up. But when allis done I cannot connect to the wireless.

I tried to check modprobe.conf but cannot find it. Things have changed in VL7 and things are not in the same place.

I don't know what to do next.

I guess VL is still not for me. A shame.

Title: Re: VL6 wireless and HP Mini 110-3735DX
Post by: bigpaws on September 05, 2011, 10:54:11 am
Have you checked ifconfig to see what interfaces are available.

Test after the modules are loaded. Also modprobe.conf is deprecated and
is now being done by udev.

Note: You will need to be root to do this, It would be my bet that you
were still using eth0 after you got the wireless running.

Title: Re: VL6 wireless and HP Mini 110-3735DX
Post by: nightflier on September 06, 2011, 05:52:52 am
Also check wicd > preferences to make sure wlan0 is listed as your wireless interface.
Title: Re: VL6 wireless and HP Mini 110-3735DX
Post by: seaken on September 11, 2011, 05:53:01 pm
Thank you for the suggestions. I will report back and let you know what happens.

I've been doing some research and experiments. I have installed three other distros that just work. Two have the 2.6.38 kernel and one uses the 2.6.34 kernel but has a package in their repos that installs the drivers this HP netbook requires.

The distros that worked were Kubuntu, Mint LXDE, and Smeegol (openSUSE 11.3). I am experimenting with others also. I don't like any of them as much as Vector and I was hoping I could get Vector working since it is my preferred system and I already have experience with it. But it seems Vector does not yet play nicely with this hardware.

Interestingly, I attempted to add XFCE to my Mint LXDE install as a second desktop environment. It loads fine but it will not recognize my wireless connection. The module is loaded and ifconfig shows the wlan0 interface. But I can't get it to connect. This is the same experience I am having in Vector. When I go back to a LXDE session in Mint the wireless comes right up, automatically.

So, there is something with XFCE that I haven't figured out yet. Something to do with a network manager I suspect. So far I have settled on using the Mint LXDE software and am using it now to make this forum entry. Sure would be nice if I could figure this  XFCE thing out though so I could go back to Vector.

I'll give it another try after a while. Got to get some work done first.