VectorLinux

Cooking up the Treats => Distro development => Topic started by: uelsk8s on October 17, 2011, 03:51:14 pm

Title: VL64-7.0-STD BETA 1 BUG REPORTS
Post by: uelsk8s on October 17, 2011, 03:51:14 pm
Please post any bugs from VL64 BETA 1 here.

Thanks,
Uelsk8s
Title: Re: VL64-7.0-STD BETA 1 BUG REPORTS
Post by: pierce.jason on October 18, 2011, 05:35:27 am
I'm getting different md5sums from the downloaded .iso and from one patched by xdelta. The downloaded iso matches the VL64-7.0-STD-B1.iso.md5.txt. My xdelta patched iso is getting md5 80d7b71bfa4b697d357a3bb9165ca585. Is that to be expected? From what I can tell, xdelta does internal md5 checksuming of the source iso before patching it.

4a4d25b7a2acb84604a1a66bc6732b1a  VL64-7.0-STD-A2.9.iso
867a8dbc4cde8fe83b98c28a4f2ae996  VL64-7.0-STD-A2to2.1.delta
846ce8a889a394e0382c78c6f2a16f91  VL64-7.0-STD-A2.9toB1.delta
b6982c79436bf5bd13da85727674083d  VL64-7.0-STD-A2.8to2.9.delta
3cecacb3d28f5b45e0e04276f4742208  VL64-7.0-STD-A2.7to2.8.delta
abe3aa05dd39a1c469fde7f1768c0e30  VL64-7.0-STD-A2.6toA2.7.delta
c5b7d6978928745e3036991ea9fc83ed  VL64-7.0-STD-A2.5to2.6.delta
f73aa1438a12086062d9ef162a53e743  VL64-7.0-STD-A2.4to2.5.delta
d5eedeffffc3deabcebf5b1bef355ca6  VL64-7.0-STD-A2.3to2.4.delta
7e24554a8495fe5495949ecc2ad8b89d  VL64-7.0-STD-A2.2to2.3.delta
0549f0fdf3bc09e12e10b781c7ad0a33  VL64-7.0-STD-A2.1to2.2.delta
Title: Re: VL64-7.0-STD BETA 1 BUG REPORTS
Post by: uelsk8s on October 18, 2011, 07:07:22 am
The downloaded ISO and the one patched with xdelta should match bit for bit giving you the same md5sum.
I made a small change to B1 at the last minute so I had a delta to the old B1 and I uploaded the wrong one.
It is all fixed now.

Sorry for the confusion,
Uelsk8s
Title: Re: VL64-7.0-STD BETA 1 BUG REPORTS
Post by: pierce.jason on October 18, 2011, 08:33:42 am
Attempting to run cairo-dock in OpenGL mode (-o) seems to reveal a bug with gtkglext.
"cairo-dock: symbol lookup error: /usr/lib64/libgtkglext-x11-1.0.so.0: undefined symbol: GTK_WIDGET_NO_WINDOW"

I believe libgtkglext will need to be patched as described here https://bugzilla.gnome.org/show_bug.cgi?id=611803

The problem seems to be from some calls that were recently deprecated in gtk2.

This probably also applies to 32bit.
Title: Re: VL64-7.0-STD BETA 1 BUG REPORTS
Post by: pierce.jason on October 18, 2011, 08:44:05 am
Thunar very slow opening on first attempt after login. Subsequent attempts at opening Thunar are quick and snappy as expected.
Title: Re: VL64-7.0-STD BETA 1 BUG REPORTS
Post by: M0E-lnx on October 18, 2011, 09:32:38 am
Thunar very slow opening on first attempt after login. Subsequent attempts at opening Thunar are quick and snappy as expected.
I noticed this too.  This problem was present on the early 7.0 x86 buikds too iirc.
Title: Re: VL64-7.0-STD BETA 1 BUG REPORTS
Post by: Joe1962 on October 18, 2011, 11:02:10 am
Thunar very slow opening on first attempt after login. Subsequent attempts at opening Thunar are quick and snappy as expected.

I have this since going to xfce-4.8 (VL 7.0 32 bit) and looked it up at the thunar forum. This is known and a fix supposedly in the works, but still not in thunar-1.3.0 which I built and installed a while back. The cause seems to be thunar looking something up on the network on start, which they planned to make asynchronous.
Title: Re: VL64-7.0-STD BETA 1 BUG REPORTS
Post by: stretchedthin on October 18, 2011, 12:45:08 pm
Thunar very slow opening on first attempt after login. Subsequent attempts at opening Thunar are quick and snappy as expected.

I have this since going to xfce-4.8 (VL 7.0 32 bit) and looked it up at the thunar forum. This is known and a fix supposedly in the works, but still not in thunar-1.3.0 which I built and installed a while back. The cause seems to be thunar looking something up on the network on start, which they planned to make asynchronous.

Found this while googling on my lunch break. Have not had a chance to try it, but may be a solution.


Quote
I "solved" my problem with Thunar by starting it daemonized when I start X. I switched from Openbox to XFCE recently, so I simply added Thunar (/usr/bin/thunar --daemon) to my Autostart list.
Putting it in Openbox autostart.sh would probably have the same effect.
Title: Re: VL64-7.0-STD BETA 1 BUG REPORTS
Post by: pierce.jason on October 18, 2011, 01:39:24 pm
Vec had to fix this on 32bit back around RC2 (possibly RC1? some early RC) I believe. I didn't hear any details on what the fix there was.
Title: Re: VL64-7.0-STD BETA 1 BUG REPORTS
Post by: stretchedthin on October 18, 2011, 04:41:55 pm
I'm not 100% sure it is fixed on the 32bit version. I've had time to try the daemon trick and it does not seem to improve matters.

You might not see it yourself at all pierce.jason as I believe you do not use the avahi-daemon at all an have it disabled from the get-go.
Title: Re: VL64-7.0-STD BETA 1 BUG REPORTS
Post by: pierce.jason on October 18, 2011, 09:07:57 pm
I don't "use" avahi, but I have not yet disabled it here. I'll disable it and see if that speeds up thunar's startup any and report back.
Title: Re: VL64-7.0-STD BETA 1 BUG REPORTS
Post by: pierce.jason on October 18, 2011, 09:39:58 pm
Missing symlink between /usr/bin/python and /usr/bin/python2 .
Title: Re: VL64-7.0-STD BETA 1 BUG REPORTS
Post by: eco2geek on October 18, 2011, 10:44:36 pm
Cosmetic gripe: Text of selected icons on the desktop is very hard to read against the default wallpaper. See attached screenshot (Desired result: get VL's artist to create a background using a darker blue. Please?)

I can confirm the problem with Thunar starting up for the first time. It seems to be looking for something on the network that it's not finding.
Title: Re: VL64-7.0-STD BETA 1 BUG REPORTS
Post by: nightflier on October 19, 2011, 08:03:36 am
Installed on real hardware: Quad core i5-750, 4 G memory, geforce GT 240, alongside my current VL6. Md5sum of iso checked.

On first run, installer crashed after creating user with strong password (password contained one single quote). Tried again with simpler password and it completed without error. Selected full install but no boot loader, using my existing LILO instead.

Most of xfce seems to be missing. It is not even an option in gdm. Installed again with same result.
Fluxbox works, I used it to verify proper operation of the basic hardware.
My usb webcam hijacks soundcard 0 position, but the hack using an /etc/modprobe.d/sound file still works.
Lots of crashes with the gecko mplayer-plugin.
Video performance very good.

Take Three: Repeated install using text installer. Same result.
Used gslapt and installed every xfce package. Works now.  :)
Title: Re: VL64-7.0-STD BETA 1 BUG REPORTS
Post by: uelsk8s on October 19, 2011, 11:16:03 am
Installed on real hardware: Quad core i5-750, 4 G memory, geforce GT 240, alongside my current VL6. Md5sum of iso checked.

On first run, installer crashed after creating user with strong password (password contained one single quote). Tried again with simpler password and it completed without error. Selected full install but no boot loader, using my existing LILO instead.

Most of xfce seems to be missing. It is not even an option in gdm. Installed again with same result.
Fluxbox works, I used it to verify proper operation of the basic hardware.
My usb webcam hijacks soundcard 0 position, but the hack using an /etc/modprobe.d/sound file still works.
Lots of crashes with the gecko mplayer-plugin.
Video performance very good.

Take Three: Repeated install using text installer. Same result.
Used gslapt and installed every xfce package. Works now.  :)

can you post the output of "grep xfce /var/log/pkgtools" for me?
Title: Re: VL64-7.0-STD BETA 1 BUG REPORTS
Post by: nightflier on October 19, 2011, 11:25:16 am
Here's the whole pkgtools file, it only shows post-install activity.
Code: [Select]
Installed on Wed Oct 19 17:37:53 Local time zone must be set--see zic manual page 2011
2011-10-19 13:55:15 Recreated GNU info directory file: /usr/info/dir.gz
2011-10-19 13:55:15 Installed new: xfce-4.8-x86_64-7vl70.txz
2011-10-19 13:55:15 Installed new: xfce4-cpufreq-plugin-1.0.0-x86_64-1vl70.txz
2011-10-19 13:55:16 Removed: pixman-0.20.2-x86_64-1vl70-upgraded-2011-10-19,13:55:15
2011-10-19 13:55:16 Upgraded: pixman-0.20.2-x86_64-1vl70 to pixman-0.21.6-x86_64-1vl70.txz
2011-10-19 13:55:16 Installed new: xfce4-cpugraph-plugin-1.0.1-x86_64-2vl70.txz
2011-10-19 13:55:16 Installed new: xfce4-datetime-plugin-0.6.1-x86_64-1vl70.txz
2011-10-19 13:55:16 Installed new: xfce4-dict-plugin-0.3.0-x86_64-1vl70.txz
2011-10-19 13:55:16 Installed new: xfce4-diskperf-plugin-2.3.0-x86_64-1vl70.txz
2011-10-19 13:55:16 Installed new: xfce4-eyes-plugin-4.4.1-x86_64-1vl70.txz
2011-10-19 13:55:17 Installed new: xfce4-fsguard-plugin-1.0.0-x86_64-1vl70.txz
2011-10-19 13:55:17 Installed new: xfce4-genmon-plugin-3.3.0-x86_64-1vl70.txz
2011-10-19 13:55:17 Installed new: xfce4-mixer-4.6.1-x86_64-2vl70.txz
2011-10-19 13:55:17 Installed new: xfce4-modemlights-plugin-0.1.3.99-x86_64-1vl70.txz
2011-10-19 13:55:17 Installed new: xfce4-mount-plugin-0.5.5-x86_64-1vl70.txz
2011-10-19 13:55:17 Installed new: libmpd-0.18.0-x86_64-1vl70.txz
2011-10-19 13:55:17 Installed new: xfce4-mpc-plugin-0.3.6-x86_64-1vl70.txz
2011-10-19 13:55:17 Installed new: xfce4-netload-plugin-1.0.0-x86_64-1vl70.txz
2011-10-19 13:55:17 Installed new: xfce4-notes-plugin-1.7.7-x86_64-1vl70.txz
2011-10-19 13:55:18 Installed new: xfce4-power-manager-1.0.10-x86_64-1vl70.txz
2011-10-19 13:55:18 Installed new: xfce4-screenshooter-plugin-1.4.0-x86_64-1vl70.txz
2011-10-19 13:55:18 Installed new: xfce4-smartbookmark-plugin-0.4.2-x86_64-1vl70.txz
2011-10-19 13:55:19 Installed new: xfce4-smartpm-plugin-0.4.0-x86_64-1vl70.txz
2011-10-19 13:55:19 Installed new: xfce4-systemload-plugin-1.0.0-x86_64-1vl70.txz
2011-10-19 13:55:19 Installed new: xfce4-time-out-plugin-1.0.0-x86_64-1vl70.txz
2011-10-19 13:55:19 Installed new: xfce4-timer-plugin-0.6-x86_64-1vl70.txz
2011-10-19 13:55:19 Installed new: xfce4-verve-plugin-1.0.0-x86_64-1vl70.txz
2011-10-19 13:55:19 Installed new: xfce4-wavelan-plugin-0.5.6-x86_64-1vl70.txz
2011-10-19 13:55:19 Installed new: xfce4-weather-plugin-0.7.4-x86_64-1vl70.txz
2011-10-19 13:55:19 Installed new: xfce4-xmms-plugin-0.5.3-x86_64-1vl70.txz
2011-10-19 13:55:19 Installed new: xfswitch-plugin-0.0.1-x86_64-1vl70.txz
Title: Re: VL64-7.0-STD BETA 1 BUG REPORTS
Post by: nightflier on October 19, 2011, 11:53:18 am
Downloaded proprietary nvidia driver. The installer disabled nouveau, built modules and installed perfectly. Judging by glxgears, framerate increased significally.

Tried to build etracer: http://slackbuilds.org/repository/13.37/games/extremetuxracer/
Error from running slacbuild:
Code: [Select]
ppgltk/images/png_reader.cpp:80:49: error: 'int_p_NULL' was not declared in this scope
ppgltk/images/png_reader.cpp:117:47: error: 'png_infopp_NULL' was not declared in this scope
make[2]: *** [png_reader.o] Error 1
make[2]: Leaving directory `/tmp/SBo/extremetuxracer-0.4/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/SBo/extremetuxracer-0.4'
make: *** [all] Error 2
When trying to run ./configure on the extracted archive:
Code: [Select]
checking for location of tclConfig.sh... configure: error: tclConfig.sh not found - use the --with-tcl option
Title: Re: VL64-7.0-STD BETA 1 BUG REPORTS
Post by: pierce.jason on October 19, 2011, 02:43:45 pm
Missing symlink between /usr/bin/python and /usr/bin/python2 .

This is fixed in python2-2.7.2 package in the repo.

Seems 2.7.2 introduces some other problems.
Code: [Select]
vl64:$ pysol.py
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Traceback (most recent call last):
  File "/usr/lib/python2.7/site.py", line 563, in <module>
    main()
  File "/usr/lib/python2.7/site.py", line 545, in main
    known_paths = addusersitepackages(known_paths)
  File "/usr/lib/python2.7/site.py", line 278, in addusersitepackages
    user_site = getusersitepackages()
  File "/usr/lib/python2.7/site.py", line 253, in getusersitepackages
    user_base = getuserbase() # this will also set USER_BASE
  File "/usr/lib/python2.7/site.py", line 243, in getuserbase
    USER_BASE = get_config_var('userbase')
  File "/usr/lib/python2.7/sysconfig.py", line 520, in get_config_var
    return get_config_vars().get(name)
  File "/usr/lib/python2.7/sysconfig.py", line 419, in get_config_vars
    _init_posix(_CONFIG_VARS)
  File "/usr/lib/python2.7/sysconfig.py", line 287, in _init_posix
    raise IOError(msg)
IOError: invalid Python installation: unable to open /usr/lib/python2.7/config/Makefile (No such file or directory)
 
Title: Re: VL64-7.0-STD BETA 1 BUG REPORTS
Post by: uelsk8s on October 19, 2011, 03:14:11 pm
Downloaded proprietary nvidia driver. The installer disabled nouveau, built modules and installed perfectly. Judging by glxgears, framerate increased significally.

Tried to build etracer: http://slackbuilds.org/repository/13.37/games/extremetuxracer/
Error from running slacbuild:
Code: [Select]
ppgltk/images/png_reader.cpp:80:49: error: 'int_p_NULL' was not declared in this scope
ppgltk/images/png_reader.cpp:117:47: error: 'png_infopp_NULL' was not declared in this scope
make[2]: *** [png_reader.o] Error 1
make[2]: Leaving directory `/tmp/SBo/extremetuxracer-0.4/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/SBo/extremetuxracer-0.4'
make: *** [all] Error 2
When trying to run ./configure on the extracted archive:
Code: [Select]
checking for location of tclConfig.sh... configure: error: tclConfig.sh not found - use the --with-tcl option

there is a png patch here:  http://shining.toofishes.net/etracer/0001-ppgltk-fix-build-with-png-1.4.patch.txt
the others in the dir look useful
you need to use the --libdir=/usr/lib64 with configure so it knows where to look for and place libs
Title: Re: VL64-7.0-STD BETA 1 BUG REPORTS
Post by: nightflier on October 20, 2011, 07:10:56 am
there is a png patch here:  http://shining.toofishes.net/etracer/0001-ppgltk-fix-build-with-png-1.4.patch.txt
the others in the dir look useful
you need to use the --libdir=/usr/lib64 with configure so it knows where to look for and place libs

Thanks! After applying the patch it would build. Now Tux "flies" at 130-260 FPS, using 1280x1024 fullscreen.
Title: Re: VL64-7.0-STD BETA 1 BUG REPORTS
Post by: eco2geek on October 20, 2011, 08:30:58 pm
I installed VLocity onto one of my computer's partitions.

- When using the "Select how Vlocity Linux should use /dev/sdXX" window, selecting "Mountpoint > Other" threw me out of the installer and into JWM (with a gray background). Had to reboot and start over.

- Trying to install LILO to the partition VL was installed on just gave error messages (on 2 attempts). (Which was just as well. I know that Slackware uses LILO, but still.) The installer would only let me install GRUB2 to the MBR of the computer, which is already "controlled" by another version of Linux, so that's not going to happen. It'd be nice to have the option of installing GRUB2 to the partition VL's installed on. I did it manually.

- I use a wireless keyboard that's connected to the computer via USB. During the ncurses part of the setup (setting up X), it didn't recognize the down arrow or up arrow keys, or the Tab key. I had to use vasm later.

- After using vasm to set up X, it wouldn't start. "modesetting" was set as the name of the driver in xorg.conf. Changed it to "nouveau".
Title: Re: VL64-7.0-STD BETA 1 BUG REPORTS
Post by: eco2geek on October 21, 2011, 08:40:32 pm
After an upgrade, gslapt will no longer run from the menu. (Actually I don't know if it ran from the menu before the upgrade, since I ran it from a terminal.) Problem is that "gksu" is missing from the command to start it.
Title: Re: VL64-7.0-STD BETA 1 BUG REPORTS
Post by: MikeCindi on October 24, 2011, 04:54:13 pm
Initial load went well using text installer. I will do my usual things over the next several days...
Title: Re: VL64-7.0-STD BETA 1 BUG REPORTS
Post by: scififry on November 05, 2011, 12:20:27 am
As I finally got the new power supply for my 64-bit machine I installed VL 64 onto it (Athlon 64 2GHz, 1280MB RAM).

Installation went very smooth, took only about 10 minutes.

When the first time configuration dialogue comes up after booting the freshly installed system for the first time, I cannot navigate between the options using the cursor keys or any other keys that could work for movement. Instead, just things like ^B , ^C and similar (depending on the key) appear in the line of the OK and Cancel buttons.
After just pressing enter without choosing anything I configured everything using vasm; keyboard and video configurations work now.

Cups still won't let me choose the parallel port as printing device (did in VL7 RC2.1 and RC3.4 too). It's an old 24-pin dot matrix printer connected directly to the parallel port and I can provide the required PPD file.

Thunar works fine without any bugs.

Looks very good so far, really good design!

Greetings,
scififry