The nuts and bolts => Networking & Security => Topic started by: bujums on January 05, 2012, 02:12:32 pm

Title: wicd... D-Bus issue
Post by: bujums on January 05, 2012, 02:12:32 pm
Just install Vector STD 7 on a Dell Vostro 1500. when I log into Vector I get an error "couldnot connect wicd's D-Bus interface  and then to check wicd log.   when I click that away I get another message that wicd daemon has stut down.   At this point point i can bring up wicd and try to connect to a router (WEP protectd) and I get a message that it cannot get an IP address.  I can however connect by plugging in a network cable.  The funny things when I take this home and work on with my own router non of this happens and I can connect easily.  I don't even get the error messages. (maybe it is just a coincidence)  The routers in the tow location are the same model but one is using WEP and the other is using WPA... any thing I can do?
Title: Re: wicd... D-Bus issue
Post by: stretchedthin on January 05, 2012, 03:40:57 pm
I'm assuming you used the live cd to install.
Open a terminal as root and type
to start the daemon manually.
If the client does not show up on the panel try (as a normal user in the terminal)

Client should appear in the panel.
Click on it find you essid I set it up.

I've run into this myself and odly enough after doing what is shown above it seems to work ok after that.

I've got something of a tutorial on wicd if you have not used it before. (
Title: Re: wicd... D-Bus issue
Post by: bujums on January 05, 2012, 08:30:38 pm
thanks for responding... wicd does showes up in the panel and I can access it from the menu.  But when I try to connect it will tell that It cannot get an IP address.  this is with the router that needs a WEP password ( I have tried all three version of the WEP password but none of them work).  When I am at home it all works fine even though I get the error.  But the home router is using WPA.  Could wicd have any issues with WEP?  I will try to start the daemon tommorrow when I am trying to access the WEP router.
Title: Re: wicd... D-Bus issue
Post by: stretchedthin on January 05, 2012, 08:56:10 pm
When you click on properties on the essid you are trying to connect to...
Does it say "WEP (Hex bla bla), WEP (Passphrase), WEP (Shared Restricted) or does it say WPA something.
You may have to change that line manually to the right one.
Title: Re: wicd... D-Bus issue
Post by: jahula1989 on February 29, 2012, 07:00:21 am
i am new with linux,
i reed all stuf that i found in net about error that error,
i check conf file about wicd and user groups, everythink look fine,
but wen i use termial to start wicd i must type root pass,
it will not start when i us my user.

What i must do for get this work normal ?
is any way to repair this ?
for now always as i log on i must start console, wrait su and pass for root and then wrait wicd-client - to get wi-fi work :/

PS: i use wi-fi adapter on usb, in live cd it work fine, and when i was using vl account.

Sorry for my english :/
Title: Re: wicd... D-Bus issue
Post by: bujums on February 29, 2012, 07:43:32 am
I wish I could tell you just what is wrong but it probably has to do with your user log in and whatever rights that use has.  Take a look at your user account and see if you can make some adjustments to include networking or even select administrator rights.  Also, there are probably lots of people on the forum that can help you.  You should start new thread with your question so more people see it and can respond. 

Also if you are new to Linux I always find it is good to try a few different distributions.  Some of the computers I have set up are happier with Vector, Ubuntu or Mint Linux.  I recently used Mint with LXDE for a low powered laptop and it worked very well.