The nuts and bolts => Networking & Security => Topic started by: abdul.jones on January 14, 2012, 07:55:47 am

Title: wpa_supplicant.conf, altered randomly and second, long psk
Post by: abdul.jones on January 14, 2012, 07:55:47 am
 I got my Belkin F5D7010 working with the native driver and it worked great for a couple of days, but I lost the signal today and when I looked in etc/wpa_supplicant.conf, found that my input (as per the instructions for setting up a WPA code in the How Tos) had been altered. All that was left was the essid and the psk plus another, bogus "psk" consisting of a load of  numbers and letters, extending the whole width of the page. When I delete them the Belkin works fine...for a few days, then I have to do the same thing again. I had the same problem with my last install, and did manage to rectify it- probably be accident, as I can't remember what I did. Actually, I can't remember many things these days......
  Anyone come across this?

  Now can't get any internet connection now with the wpa psk on. Working with an open connection, and quite a decent connection, but would like it encrypted, even though I only intend this laptop for writing. will need an internet connection to print if I ever get cups to work..

  Now have taken everything off that related to the wireless and started again, using native module and a brand new key. At the moment I have a connection, but it fluctuates between 4% and 30%. When I had this on ndiswrapper  it worked better (ie stronger signal), but I now can't get ndiswrpper to work. When I reboot I lose the wireless completely and have to set up all over again. When I use VASM to probe the hardware, it sets it up as eth1 rtl8180 in modprobe.conf, even though I've blacklisted rtl8180. Have tried setting up as eth1 rather than wlan0, bot the computer tells me there's no such thing. Have taken ndiswrapper off and am back with the crappy rtl8180 connection. It works- but not very well. Which makes resolving the problem with cups problematical as I won't know how much is down to a naff connection 

Added 12 feb
 Am of the opinion that the long psk is the result of me changing the psk settings from passphrase to preshared key on wicd.
  Have tried to reinstall ndiswrapper but it's still not starting on boot and Vasm still enters the wireless card as eth1 when I probe the hardware. It also appears to remove alias wlan0 ndiswrapper from modprob.conf every 3-4 probes. The upside is, vlwifi will detect the device after probing, but can't actually connect with the router. At the beginning of my reinstall, vlwifi did connect and with the encryption, but it lost the connection after half an hour and I can't get it back, even with the encryption off. Signal varies around 50% on average
Title: Re: wpa_supplicant.conf, altered randomly and second, long psk
Post by: abdul.jones on February 13, 2012, 11:37:19 am
 have tried again with ndiswrapper but no joy. Have looked at var/ logs and found this-


vector kernel rtl8180 0000:02:00.0 setting latency timer to 64
------"------- :authenticate with AP:94:0c:6d:a6:0a:23
------"-------wlan0 authenticated
vector dhcpcd [3929] broadcastAddr option is missing in DHC server response. Assuming
vector kernel:wlan0:disassociated
------"------- associated with AP: 94:0c (etc)
vector last message repeated 2 times
vecto kernel wlan0 privacy config mismatched and mixed cell disabled- disassociate


vector kernel:rtl8180 0000:02:00.0 enabling device(0000->0003)
-------"-------------------------------PCI INT A ->Link[LINKB]-> GSI 10 (level low)->IRQ10
-------"-------phy0:hwaddr 00:17:3f:d7:b8:fe,RTL8185vD+ rtl82252
------"--------:ndiswrapper version 1.54 loaded(smp=yes,prompt=yes)
vector loadndisdriver:loadndisdriver:load_driver(358)couldn't load driver net8185
vedtor kernel:usbcore:registered new interfacedriver ndiswrapper


vector kernel:ndiswrapper(import:242):unknown symbol:ntoskrnl.exe zwEnumerateKey
-----------------"--------------------------:unknown symbol:ntoskrnl.exe zwQueryKey
--------------------------------------------"--------------------------------- loWMIQueryAllData
----------------"-----------(load_sys_files:206)couldn't prepare driver "net8185"
----------------"-----------(load_wrap_driver1108)couldn't load driver net8185:checksystemlog for messages from loandisdriver

 No idea what this means (esp. syslog) . Is ndiswrapper itself the problem?

Title: Re: wpa_supplicant.conf, altered randomly and second, long psk
Post by: abdul.jones on February 13, 2012, 12:45:15 pm
Some time later.... previous post should have been sent last night but connection failed before I could send- to tired to try again til tonight.

  Anyway, I've given up on ndiswrapper for now, especially as I've managed to delete it.
am perservering with the native driver, as I'm not sure that's working properly. The problem seems to be wpa supplicant (don't we all love it!).

  The Belkin I've got now starts up at boot, and condescended to find an IP address and connect. Soon as I put the encryption back on, no joy. When I entered  wpa_supplicant -B -Dwext -iwlan0 -c/etc/wpa_supplicant.conf I got the message

  ioctl[SIOCSIWAUTH]: operation not supported
 WEXT auth param 4 value 0x0 -cannot override it
 Delete /var/run/wpa_supplicant_wlan0 manually if it is not in use anymore
 Failed to initialise control interface var/run/wpa_supplicant
you may have another wpa_supplicant process already running or the file was left by an unclean termination of wpa_supplicant in which case you will need to manually remove this file before starting wpa_supplicant again
ioctl[SIOCSIWAUTH]: operation not supported
WEXT auth param 4 value 0x0 I deleted the wlan0 file, rebooted and started again, typed in "wpa_supplicat -B ..." etc and this time got

 ioctl[SIOCSINAUTH]:operation not supported
WEXT auth param 4 value 0x0

 As I have no idea what this means other than it doesn't sound good, I logged out. Help and explanation would be appreciated.
 I also changed the encryption type on my router from aes to tkip (aes had worked with a previous good connection of this card as CCMP) and hey! connection. I turned the computer off and back on  and, hey! still got a connection. And it seems an improved connection- averaging 20% rather than 5- 10%, which was previous.
  So I'm hopeful if someone would help me with the above error messages (as much for my future use as for sorting this current problem) I might actually end up with a decent connection and on to my next great adventure...getting the printer to print! Ta, folks...
Title: Re: wpa_supplicant.conf, altered randomly and second, long psk
Post by: sledgehammer on February 13, 2012, 09:48:37 pm
Sorry abdul.jones but I can't be of help.  I don't know much about wifi. I don't recall what I did to get wpa encryption on my Netgear.   I use WL 7 and if I recall just clicked on the little wifi icon and followed the prompts.  It just worked.  I don't recall whether I had to get on the router or not, but don't think so. 
Title: Re: wpa_supplicant.conf, altered randomly and second, long psk
Post by: abdul.jones on February 19, 2012, 03:08:36 am
Spent most of yesterday on this. Still not sorted. However, if this makes it to the forum, I can tell you that I am writing this wireless. I have spent time going through all the likely post in the forum up to 2009 and through all the files on my system that might have something to do with wireless. I found a couple still sporting ndiswrapper as driver (etc/wireless was the last one). I've also tried all the tweaks and changes I found in the forum and current positition is-

I have a decent signal now (averaging 40% as opposed to the previous 10%)
I cannot get Wicd to accept my wpa psk- just get bad password message
Wicd connects- sometimes- without the psk on, but connection can drop randomly. Sometimes it will reconnect if I refresh, sometimes not
Wicd sometime freezes

 I need some tweaks friends. Any ideas where I might look?
Title: Re: wpa_supplicant.conf, altered randomly and second, long psk
Post by: abdul.jones on February 22, 2012, 12:50:28 pm
Right, guys- stand down. Brace yourselves for bad news----the mo-bo died today. After a short, undetected illness it pegged, popped it's clogs, shuffled off this mortal coil and went to join that great recycling plant in the sky.
  The good news is that I was given an old (but newer) lap top by someone at work a couple of days ago. She'd been given it by someone she knew and all that was wrong with it (apparently) is the hard drive's dead. This appears to be the case and I have a new HD arriving tomorrow. I am currently writing this on said machine with no hard drive, but vl7 live in the dvd drive. Has in built wireless-- broadcom (?) chips, set up straight away- once I realised there was a physical button to switch the wireless on. Hope to finally appreciate linux in all it's glory this weekend- instead of swearing at it as I have been for the last few months.

  To those who tried to help and those who wanted to help, but couldn't, thanks. It was a bit of a baptism by fire, but I probably learned more from trying to solve the problems than with a trouble free install. To those just starting out with linux, I suggest view it as a hobby, then you won't get frustrated, just intrigued.
  Speak to you this weekend, this time from VL7 as this has decidedly more oomph than the last lap top. Cheers!
Title: Re: wpa_supplicant.conf, altered randomly and second, long psk
Post by: sledgehammer on February 22, 2012, 10:08:38 pm
Looking forward to your post.  I am not sure about your "try it as a hobby" suggestion.  Best way to learn about lifesavers is to be on the boat when it goes down. Seems to me that you know more about these gadgets than most and I bet once you get the hard drive installed, you won't have other problems. 

Title: Re: wpa_supplicant.conf, altered randomly and second, long psk
Post by: abdul.jones on February 23, 2012, 11:23:12 am
 Trust me, treating it as a hobby stops you chucking it out the window and going back to You Know Who. I view it rather in the same way I view cryptic crosswords- an absorbing challenge, but if I don't finish, it's no big deal
 We're up and running, the hard drive is in and now I have a Broadcom wireless issue to sort out. But that's another post...