VectorLinux

Cooking up the Treats => New Package Requests => Topic started by: ronnyquest on January 30, 2012, 04:10:04 am

Title: [VL 7.0-64] FlightGear
Post by: ronnyquest on January 30, 2012, 04:10:04 am
The Slackware packages can be found here:

http://packages.flightgear.org.uk/Release-2.4.0/Slackware64-13.37/
Title: Re: [VL 7.0-64] FlightGear
Post by: stretchedthin on January 31, 2012, 12:31:52 pm
Working on this.  Will take a little longer than usual. The data pack alone took me 6 hours to download.
Title: Re: [VL 7.0-64] FlightGear
Post by: ronnyquest on January 31, 2012, 05:39:53 pm
Thanks for working on this.  I know you're stretched thin. 
Title: Re: [VL 7.0-64] FlightGear
Post by: Herpy on January 31, 2012, 05:52:00 pm
Thanks for working on this.  I know you're stretched thin. 
I see what you did there.
Title: Re: [VL 7.0-64] FlightGear
Post by: stretchedthin on February 02, 2012, 10:57:10 am
Damn, that's a big data file.  Took all day to upload.
Should be in the repository for 32bit now.  Working on the 64bit build and upload now, but because of the size give it a couple days.
Title: Re: [VL 7.0-64] FlightGear
Post by: uelsk8s on February 03, 2012, 08:48:13 am
Damn, that's a big data file.  Took all day to upload.
Should be in the repository for 32bit now.  Working on the 64bit build and upload now, but because of the size give it a couple days.

Is there a way we can use the same data file for both archs?
I just don't want to use that much space on the Repo if it's not necessary.
Title: Re: [VL 7.0-64] FlightGear
Post by: stretchedthin on February 03, 2012, 12:19:43 pm
@uelsk8s
I don't really need the source in 64bit, since it is the same as 32 bit.  That will save quite a bit of space.
Title: Re: [VL 7.0-64] FlightGear
Post by: stretchedthin on February 03, 2012, 12:21:57 pm
@ronnyquest
FlightGear uploaded to 64bit.  Give it a go and let me know.  I'm installing from gslapt here so I'll report how it goes, for me as well.
Be prepared for a lenghty install.
Title: Re: [VL 7.0-64] FlightGear
Post by: uelsk8s on February 03, 2012, 12:59:13 pm
@uelsk8s
I don't really need the source in 64bit, since it is the same as 32 bit.  That will save quite a bit of space.

Thats good, but I was asking about the data pkg: http://vectorlinux.osuosl.org/VL64-7.0/extra/games/flightgear-data-2.4.0-x86_64-1vl70.txz
It is over 2GB.
Title: Re: [VL 7.0-64] FlightGear
Post by: stretchedthin on February 03, 2012, 01:10:19 pm
@uelsk8s
I don't really need the source in 64bit, since it is the same as 32 bit.  That will save quite a bit of space.

Thats good, but I was asking about the data pkg: http://vectorlinux.osuosl.org/VL64-7.0/extra/games/flightgear-data-2.4.0-x86_64-1vl70.txz
It is over 2GB.

Don't think we can avoid that one.

@ronnyquest.  Installed and ran fine on my 64bit.
Title: Re: [VL 7.0-64] FlightGear
Post by: ronnyquest on February 04, 2012, 07:13:17 pm
I will get it and begin testing now.  Thanks!  Sorry about the huge data files...I should have warned you.
Title: Re: [VL 7.0-64] FlightGear
Post by: ronnyquest on February 07, 2012, 04:07:00 pm
Flightgear seemed to install, but there is a problem when I attempt to launch it from either machine.  A window opens, but nothing displays.  The window stays for a while, during which time the load goes crazy on two of the CPUs, then the window goes away without error and flightgear never launches.
Title: Re: [VL 7.0-64] FlightGear
Post by: stretchedthin on February 07, 2012, 06:14:10 pm
Try this from the command line..
/usr/bin/fgfs --geometry=1024x768 --enable-game-mode

that is what is ran when it is started from the menu.  Let me know what errors kick up.
Title: Re: [VL 7.0-64] FlightGear
Post by: ronnyquest on February 07, 2012, 09:02:04 pm
Code: [Select]
ronnyquest:$ /usr/bin/fgfs --geometry=1024x768 --enable-game-mode
***
***
*** Warning: changing bad FG_ROOT/--fg-root to '/usr/share/flightgear/data'
***
***
Processing command line arguments
KI266 dme indicator #0 initialized
loading scenario 'nimitz_demo'
socket(): Address family not supported by protocol
creating 3D noise texture... DONE
Initializing Nasal Electrical System
*********************************WARN_ONCE*********************************
File evergreen_render.c function evergreenTryDrawPrims line 895
Rendering was 1 commands larger than predicted size. We might overflow  command buffer.
***************************************************************************
failure to revalidate BOs - badness
fgfs: radeon_cs_gem.c:181: cs_gem_write_reloc: Assertion `boi->space_accounted' failed.
Aborted
Title: Re: [VL 7.0-64] FlightGear
Post by: stretchedthin on February 07, 2012, 09:40:47 pm
Just a guess but it looks like it's not liking the radeon graphics driver.
Title: Re: [VL 7.0-64] FlightGear
Post by: ronnyquest on February 08, 2012, 06:48:14 am
Looks that way.