VectorLinux

The nuts and bolts => Technical General => Topic started by: syncdram on May 15, 2012, 07:59:28 am

Title: Right Cick Problem
Post by: syncdram on May 15, 2012, 07:59:28 am
If i'm in my home directory and right click the menu opens and stays up, if i go past this point say into a folder within my home directory and right click i have to hold down on the mouse to keep the menus up. This does not happen on the desktop has anyone else run into this? using vector 7 gold.
Title: Re: Right Cick Problem
Post by: M0E-lnx on May 15, 2012, 01:39:26 pm
I'm trying to replicate this on my 7.0 install and I can't.

Perhaps you should detail your steps to see the problem.  Here is what i'm doing.
Open Thunar from the menu (xfce menu)
Thunar goes into your home directory by default
Once there, I right click any blank area in the thunar window.
My menu works as expected.

How are you getting this?
Title: Re: Right Cick Problem
Post by: stretchedthin on May 15, 2012, 02:42:34 pm
I have seen this, but as an exception not a rule.  I will try and pay some attention as to the conditions present if and when I see it happen again.
Title: Re: Right Cick Problem
Post by: fogpipe on May 15, 2012, 07:02:27 pm
This has happened to me as well, but not often. Using vl7-64 rc2.
Title: Re: Right Cick Problem
Post by: syncdram on May 16, 2012, 07:41:57 am
Moe-lnx,

ok when i do just as you mention, the menu does work fine, its when i right click on a folder in the home directory and behond i have to hold down the right click button for the menu to stay open.
Title: Re: Right Cick Problem
Post by: Joe1962 on May 16, 2012, 09:38:35 am
Heh! This one took me a while to figure out some weeks back and I still wonder if this is by (somewhat twisted) design, or a gtk2 themes  bug. Just change the xfce (gtk2) toolkit appearance theme. Some need holding down the right button all the time, others don't... >:(

I personally use Curve, since the menu works properly and it is a nice and workable (though not spectacular) theme.


EDIT: I was going to post about this issue some time back, but then forgot... :-[
Title: Re: Right Cick Problem
Post by: stretchedthin on May 16, 2012, 06:43:47 pm
Heh! This one took me a while to figure out some weeks back and I still wonder if this is by (somewhat twisted) design, or a gtk2 themes  bug. Just change the xfce (gtk2) toolkit appearance theme. Some need holding down the right button all the time, others don't... >:(

I personally use Curve, since the menu works properly and it is a nice and workable (though not spectacular) theme.


EDIT: I was going to post about this issue some time back, but then forgot... :-[

@joe1962.  Are you referring to the default Style Theme "Fn Closure" as the problem?  Or should I be looking someplace other than Settings-->Appearance?


Title: Re: Right Cick Problem
Post by: Joe1962 on May 18, 2012, 06:12:46 am
Ok, so I got a bit confused here, memory's not what i used to be, LOL. Curve is a window style and menu issues are probably a widget style thing. But I just tried to replicate the problem on my new 64 bit install and can't. Yet I always had this on VL7 32 bit. What I am not sure about is if it happened right after installation, or only after upgrading some XFCE stuff. Anyway, try changing the widget styles around and see what you get.
Title: Re: Right Cick Problem
Post by: stretchedthin on May 18, 2012, 10:52:37 am
No problem. Well if it is not a theme issue and playing with that does not fix it them maybe it's an xfce4 issue and the nex xfce4-4.10 will fix it.
I should have xfce4-4.10 back in and tested by tomorrow.
Hopefully that will do the trick for you syncdram.