VectorLinux

The nuts and bolts => Office & Printing => Topic started by: tunit on July 23, 2012, 01:03:06 am

Title: Kmymoney install- vpackager says kde-config was not found!
Post by: tunit on July 23, 2012, 01:03:06 am
Setting permissions...
Configuring source...
checking build system type... i486-slackware-linux-gnu
checking host system type... i486-slackware-linux-gnu
checking target system type... i486-slackware-linux-gnu
checking for a BSD-compatible install... /bin/ginstall -c
checking for -p flag to install... yes
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for kde-config... not found
configure: error: The important program kde-config was not found!
Please check whether you installed KDE correctly.


I was using vpackager to build and install from a .tar.bz2 file. I have already installed KDE, but it seems vpackager cannot find KDE... Please help.

p.s. I cannot login using KDE plasma desktop session, it logs out automatically in less than 10 seconds.
Title: Re: Kmymoney install- vpackager says kde-config was not found!
Post by: M0E-lnx on July 23, 2012, 05:26:04 am
That means you need to install some kde components before building it.  Normally, these will include kdelibs, qt4, and/or others.
Title: Re: Kmymoney install- vpackager says kde-config was not found!
Post by: tunit on July 23, 2012, 10:04:55 pm
That means you need to install some kde components before building it.  Normally, these will include kdelibs, qt4, and/or others.

I have installed kdelibs, qt3 is already installed, qt4 is not showing up on gslapt packages list. I'll try out installing any additional kde components that can do the trick..
Title: Re: Kmymoney install- vpackager says kde-config was not found!
Post by: M0E-lnx on July 24, 2012, 09:48:59 am
You'd have to look at the log.  Put the log in a pastebin somewhere.