The nuts and bolts => Networking & Security => Topic started by: StrayBit on January 05, 2013, 01:07:26 pm

Title: [SOLVED} Network unreachable
Post by: StrayBit on January 05, 2013, 01:07:26 pm
Dell GS820 dual Pentium 4 processors 3.60Ghz, 1GiB ram

Wednesday, with VL5.9, I Dl'd 6.0 Std iso, 7.0 Std.iso and vinstall-iso.  Successfully installed 6 and was able to access the internet with it.

Today, the "network is unreachable" - both in 5.9 and 6.0!
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FW/FPW (ICH6 Family SMBus Controller (rev 03)
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BC751 GigaBit Ethernet PCI Express (rev 01)
04:01.0 Communication Controller: Conexant HSF 56k Data/Fax Modem
04:02.0 Network controller: intersil Corporation ISL3890 [Prism GT/Prism Duette]/ISL3886 [Prism Javelin/Prism Xbow] (rev 01)

prism54: request firmware() failed for isl3890
Ah!  I swapped slots for SMBus Controller and modem - will try deleting...

Deleted both inet1 and inetd
root:# vasm->Network-NetConfig
SDCMO --backtitle "sBACKTITLE" --title "sTITLE" --menu "sTEXT" sDIMENSION /
inet1: RECYCLE DEVICE=eth0" /
inet2: RECYCLE DEVICE=eth1" /
inet3: "NEW inet" /
2> $reply
Dell: /~
root:# ping -c3
Connect: Network is unreachable
Dell: /~
root:# vasm->Network-INET->set
starting network eth0 as
SIOCSIFLAGS: No such file or directory
The quotes were copied to paper then typed into a text file.

The only thing I can think of now is to tear the PC out (pain), open it up and put the cards back where they were (more pain).  Putting the PC back in it's notch is even more pain!

Hopefully, someone has an idea that I can try before tearing apart my work station - again.

(I tried vinstall-iso VL7.0 but it wouldn't start.  If that still happens after I get the network working, I'll start a new topic.)
Title: Re: Network unreachable
Post by: bigpaws on January 05, 2013, 01:20:02 pm
More than likely the card order was lost. Meaning that the card that
was eth0 is now eth1 and so on. No real order.

As root:

ifconfig should give you more information. Like the MAC addresses so that you can
do some tests.

You can also see if there are any entries in /etc/udev/rules.d/70-persistant-net.rules


Title: Re: Network unreachable
Post by: StrayBit on January 05, 2013, 07:01:00 pm
Thanks for your reply, Bigpaws.

ifconfig -a  only lists lo.

There was no /etc/udev/rules.d/70-persistant-net.rules.  I did look at 75-persistant-net.rules, 90-network.rules and network-device.rules.  While I'm not knowledgeable enough to know what they were doing, I couldn't see anything storing the devices.

When I try to ADD or SET an inet, the second sceen "Selecting a network device" only lists dummy0 which is new tonight, it used to list etho, eth0.1, etc.

Title: Re: Network unreachable
Post by: retired1af on January 06, 2013, 03:31:42 am
prism54: request firmware() failed for isl3890

It's possible the wlan card went tango uniform.
Title: Re: Network unreachable
Post by: bigpaws on January 06, 2013, 09:15:03 am
Is this an older MB?

Being these devices worked in their previous
positions it is possible that there is an IRQ conflict.

You need to go through dmesg and see if there are
any errors.

The 70-... is just a position in udev as an order.

You should see something like this:

# PCI device 0x10ec:0x8168 (r8169)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="90:e6:ba:2d:33:b7", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

Notice the MAC address under ATTR, also the NAME=
Those give you device information.

See where that gets you.

Title: Re: [SOLVED} Network unreachable
Post by: StrayBit on January 06, 2013, 06:42:47 pm
The original VL5.9 is on sda1 and I had copied it to sdb2 which is where I had all the trouble (excluding VL6 for the moment).  sda1 was still working so I erased sdb2 (except /mnt) then rsync sda1 sdb2.  Still had the same problem but now, vasm->NETWORK->INET->SET allowed me to change from eth0 to eth1.  Am posting this from sdb2.

Now I can see if VL6 (sda6) is still a problem - if so, I'll just reinstall.  I've saved fstab & smb.conf, etc.

Also, I can now install VL7 to the larger sda1.

Oh!  The modem and associated network controller will be removed as soon as I find a plate and have the PC apart.

Then I'll try to find what ever is needed to get SMBus Intel 82801FB/... wireless card working.

Thanks for all your help and suggestions.