VectorLinux

General Announcements => VL package news and Updates => Topic started by: hata_ph on June 30, 2013, 10:26:06 pm

Title: etm-891 and etm_qt-2.1.5 [VL 7.0]
Post by: hata_ph on June 30, 2013, 10:26:06 pm
Upload etm-891 and etm_qt-2.1.5 to the testing repo...

http://people.duke.edu/~dgraham/ETM/
http://people.duke.edu/~dgraham/etmqt/

(http://people.duke.edu/~dgraham/ETM/html-images/etm_gui_cli_small.png)
Title: Re: etm-891 and etm_qt-2.1.5 [VL 7.0]
Post by: sledgehammer on July 14, 2013, 11:03:45 pm
hata_ph,

I have been running etm from the VL7 repository and have no problems.  I don't see an icon in the directory.  Have to, as we discussed before, make sure pyqt4 4.8.3-i486-1vl70 is not loaded. 

I like your description too.  It is very hard to describe.  I think of Mark Twain trying to describe a rocket ship.  The concepts that such a description would require would simply not be part of Mark's world.  That same thing is true of ETM, at least for me.  It organizes one's life from many different standpoints. 

Thank you!

John
Title: Re: etm-891 and etm_qt-2.1.5 [VL 7.0]
Post by: hata_ph on July 15, 2013, 12:51:10 am
sledgehammer,

I tested etm on a fresh VM, no problem with pyqt4 installed. But I notice etm need distribute or setuptools to be installed to work or else it will show below message when run e.pyw

Quote
Errors importing etm.etmWX
(<type 'exceptions.ImportError'>, ImportError('No module named pkg_resources',), <traceback object at 0x2da57a0>)

So I have rebuild both etm and etm_qt to fix the dependencies issue and add a desktop files to them too...should be available in the testing repo soon...