VectorLinux

Cooking up the Treats => New Package Requests => Topic started by: nightflier on January 02, 2014, 06:22:33 pm

Title: PNMixer
Post by: nightflier on January 02, 2014, 06:22:33 pm
Fork of obmixer, with added features.
https://github.com/nicklan/pnmixer

It looks good, I tested it using this slackbuild, after editing the version number and setting the snapbuild variable to "NO":
https://raw.github.com/PhantomX/slackbuilds/master/pnmixer/pnmixer.SlackBuild
Title: Re: PNMixer
Post by: hata_ph on January 02, 2014, 07:14:59 pm
pnmixer-0.5.1 is available at the untested repo...
but it seem it require alsamixergui/xfce4-mixer/gnome-alsamixer/pavucontrol for the volume control...

(https://github.com/nicklan/pnmixer/wiki/behavior_prefs.png)
Title: Re: PNMixer
Post by: nightflier on January 03, 2014, 04:32:42 am
Package tests good on 7.1 B1 32-bit. As always, thank you for the quick response, hata_ph.  :)

The program does need an external application for adjusting settings, but unlike obmixer which was hard coded to use alsamixergui, this one allows you to manually specify the command you want. I typed in aumix and it happily uses that.

Of course, adding alsamixergui (plus dep fltk) to the repo would not be a bad idea..
Title: Re: PNMixer
Post by: hata_ph on January 03, 2014, 04:56:40 pm
alsamixergui-0.9.0rc2 should be available at the untested repo now :)
Title: Re: PNMixer
Post by: nightflier on January 04, 2014, 05:01:35 am
Package alsamixergui-0.9.0rc2-i586-1vl71.txz tests good.

I had to manually download it. Looks like the 32 bit package did not get processed properly for the repo, it's not mentioned in PACKAGES.TXT and does not have a .meta file.
Title: Re: PNMixer
Post by: hata_ph on January 05, 2014, 05:20:18 pm
I have move pnmixer and alsamixergui to testing repo...
Title: Re: PNMixer
Post by: Lyn on January 07, 2014, 01:38:13 pm
alsamixergui works fine

PNMixer fails to load....

(pnmixer:3850): Gtk-WARNING **: Unable to locate theme engine in module_path: "experience",
Title: Re: PNMixer
Post by: hata_ph on January 07, 2014, 05:57:05 pm
alsamixergui works fine

PNMixer fails to load....

(pnmixer:3850): Gtk-WARNING **: Unable to locate theme engine in module_path: "experience",


On 7.0 or 7.1?
Title: Re: PNMixer
Post by: Lyn on January 08, 2014, 04:37:16 am
sory on v7.0 64 bit
Title: Re: PNMixer
Post by: hata_ph on January 08, 2014, 05:12:06 pm
I just install pnmixer-0.5.1 at VL 7.0 64bit via gslapt and it work fine without any error...
If you run pnmixer from terminal, is there any error messages?
Title: Re: PNMixer
Post by: Lyn on January 09, 2014, 07:03:59 am
the error message was above
Title: Re: PNMixer
Post by: uelsk8s on January 09, 2014, 09:41:18 am
Lyn,
your error is for a missing theme engine, can you try using a different gtk theme or installing the experience theme engine?

HTH,
Uelsk8s