VectorLinux

Cooking up the Treats => Distro development => Topic started by: Pita on May 10, 2014, 09:01:45 pm

Title: VL-7.1-LIGHT
Post by: Pita on May 10, 2014, 09:01:45 pm
Is VL-7.1-LIGHT under active development?

Installed VL-7.1-LIGHT-A0.1.iso 32bit.

Where to report?

Title: Re: VL-7.1-LIGHT
Post by: nightflier on May 11, 2014, 03:45:43 am
Pita, Light is coming together, if slowly and under the radar for now. You may report your findings here. :)
Title: Re: VL-7.1-LIGHT
Post by: Pita on May 12, 2014, 12:45:45 am
installed VL-7.1-LIGHT-A0.1.iso. 32bit

Installation went smooth

Surprise, surprise both my USB connected printers were detected  ;D  ;D  ;D
and are even actually printing.   ;)

That is a first in VL-7.1 long running development and does not really come
as a surprise. Before in VL-6 and may be VL5 it was the light version only
with which I was able to print.

Claws-mail still hangs on Configuration>Preferences for current account>Apply/OK>Hang.

Mail will not go out on port 25. Which one should I use?

Menu>Accessories>root-terminal does not open after giving password.

DVD plays smooth with smplayer.

Audio CD playing is stuttering both with smplayer and umplayer.

Fluxbox opens when chosen as desktop.

No problem with USB port connected KB and mouse.

Indeed a very nice distro already.
Title: Re: VL-7.1-LIGHT
Post by: nightflier on May 12, 2014, 03:05:41 am
Thank you for that report, Pita.

The USB printing is fixed in Standard as well.

I wonder if the Claws-mail problems are caused by mail server settings. In my test it did not work until I checked the box for smtp authentication for sending mail. There is no restriction by the OS for sending on port 25, or any other outgoing traffic.

I see the problem with root terminal, will fix.

I'm leaning towards using smplayer as only media player, remove umplayer and exaile.

Fluxbox may be replaced by JWM, if any.
Title: Re: VL-7.1-LIGHT
Post by: overthere on May 12, 2014, 10:29:58 pm
Quote
I'm leaning towards using smplayer as only media player, remove umplayer and exaile.

I like that idea and also your wallpaper...

Quote
Fluxbox may be replaced by JWM, if any.

.aaah no fluxbox..I vote skip jwm...icewm spiced...

The previous file manager with the apps folder was nice but spacefm look interesting
Title: Re: VL-7.1-LIGHT
Post by: Pita on May 12, 2014, 11:53:13 pm
Yes does not make sense in light edition to offer several players.

I will always use fluxbox.

Unable to send mail with claws-mail. Tried all kind of settings and it always comes back:
Quote
* Account 'ISPX': Connecting to SMTP server: smtp.smartbro.net:25...
*** smtp.smartbro.net:25: unknown host.
*** Error occurred while sending the message.

I copied ~/.claws-mail over from working box still nothing doing.

I can ping smartbro.net.
Title: Re: VL-7.1-LIGHT
Post by: nightflier on May 13, 2014, 04:39:48 am
Fluxbox users, check out xdgmenumaker. I'm not well-versed with fluxbox, but if you guys came up with a nice configuration including a menu maker, that would be a nice addition.

@overthere, the previous file manager with apps folder must be pcmanfm. It is very nice, but with a dependency list much longer than that of spacefm. It is getting to be a struggle to keep the dep list from growing in all directions.

@Pita, that error could indicate a DNS problem, "smartbro.net" and "smtp.smartbro.net" are different servers. Try pinging smtp.smartbro.net
Title: Re: VL-7.1-LIGHT
Post by: hata_ph on May 13, 2014, 10:24:43 pm
i believe claws-mail will hang even using local mailbox...
Title: Re: VL-7.1-LIGHT
Post by: Pita on May 14, 2014, 12:14:04 am
No problem pinging smtp.smartbro.net.

That is the first time I encounter this problem of claws-mail unable to send mail.

The hang problem one can avoid by not using "Preferences for current account"
using in the meantime only "Edit accounts".

Installed Sylpheed. Mail will not go out:
Quote
(sylpheed:5386): LibSylph-WARNING **: session timeout.
(sylpheed:5386): LibSylph-WARNING **: [15:52:03] Session timed out.
(sylpheed:5386): Sylpheed-WARNING **: Sending queued message 1 failed.
Title: Re: VL-7.1-LIGHT
Post by: Pita on May 16, 2014, 11:47:38 pm
I cannot burn with Brasero my DVD+RW it always comes back with:
Quote
Please replace the disk with a supported CD or DVD

That is as well the case in Salix.

No problem with X-CD-Roast my prefered burning program.
Title: Re: VL-7.1-LIGHT
Post by: nightflier on May 17, 2014, 04:12:57 am
Claws-mail: not sure what to look for, as I'm unable to duplicate any of the reported problems. In a virtual machine that is.
EDIT: I see it now: when using "preferences for current account" and clicking OK, it throws an error "Another claws-mail instance is already running". Then it times out and quits. This needs to be reported to the general VL 7.1 bug tracker.

My current, local dev setup is ahead of what is available on vlcore, when that system is done refreshing I'll upload the changes for a new ISO.
Title: Re: VL-7.1-LIGHT
Post by: Pita on May 17, 2014, 05:50:03 pm
I cannot burn with Brasero my DVD+RW it always comes back with:
Quote
Please replace the disk with a supported CD or DVD

That is as well the case in Salix.

No problem with X-CD-Roast my prefered burning program.

Was informed this problem of Brasero can be solved by putting:
Code: [Select]
/dev/sr0 /media/dvd auto ro,user,noauto,unhide 0 0
into fstab
Title: Re: VL-7.1-LIGHT
Post by: nightflier on May 18, 2014, 01:34:56 pm
Code: [Select]
/dev/sr0 /media/dvd auto ro,user,noauto,unhide 0 0

Thanks. Did this on test system and Brasero works. But.. man, it's slow! I can't find X-CD-Roast in our repo. Where did you get your copy?
Title: Re: VL-7.1-LIGHT
Post by: Pita on May 18, 2014, 08:43:46 pm

Thanks. Did this on test system and Brasero works. But.. man, it's slow! I can't find X-CD-Roast in our repo.
Where did you get your copy?

http://slackbuilds.org/repository/13.37/system/xcdroast/

When I started with Linux RedHat 5.2 xcdroast was the program for burning
CDs and I have stayed with it ever since and it never let me down. I tried
others and always come back to it.

Title: Re: VL-7.1-LIGHT
Post by: nightflier on May 19, 2014, 09:41:15 am
http://slackbuilds.org/repository/13.37/system/xcdroast/

That one built and installed, but throws an error about the permissions of /usr/bin/cdrecord. If you have your copy running on 7.1, did you do anything in particular to make it work?
Title: Re: VL-7.1-LIGHT
Post by: Pita on May 20, 2014, 01:39:13 am
http://slackbuilds.org/repository/13.37/system/xcdroast/

That one built and installed, but throws an error about the permissions of /usr/bin/cdrecord. If you have your copy running on 7.1, did you do anything in particular to make it work?

I got the same error.
/usr/bin/cdrecord is a synlink to /usr/bin/wodim.
I copied cdrecord from Salix over to Light and xcdroast started. In Salix
cdrecord is not a symlink.
Title: Re: VL-7.1-LIGHT
Post by: roarde on May 20, 2014, 03:22:26 pm
Cdrtools is a beast to re-initiate into the package system due mainly to the maintainer's eccentricities. On the flip side, those same eccentricities make it pretty simple to maintain and keep once it's back in there.

But didn't I see something in xcdroast source notes about cdrecord, etc. being included somewhere in xcdroast's own libs, and copyable to system path? Was a really cursory skimming so I could easily be wrong; but maybe worth a look.
Title: Re: VL-7.1-LIGHT
Post by: Pita on May 22, 2014, 01:17:06 am
I am still struggling to send mail with claws-mail or for that matter sylpheed.

with clwas-mal I get:
Code: [Select]
** (claws-mail:12250): WARNING **: getaddrinfo for smtp.smartbro.net:25 failed: No address associated with hostname

** (claws-mail:12250): WARNING **: [16:28:24] smtp.smartbro.net:25: host lookup failed (No address associated with hostname).

** (claws-mail:12243): WARNING **: DNS lookup failed

** (claws-mail:12243): WARNING **: [16:28:24] smtp.smartbro.net:25: unknown host.

** (claws-mail:12243): WARNING **: can't connect to server.

sylpheed just says: session timed out

I have never before experienced this in any distro. ???
Title: Re: VL-7.1-LIGHT
Post by: nightflier on May 22, 2014, 03:33:16 am
Code: [Select]
** (claws-mail:12243): WARNING **: DNS lookup failed

What is the content of your "/etc/resolv.conf" file?
Title: Re: VL-7.1-LIGHT
Post by: Pita on May 22, 2014, 04:03:03 am
Code: [Select]
cat /etc/resolv.conf
# Generated by dhcpcd from eth0
# /etc/resolv.conf.head can replace this line
domain smartbro.net
nameserver 121.1.3.81
nameserver 121.1.3.16
nameserver 121.1.3.66
# /etc/resolv.conf.tail can replace this line

That has not changed for ages. ;)
Title: Re: VL-7.1-LIGHT
Post by: nightflier on May 22, 2014, 04:09:00 am
Try replacing "121.1.3.81" with "8.8.8.8" and test again.
Title: Re: VL-7.1-LIGHT
Post by: Pita on May 22, 2014, 04:12:45 am
Try replacing "121.1.3.81" with "8.8.8.8" and test again.

Will do tomorrow. I am on my  night cap. ;)
Title: Re: VL-7.1-LIGHT
Post by: Pita on May 22, 2014, 07:56:31 pm
Try replacing "121.1.3.81" with "8.8.8.8" and test again.

Works!  :D
So I don't understand why.  ???
What would be the explanation and can that be corrected in future?
Title: Re: VL-7.1-LIGHT
Post by: nightflier on May 23, 2014, 03:10:46 am
Glad it's working for you.  :)

Your ISP's DNS server is slow to respond. DNS is like the phone book for the internet, your computer asks it where to find smartbro.net, then makes that connection. Probably, Sylpheed does not try enough pings, and/or doesn't wait long enough to get an answer, so it gives up. The time it waits before giving up can be adjusted in the preferences.

Google offers free DNS services on 8.8.8.8 and 8.8.4.4, and so does OpenDNS at 208.67.222.222 and 208.67.220.220. I have found these servers to be better than what my ISP delivers, and use them all the time. You can configure your network manager to do this.

Another "trick" is to check for incoming mail right before sending, as this can create a connection to the server that stays alive long enough to send.
Title: Re: VL-7.1-LIGHT
Post by: nightflier on May 24, 2014, 06:51:53 am
Light A0.2 is available. Known issues: Shutdown/Reboot menu does not work. Netsurf is missing deps. Solve these by enabling untested repo, then re-install sudo and netsurf.
Title: Re: VL-7.1-LIGHT
Post by: retired1af on May 24, 2014, 09:05:17 am
Google offers free DNS services on 8.8.8.8 and 8.8.4.4, and so does OpenDNS at 208.67.222.222 and 208.67.220.220. I have found these servers to be better than what my ISP delivers, and use them all the time.

Careful with the OpenDNS entries. I tend to block those at the firewall as do many other admins I know. If I recall correctly, Config Server Firewall (csf) has OpenDNS blocked as default.
Title: Re: VL-7.1-LIGHT
Post by: nightflier on May 24, 2014, 09:41:01 am
Why would you want to block OpenDNS?
Title: Re: VL-7.1-LIGHT
Post by: retired1af on May 24, 2014, 10:12:23 am
Same reason I block TOR.  :P
Title: Re: VL-7.1-LIGHT
Post by: Pita on May 25, 2014, 07:43:38 pm
Light A0.2 is available. Known issues: Shutdown/Reboot menu does not work. Netsurf is missing deps. Solve these by enabling untested repo, then re-install sudo and netsurf.

Can't install. :(

Installation hangs on installing python-2.7.6-* both with GUI and TUI.
Burned a DVD twice, no change. When python starts the install bar
jumps all the way to the end and installation stops.
md5sum of iso file OK.

Edit:
Now used unetbootin and installation run smoothly from USB stick. :D
Title: Re: VL-7.1-LIGHT
Post by: Pita on May 25, 2014, 11:49:04 pm
$ netsurf
netsurf: error while loading shared libraries: libnsbmp.so.0: cannot open shared object file: No such file or directory
vector:/~
$ sylpheed
sylpheed: error while loading shared libraries: libcompface.so.1: cannot open shared object file: No such file or directory
vector:/~
$ brasero
brasero: error while loading shared libraries: libtdb.so.1: cannot open shared object file: No such file or directory

ldd /usr/bin/netsurf| grep found
   libnsbmp.so.0 => not found
   libnsgif.so.0 => not found
   libwebp.so.4 => not found
   libcss.so.0 => not found
   libparserutils.so.0 => not found
   libwapcaplet.so.0 => not found
   libdom.so.0 => not found
   libhubbub.so.0 => not found

pnmixer Error
Could not bind the following hotkeys:
 XF86AudioMute
 XF86AudioRaiseVolume
 XF86AudioLowerVolume
Title: Re: VL-7.1-LIGHT
Post by: nightflier on May 26, 2014, 03:33:35 pm
Pita, thank you for that feedback. This ISO was created right after a rebuild of the untested repository, looks like we still have some kinks to work out there.
Title: Re: VL-7.1-LIGHT
Post by: Pita on May 26, 2014, 05:42:51 pm
Pita, thank you for that feedback. This ISO was created right after a rebuild of the untested repository, looks like we still have some kinks to work out there.

I saw quite a few wrong symlinks in /usr/lib. I will correct that and most likely
then brasero and sylpheed will open.

Stay tuned ;)

Worked only for Brasero.

Reinstalled sylpheed and netsurf. Both are now opening.  :D

Logout Menu now working with restart and  shutdown. Logout always worked.  ;D

Reinstalling pnmixer would not change error, not openng.  :(

Can't find now any further faults.   :)  

Just installed midori-0.5.8 and it crashes when clicking on "Edit" on menu bar. This happens as well in Salix-14.1 for which reason I reinstalled
midori-0.5.7. The drawback with that version, spellchecker is not working.
Title: Re: VL-7.1-LIGHT
Post by: M0E-lnx on May 27, 2014, 06:06:23 am
Midori works good for me except for the icons on the browser tabs. 
Title: Re: VL-7.1-LIGHT
Post by: Pita on May 27, 2014, 08:52:45 pm
Since I am no fan of midori I removed it. Just wanted to check if it crashes. And it does in 32bit.

However, Netsurf crashes as well:

Edit > Prefrences > Network > Crash 
Title: Re: VL-7.1-LIGHT
Post by: nightflier on May 28, 2014, 05:49:33 am
pnmixer Error
Could not bind the following hotkeys:
 XF86AudioMute
 XF86AudioRaiseVolume
 XF86AudioLowerVolume

Got it.. pnmixer is already running, as indicated by a speaker icon in the notification area. It should be started only once, from the startup script. Think I'll just remove the menu icon.
Title: Re: VL-7.1-LIGHT
Post by: Pita on May 28, 2014, 09:00:12 pm
Midori works good for me except for the icons on the browser tabs. 

Just made in installation of midori-0.5.8 in distro Slackel and it crashes
when cicking on 'Edit' on the mebubar.

So 0.5.8 crashes, 0.5.7 spellchecker not working remains stable 0.5.5
Title: Re: VL-7.1-LIGHT
Post by: Pita on May 28, 2014, 09:09:46 pm
pnmixer Error
Could not bind the following hotkeys:
 XF86AudioMute
 XF86AudioRaiseVolume
 XF86AudioLowerVolume

Got it.. pnmixer is already running, as indicated by a speaker icon in the notification area. It should be started only once, from the startup script. Think I'll just remove the menu icon.

I removed the menu icon. Removed as well gimp, samba and exaile since I do not use
those programs.

To me this VL-Light-7.1 is final. Furnishing the house now to my taste
like adding joe, xv, xpaint as well as my /usr/local partition where i have
dillo and other for me valuable programs. Fluxbox is running great with
my menu from present working distro.
Title: Re: VL-7.1-LIGHT
Post by: nightflier on June 05, 2014, 06:30:46 pm
The A0.2 ISOs have been cleaned up and rebuilt. If you want to check one out, find them here:
http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.1/iso/VL-7.1-LIGHT-A0.2.iso md5sum be6785167e9179372765b742cffecdc6
http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.1/iso/VL64-7.1-LIGHT-A0.2.iso md5sum 7a43cefc2ff7e6c400b01000487a25c9

Main changes: Removed netsurf, vcpufreq, gambas2-runtime, qt3, exaile, fluxbox, pnmixer menu entry.
Made separate IceWM entry for building menu and added option to have it created on every login.
Entry for optical drives in fstab (for brasero's benefit).
Sylpheed now works in my tests.

If things turn out to work okay, next step is to tweak package selection further. Midori or netsurf may replace firefox. Mtpaint instead of gimp. Xsane.. maybe not. Hexchat or Pidgin? Xscreensaver.. maybe for screen locking? Abiword and Gnumeric?
Title: Re: VL-7.1-LIGHT
Post by: Lyn on June 06, 2014, 04:36:15 am
How light are we aiming?  Is it going to be like the last light with a range of light desktops and appropriate tools or just sticking to IceWM?  If so the Abiword and Gnumeric would be good, if we are going more then maybe Ted and SIAG? 
Title: Re: VL-7.1-LIGHT
Post by: nightflier on June 06, 2014, 06:34:44 am
Not as light as before, and IceWM only.

The previous version was hand built, with shameless hacks to the text installer and liberties taken with respect to system configuration. This allowed you to install it on low end computers, but also created confusion and inconsistencies. This time the aim is compatibility with Standard, using the same installer and automated build system.

A better name might be just "IceWM Edition", but since Light is already established, we'll go with that. Target audience is previous IceWM users, and those who want full manual control over their UI.
Title: Re: VL-7.1-LIGHT
Post by: wigums on June 06, 2014, 11:16:43 am
for what its worth i have problems with midori regardless of which distrobution its on. it would be nice if the damn thing ever worked right
Title: Re: VL-7.1-LIGHT
Post by: Lyn on June 07, 2014, 01:44:20 am
Thanks for the clarification, as you know I am a fan of IceWM and think we have had very slick implementations of it. interesting you are doing both 32 and 64 bit versions.
Title: Re: VL-7.1-LIGHT
Post by: nightflier on June 07, 2014, 04:43:37 am
for what its worth i have problems with midori regardless of which distrobution its on. it would be nice if the damn thing ever worked right

Have to agree with you there. Finally got it looking okay by tweaking the icon themes, but trying to use it is frustrating. Have yet to figure out how to make the search field work. And what's with the current browser disease of forcing you to display the tab bar at all times?

If we can fix Netsurf so it doesn't crash when you click Edit > Preferences > Network, it will be the default.
Title: Re: VL-7.1-LIGHT
Post by: nightflier on June 07, 2014, 04:55:51 am
Thanks for the clarification, as you know I am a fan of IceWM and think we have had very slick implementations of it. interesting you are doing both 32 and 64 bit versions.

With the autmatic build system, there is very little additional effort in doing both versions.  ;D

BTW, the icewmvmods package will now install on STD and pull in deps to create the "Light" environment. Note that you get wicd with it, so you'd need to uninstall NetworkManager. Reason for going with wicd: it is smaller, and I had problems with the nm-applet display in the icewm notification area.
Title: Re: VL-7.1-LIGHT
Post by: Pita on June 07, 2014, 06:36:20 pm
I have a new package of midor from http://salix.hostingxtreme.com/i486/14.1/salix/xap/
and it seems to work well now.

Today
http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.1/iso/
does not open so I cannot download new A02 version.

Title: Re: VL-7.1-LIGHT
Post by: retired1af on June 08, 2014, 04:22:11 am
Here's a direct link Pita.

http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.1/iso/VL-7.1-LIGHT-A0.2.iso
Title: Re: VL-7.1-LIGHT
Post by: nightflier on June 08, 2014, 06:17:01 am
I have a new package of midor from http://salix.hostingxtreme.com/i486/14.1/salix/xap/

Salix's package does come with the search engines configured, they even included entries for their own forum and wiki. Pretty slick. The file containing the definitions is in /etc/xdg/midori/search. We should do something similar.

EDIT: New package now has search engines configured.
Title: Re: VL-7.1-LIGHT
Post by: Pita on June 09, 2014, 01:08:11 am
New VL-7.1-LIGHT-A0.2.iso
$ sylpheed
sylpheed: error while loading shared libraries: libcompface.so.1: cannot open shared object file: No such file or directory

locate libcompface*
none

Will pull it over later from previous VL-7.1-LIGHT-A0.2.iso

Title: Re: VL-7.1-LIGHT
Post by: nightflier on June 09, 2014, 02:54:23 am
That was unexpected, compface was added to the iso built on June-05-2014.

Installing compface using gslapt should fix this, but I wonder what else might have failed to install.
Title: Re: VL-7.1-LIGHT
Post by: Pita on June 11, 2014, 04:15:25 am
That was unexpected, compface was added to the iso built on June-05-2014.

Installing compface using gslapt should fix this, but I wonder what else might have failed to install.

Can't find any further big faults, except an audio CD still plays choppy with smplayer. It is like it keeps on buffering. No such problem playing a DVD.

Sending mail with sylpheed needs /etc/resolv.conf to be set to 8.8.8.8.
Title: Re: VL-7.1-LIGHT
Post by: roarde on December 05, 2014, 12:32:08 am
Installed 32-bit RC1 using delta from B1.1. WARNING: There were at least two versions of B1.1, so delta may not work for the B1.1 you have.

On B1.1, installer locked up after "installing bootloader". I used the same setup and options to install RC1. Install was flawless and completed normally :)

Normal user couldn't see bold text in manpages. Root didn't have this problem. Turned out default for bold is high white. Solution is to edit /usr/share/roxterm/Config/Colours/GTK. Find "cursor=#939309b609b6". Put "bold=#146108870887" as the next line. For users that have already modified the color scheme, the change goes in ~/.config/roxterm.sourceforge.net/Colours/GTK .

EDIT: "bold=060606060606" is both simpler and bolder. The first was picked from the color wheel, this one by trial-and-error edit.

Installed HexChat. Icon doesn't show on menu. I'll look around for a way for xdgmenumaker to pick this up automatically.
Title: Re: VL-7.1-LIGHT
Post by: roarde on December 05, 2014, 12:49:57 pm
HexChat icon:
HexChat installation wasn't updating icon cache. Looks like using the index files is where xdgmenumaker gets some of its speed.

Tried the new hexchat package in untested (2.10.2) and that worked  :)   I assume a later ISO build would pick this up, dunno.
Title: Re: VL-7.1-LIGHT
Post by: M0E-lnx on December 05, 2014, 01:26:24 pm
HexChat icon:
HexChat installation wasn't updating icon cache. Looks like using the index files is where xdgmenumaker gets some of its speed.

Tried the new hexchat package in untested (2.10.2) and that worked  :)   I assume a later ISO build would pick this up, dunno.
Your hexchat packages have been moved to extra... so yes, the next ISO will have the updated version
Title: Re: VL-7.1-LIGHT
Post by: roarde on December 05, 2014, 01:49:04 pm
HexChat icon:
HexChat installation wasn't updating icon cache. Looks like using the index files is where xdgmenumaker gets some of its speed.

Tried the new hexchat package in untested (2.10.2) and that worked  :)   I assume a later ISO build would pick this up, dunno.
Your hexchat packages have been moved to extra... so yes, the next ISO will have the updated version

Or wait. No it won't. Hexchat isn't on the ISO in the first place  :D  My bad.
Title: Re: VL-7.1-LIGHT
Post by: nightflier on December 06, 2014, 10:54:30 am
Normal user couldn't see bold text in manpages. Root didn't have this problem. Turned out default for bold is high white. Solution is to edit /usr/share/roxterm/Config/Colours/GTK. Find "cursor=#939309b609b6". Put "bold=#146108870887" as the next line. For users that have already modified the color scheme, the change goes in ~/.config/roxterm.sourceforge.net/Colours/GTK .

EDIT: "bold=060606060606" is both simpler and bolder. The first was picked from the color wheel, this one by trial-and-error edit.

Good catch, good fix!
Title: Re: VL-7.1-LIGHT
Post by: Pita on December 07, 2014, 07:46:01 pm
VL-7.1-LIGHT-RC1.iso 32bit PC Desktop

Burned on DVD

GUI installer would disable forward and back after saying "None" for choose boot loader. :(

TUI installer run until installing LibXmu then the install bar went to 100 %
and installation stopped. :(
Title: Re: VL-7.1-LIGHT
Post by: nightflier on December 08, 2014, 03:35:52 am
@Pita: My guess is read errors from media during install. The usual suspects are iso download errors (check md5sum), bad disc burn, and scratches/smudges on disc surface. I wash discs with soap and warm water before burning.

When possible, I prefer a USB stick prepared with unetbootin. Quicker and easier, with file system error correction.
Title: Re: VL-7.1-LIGHT
Post by: Pita on December 08, 2014, 11:44:55 pm
@Pita: My guess is read errors from media during install. The usual suspects are iso download errors (check md5sum), bad disc burn, and scratches/smudges on disc surface. I wash discs with soap and warm water before burning.

When possible, I prefer a USB stick prepared with unetbootin. Quicker and easier, with file system error correction.

I think you are right I must discard this badly scratched DVD.

Installed with unetbootin. GUI run smooth. Booted with Sackware Linux custom USB boot stick and I love what I see.  ;D

The few programs tested I have seen no kinks. My old Epson impact printer was detected and is printing.   :)

"at" wants me to be root. I can change that.

Title: Re: VL-7.1-LIGHT
Post by: Pita on December 09, 2014, 07:30:08 pm
Moved /etc/at.deny to /etc/at.deny and "at" now accepts user.  :)

Adobe Flash Player Preferences crashes when Playback is clicked.

UseMouseWheel=1 in .icewm/preferences does not seem to work.
Title: Re: VL-7.1-LIGHT
Post by: roarde on December 09, 2014, 09:12:44 pm
Moved /etc/at.deny to /etc/at.deny and "at" now accepts user.  :)

I needed this info right now. Thank you.
mv /etc/at.deny.new /etc/at.deny, right?
Title: Re: VL-7.1-LIGHT
Post by: Pita on December 12, 2014, 08:02:17 pm
Moved /etc/at.deny to /etc/at.deny and "at" now accepts user.  :)

I needed this info right now. Thank you.
mv /etc/at.deny.new /etc/at.deny, right?

Yes, however, it seems "at" is not started on login. One has to go as root to /etc/rc.d/init.d
and
Code: [Select]
./at start
Title: Re: VL-7.1-LIGHT
Post by: Pita on December 12, 2014, 08:07:48 pm
It seems "at" is not started on login.

Would like that on double-click of title bar window would roll-up
instead of maximize. How to do? Can't get Alt+F12 to work.

Would like to scroll with mouse wheel on desktop to different work-spaces.

Title: Re: VL-7.1-LIGHT
Post by: roarde on December 12, 2014, 10:49:11 pm
It seems "at" is not started on login.
Mea culpa. Can't decide whether to put service selection back on vasm menu as-is, or keep trying to find time to edit it.    
As root, start 'vsrvset' and select 'at' on any runlevels you want it for.


Can't get Alt+F12 to work.
I'm guessing that X doesn't know it's an "extended" keyboard. I don't know how to fix it the correct way using xorg.conf.d, but someone else might. Please post the output of
Code: [Select]
grep xkb_model /var/log/Xorg.0.log



Would like that on double-click of title bar window would roll-up
instead of maximize. How to do?

~/.icewm/preferences:
Code: [Select]
#  TitleBar mouse-button double click to maximize the window
TitleBarMaximizeButton=0 # [0-5]

#  TitleBar mouse-button double click to rollup the window
TitleBarRollupButton=1 # [0-5]
Since maximize double-click on button 1 is the compiled-in default, you do have to disable that (like above) for putting rollup there to work. Restart IceWM.
Title: Re: VL-7.1-LIGHT
Post by: Pita on December 13, 2014, 03:38:12 pm
Thanks!
Rollup with double click on title bar is now working.
I had the line "TitleBarMaximizeButton=1 # [0-5] " just disabled with # and that did not work.

In the early days with RedHat double click on the title bar was always roll-up.
A tradition which Fluxbox still continuous.  ;D
For me unknown reason that double click was changed to maximize.  :P
I personally have seldom a need to maximize a window, however, quite often to roll-up.

Code: [Select]
grep xkb_model /var/log/Xorg.0.log
[    58.376] (**) Option "xkb_model" "evdev"
[    58.403] (**) Option "xkb_model" "evdev"
[    58.406] (**) Option "xkb_model" "evdev"
[    58.407] (**) Option "xkb_model" "evdev"
[    58.410] (**) Option "xkb_model" "evdev"

In my working box that is pc104.

BTW the burn program flburn works perfectly. I think better than xfburn.
That program could not burn on a certain DVD whereas flburn could.
Title: Re: VL-7.1-LIGHT
Post by: roarde on February 26, 2015, 07:04:05 pm
VL 7.1 Light RC 1.2:
Wget can't download an https link. Same problem makes QupZilla crash when SSL is encountered.

It's possible that this is a local problem. Someone else, who installed to a VM, reported it worked normally for them.

Could someone with an RC 1.2 install on real hardware check this out please? Be sure that running 'openssl version' returns "1.0.1j" as the version number. (see edit, below)

Easy way to see if it works:
Code: [Select]
wget https://bitbucket.org/VLCore/vl71/raw/HEAD/var/vabs/VL-ISO-LIGHT/src/VL-ISO-LIGHT.SlackBuildor use any https file URL that you're sure won't revert to http.

thanks

Edit: Right after posting, 1.0.1k appeared in untested. Upgrading to it fixes the problem. Besides enabling untested, you might have to temporarily disable patches to get this -- or download directly and installpkg.

1.0.1k (or a yet-unreleased newer version) should appear on the next ISO, so this isn't a continuing issue. Leaving the post for the record.
Title: Re: VL-7.1-LIGHT
Post by: roarde on March 08, 2015, 03:00:50 am
RC 1.2:
Ok, this is boring:
I've been using this for a while now. After handling the issue above, I have nothing else to report   ;D

I will suggest that those coming directly from 7.0 Light, or bringing in an existing IceWM setup, not allow their present ~/.icewm directory to be copied to the new install; rather, back it up or rename it. You'll miss nice features otherwise IMO. Configure the fresh install for a bit, then manually bring over your own stuff that you still miss.
Title: Re: VL-7.1-LIGHT
Post by: nightflier on March 08, 2015, 05:36:56 am
One of the reasons why I like IceWM, is that it stays the way I set it, and doesn't change unless I tell it to.
Still, some changes are worth checking out, as roarde points out.
Some features which we feel are improvements in this version:
- Menu generator: The homegrown version has been replaced by xdgmenugenerator, which is a lot faster. You have the option to automatically generate the menu on each login.
- File manager: Spacefm provides advanced features like device auto-mounting and remote file system access, while staying small and unobtrusive.
- Volume applet: PNMixer adds features like multimedia key bindings.

Title: Re: VL-7.1-LIGHT
Post by: Lyn on March 15, 2015, 10:07:22 am
Success. Loaded on an old Toshiba laptop and it looks really good.  So far no issues -will investigate further
Title: Re: VL-7.1-LIGHT
Post by: nightflier on May 22, 2015, 06:02:53 pm
Gentlemen, Light RC2 is now out for your testing pleasure.  ;D
Title: Re: VL-7.1-LIGHT
Post by: roarde on May 28, 2015, 05:03:24 pm
"Pleasure"? What? What with lack of problems and not even a nitpick I can pretend is worth reporting, it's downright boring. A snoozer ;)
Title: Re: VL-7.1-LIGHT
Post by: nightflier on May 30, 2015, 06:04:00 am
Okay, forget RC2.
Go to RC2.1 instead.
It has the latest LTS kernel, 3.18.14.

FWIW, I'm keeping this one as my own "final".  ;D
Title: Re: VL-7.1-LIGHT
Post by: overthere on May 30, 2015, 02:35:07 pm
As user in /home/someone/.icewm/toolbar I added: prog "Log-Out" /usr/share/icewm/icons/logout.png /usr/share/icewm/shutdown-dialog

although this added a logout button to the panel..is it possible to move it to the right next to the clock?

have been hunting but not confident

 :-[ :-\ :)
Title: Re: VL-7.1-LIGHT
Post by: nightflier on May 31, 2015, 04:31:24 am
Good question.. I can't find anything about adding something to the right of the clock. It may not be an option.
Title: Re: VL-7.1-LIGHT
Post by: overthere on May 31, 2015, 11:56:13 am
I concur..not an option..thanks
Title: Re: VL-7.1-LIGHT
Post by: Pita on June 20, 2015, 08:30:36 pm
Have the latest RC installed.

All seems to work fine. Wonder why it is still a Release Candidate.

I have a problem with skype-4.3.0.37. Sound test echo fails, does not replay
my message. In my other linux box in skype ctrl-o>Sound Deivices  I can do
settings for pulseaudio and get replay of message working. This setting possibility
is absent here in VL-Light.

Installed pavucontrol with --no-dep since it is looking for gtkmm which I cannot find.
Now PulsAudioVolumeControl does show in skype Sound Devices, however, will not open.
Title: Re: VL-7.1-LIGHT
Post by: nightflier on June 21, 2015, 06:08:52 am
The repos still need some work before we can go final.

Installing a package without dependencies often leaves it non-functional. To obtain the deps for pavucontrol you need to enable the "untested" repo.  (http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.1/x86/ for 32-bit). That will pull in gtkmm plus a few other packages.

Where did you get Skype from, and what type of installer?
Title: Re: VL-7.1-LIGHT
Post by: sledgehammer on June 21, 2015, 07:51:41 am
I removed skype from my system as soon as Gates bought it.  We need to stand up to these monopolists whenever possible.  There are alternatives.
Title: Re: VL-7.1-LIGHT
Post by: Pita on June 21, 2015, 09:13:17 pm
The repos still need some work before we can go final.

Installing a package without dependencies often leaves it non-functional. To obtain the deps for pavucontrol you need to enable the "untested" repo.  (http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.1/x86/ for 32-bit). That will pull in gtkmm plus a few other packages.

Where did you get Skype from, and what type of installer?

http://slackbuilds.org/repository/14.1/network/skype/

Will check on gtkmm later

Title: Re: VL-7.1-LIGHT
Post by: Pita on June 21, 2015, 09:15:22 pm
I removed skype from my system as soon as Gates bought it.  We need to stand up to these monopolists whenever possible.  There are alternatives.

I fully agree! Unfortunately my contacts are Windows blokes. Hard to change.

And how about those using skype with their cellphone or iphone?
Title: Re: VL-7.1-LIGHT
Post by: nightflier on June 22, 2015, 05:07:43 am
This really belongs in a different topic, and opens up several cans of worms. A few thoughts:
- Best approach would be to make a request for Skype in the "New package requests" area.
Otherwise, working with what you have:
- Enable the untested repo and re-install pavucontrol. It will pull in 7 other pkgs as deps.
- Read the notes that come with that slackbuild: http://slackbuilds.org/slackbuilds/14.1/network/skype/README.SLACKWARE
- You may try to use the "Dynamic" package on the Skype download page.
Title: Re: VL-7.1-LIGHT
Post by: retired1af on June 22, 2015, 05:20:44 am
Unfortunately, Skype under Linux is notoriously buggy and unstable, even for those distros that are more mainstream and provide Skype in their distribution repos.
Title: Re: VL-7.1-LIGHT
Post by: nightflier on June 22, 2015, 02:12:22 pm
I got skype working on Light.  ;D

First, I installed pavucontrol+deps from untested repo.
Next, I downloaded the "dynamic" version from skype.com,
extracted it (as root) to /opt with "tar xvf skype-4.3.0.37.tar.bz2 -C /opt"
Then run "/opt/skype-4.3.0.37/skype" (as user).

Had to fiddle with pavucontrol to find the correct settings, but finally made a successful test call.
Title: Re: VL-7.1-LIGHT
Post by: Pita on June 23, 2015, 01:20:13 am
I got skype working on Light.  ;D

First, I installed pavucontrol+deps from untested repo.
Next, I downloaded the "dynamic" version from skype.com,
extracted it (as root) to /opt with "tar xvf skype-4.3.0.37.tar.bz2 -C /opt"
Then run "/opt/skype-4.3.0.37/skype" (as user).

Had to fiddle with pavucontrol to find the correct settings, but finally made a successful test call.

Got mine working as well.  :)
However, the skype from the site I mentioned before.
5 libraries had to be installed from untested repo.
Title: Re: VL-7.1-LIGHT
Post by: nightflier on July 20, 2015, 07:32:09 am
Almost there, guys. I have the final iso's ready here:
http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.1/iso/VL-7.1-LIGHT.iso
http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.1/iso/VL64-7.1-LIGHT.iso

All testers are encouraged to give this one a try. If none of you find any show stoppers, we'll release it to the general public the way it is.

Happy hacking!   ;D
Title: Re: VL-7.1-LIGHT
Post by: Lyn on July 21, 2015, 04:06:43 am
Will test over the weekend :-)
Title: Re: VL-7.1-LIGHT
Post by: Pita on July 22, 2015, 12:36:33 am
32 bit

Bloody fast!

Sylpheed will not open when clicked from menu, either desktop or panel.
Does open with command from terminal and working properly.

Title: Re: VL-7.1-LIGHT
Post by: roarde on July 22, 2015, 01:59:00 pm
Light 7.1 is even more compatible with STD and the repos than was 7.0. A fix applied to the ISO dated 18 July would have caused problems for STD users if that updated package were moved to the stable repos. This was a "show stopper", as nightflier termed it. Light worked fine (with you in a moment, Pita), but needed to be changed so Light and STD would continue to cooperate seamlessly.

There's a new final ISO, dated 22 July. If there's anyone who'd like to check it out and hasn't tried yet, download that one. Those who have the "old" one have the option of using delta files to decrease the total size of downloads:

This is written for a 32-bit machine; those using the 64-bit version should substitute 'VL64-' where I say 'VL-'.

I repeat: If bandwidth is no problem for you, just downloading the present ISO is easier, and you can skip the rest.

Change to the directory where VL-7.1-LIGHT.iso is stored. Download the delta files to that directory.
http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.1/iso/VL-7.1-LIGHTtoRC3.3.delta
http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.1/iso/VL-7.1-LIGHT-RC3.3to_release_.delta
64-bit:
http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.1/iso/VL64-7.1-LIGHTtoRC3.3.delta
http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.1/iso/VL64-7.1-LIGHT-RC3.3to_release_.delta

If you already have VL-7.1-LIGHT.iso.md5sum.txt, rename or delete it and get the new sum
http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.1/iso/VL-7.1-LIGHT.iso.md5sum.txt
64:
http://vlcore.vectorlinux.com/pkg/untested/veclinux-7.1/iso/VL64-7.1-LIGHT.iso.md5sum.txt

Generate the first new ISO
Code: [Select]
xdelta patch VL-7.1-LIGHTtoRC3.3.deltaxdelta has little, or usually nothing, to say. On a slower machine, go get a cup of coffee.

Code: [Select]
echo $?Should say "0"; this is an extra check before going further.

Now rename, move, or delete VL-7.1-LIGHT.iso. The next step creates a new one.
Code: [Select]
xdelta patch VL-7.1-LIGHT-RC3.3to_release_.delta    # and wait
md5sum -c VL-7.1-LIGHT.iso.md5sum.txt

@Pita
Thanks for reporting your problem with Sylpheed startup. No one has been able to duplicate it. If you can, please try the new ISO.
Title: Re: VL-7.1-LIGHT
Post by: Pita on July 22, 2015, 08:08:33 pm
Installed Jul. 22 version.

Sylpheed still not opening from menus opens only from terminal command.

Copied /usr/share/applications/sylpheed.desktp to ~/Desktop/
Chown to user:user
Clicking on desktop icon sylpheed will not open. Trying execute, same no dice.

Next:
:$ qupzilla
qupzilla: /usr/lib/libcrypto.so.1: no version information available (required by /usr/lib/libQupZilla.so.1)
qupzilla: symbol lookup error: qupzilla: undefined symbol: _ZN2Qz7VERSIONE

Tried to open all programs on menu only sylpheed will not open and qupzilla.
Title: Re: VL-7.1-LIGHT
Post by: Pita on July 22, 2015, 11:53:54 pm
Got sylpheed working with clicking from menus or desktop icon.  ;D

How? Copied from my working box ~/Desktop/sylpheed.desktop to VL-Light ~/Desktop/  ???
Both look the same.
Title: Re: VL-7.1-LIGHT
Post by: Pita on July 23, 2015, 12:27:55 am
Made an upgrade via gslapt.

Qupzilla now working  :D from menus.
Title: Re: VL-7.1-LIGHT
Post by: nightflier on July 23, 2015, 04:23:36 am
Thanks for the reports pita.  Not sure what caused your problems, but sounds like you got it fixed. That's the kind of hacking and experimenting that Light encourages.  :)
Title: Re: VL-7.1-LIGHT
Post by: Pita on July 24, 2015, 12:21:51 am
Installed fluxbox, my favored desktop. Feel more at home that way.

Now comes the tedious task of building a distro to my liking. After VL-4.8
I have used VL-Light as the base for my VL box.

Title: Re: VL-7.1-LIGHT
Post by: overthere on July 24, 2015, 12:53:11 am
pita..curious if you notice any issues with fluxbox 1.3.6 or 7

I find the once (previous) right click on the panel for panel menu now a middle click and the slit right click problematic but the desktop right click menu works fine so far including the configure features for panel and slit

I found that 1.3.5 does not have the issue but still unclear on the nessessity to upgrade

as a fan of fluxbox I thought you may offer insight..
Title: Re: VL-7.1-LIGHT
Post by: roarde on July 24, 2015, 08:21:02 pm
A common fluxbox "starting point" meta-package would be nice to have. Something with more features and more complete config, but geared to assist users creating the fluxbox desktop they want.
Title: Re: VL-7.1-LIGHT
Post by: overthere on July 24, 2015, 10:07:55 pm
Interesting
overthere out
Title: Re: VL-7.1-LIGHT
Post by: Pita on July 25, 2015, 01:37:48 am
pita..curious if you notice any issues with fluxbox 1.3.6 or 7

I find the once (previous) right click on the panel for panel menu now a middle click and the slit right click problematic but the desktop right click menu works fine so far including the configure features for panel and slit

I found that 1.3.5 does not have the issue but still unclear on the nessessity to upgrade

as a fan of fluxbox I thought you may offer insight..

Yes the click on the panel changed as you noticed. I do not see any problem with slit.

Check: http://fluxbox.org/news/
for changes.