VectorLinux

The nuts and bolts => Software General => Topic started by: CrazyDog on May 19, 2014, 11:22:57 pm

Title: Chromium
Post by: CrazyDog on May 19, 2014, 11:22:57 pm
I would like to know if there is any way that Chromium could be included in the repositories?  Sorry if this has been asked before.  I asked over at the Salix forum, but they have no plans to add it as a choice in gslapt.

Thanks!
Title: Re: Chromium
Post by: retired1af on May 20, 2014, 04:32:22 am
I found a slack package in the Slack repo, but it has... issues.

I, too, would like a Chromium package as well. I don't use it, but it would be helpful to have it on hand when I need to test things.
Title: Re: Chromium
Post by: M0E-lnx on May 20, 2014, 11:16:40 am
I'm currently building chromium for 7.1.  It is a monster to build, so it will take a few hours.  If everything goes well, we should have a package in the untested repo soon.  Build link: http://vlcore.vectorlinux.com/buildbot/builders/chromium/builds/4
Title: Re: Chromium
Post by: CrazyDog on May 21, 2014, 01:26:56 am
I'm currently building chromium for 7.1.  It is a monster to build, so it will take a few hours.  If everything goes well, we should have a package in the untested repo soon.  Build link: http://vlcore.vectorlinux.com/buildbot/builders/chromium/builds/4


Thank you so much!   I really do appreciate it.   ;D
Title: Re: Chromium
Post by: M0E-lnx on May 22, 2014, 04:11:54 am
The build was succesful.  The package is in untested.  Test it and let us know if you get any issues with it
Title: Re: Chromium
Post by: nightflier on May 22, 2014, 04:36:19 am
Semi-good test on my system.

It upgraded sqlite and mozilla-nss in the progress.
The .desktop lists the executable as '/usr/bin/chromium' but is actually found in '/usr/lib/chromium/chromium'.

Quick test of browser indicates proper operation.  :)
Title: Re: Chromium
Post by: retired1af on May 22, 2014, 05:26:18 am
Bombs on 64-bit. Wrong location in chromium.desktop as described by Nightflier. Manual attempt via terminal results in:

retired1:$ /usr/lib64/chromium/chromium
/usr/lib64/chromium/chromium: /usr/lib64/libnss3.so: version `NSS_3.14.3' not found (required by /usr/lib64/chromium/chromium)
Title: Re: Chromium
Post by: M0E-lnx on May 22, 2014, 12:19:02 pm
Bombs on 64-bit. Wrong location in chromium.desktop as described by Nightflier. Manual attempt via terminal results in:

retired1:$ /usr/lib64/chromium/chromium
/usr/lib64/chromium/chromium: /usr/lib64/libnss3.so: version `NSS_3.14.3' not found (required by /usr/lib64/chromium/chromium)

Did this upgrade mozilla-nss?.  If not, could you upgrade it via slapt-get andd try to launch again?
Title: Re: Chromium
Post by: M0E-lnx on May 23, 2014, 10:33:03 am
I re-built the package, fixed the path to the binary and tested on 64-bit myself.  Seems to work.

Anyone who wants to try out the new package, use slapt-get or gslapt to remove your current package, and install the new one. 

NOTE:  Package name did not change, so it will not show up as an update.
NOTE2:  Package must be installed with gslapt or slapt-get with the untested repository enabled.  Otherwise, it will not find the Mozilla-nss package it needs.
Title: Re: Chromium
Post by: nightflier on May 24, 2014, 05:40:14 am
Posting from it now. Installed on 64-bit Light A0.2. No additional packages were needed.
Title: Re: Chromium
Post by: retired1af on May 24, 2014, 08:55:50 am
Installed via gslapt. Works perfectly now. :)
Title: Re: Chromium
Post by: M0E-lnx on May 24, 2014, 03:52:50 pm
Nice.  Thanks for testing
Title: Re: Chromium
Post by: solex on July 05, 2014, 06:51:58 pm
Can some one post instructions for the lame on how to install?

I added http://bitbucket.org/VLCore/vl71/ as a package source but it fails to pull.

"This package source failed or is not available.  Do you want to disable..."

Thank you,
Dan
Title: Re: Chromium
Post by: bigpaws on July 05, 2014, 08:35:46 pm
You need to enable the testing repo in the glsapt sources.

The path you tried is only information about the package.

You can get the package here:

http://vectorlinux.osuosl.org/veclinux-7.1/extra/xap/Network/ (http://vectorlinux.osuosl.org/veclinux-7.1/extra/xap/Network/)

HTH

Bigpaws
Title: Re: Chromium
Post by: solex on July 06, 2014, 06:48:35 am
BigPaws,

I got the same error when adding the url as a source.

Any ideas?
Dan
Title: Re: Chromium
Post by: retired1af on July 06, 2014, 07:47:16 am
Did you run "Update" to ensure the lists are current?
Title: Re: Chromium
Post by: nightflier on July 06, 2014, 09:51:31 am
BigPaws,

I got the same error when adding the url as a source.

Any ideas?
Dan

Make sure you added source http://vectorlinux.osuosl.org/veclinux-7.1/extra/
It should already be listed in gslapt, and you should only have to check the box next to it.