The nuts and bolts => Office & Printing => Topic started by: overthere on June 29, 2015, 05:11:04 pm

Title: (SOLVED) xsane segfault
Post by: overthere on June 29, 2015, 05:11:04 pm
I have a brother MFC-685cw wireless and a canoscan n670u usb satillite. a100 laptop.VL7.1 std 32 final

after converting the brother drivers .rpm to .txz and installing the printer appeared in print settings and from there I added the wireless..printing appears to work so far wireless or usb

when I attempted a scan xsane found nothing, so in terminal I did

brsaneconfig2 -a name=SCANNER_mfc685CW model=MFC-685CW (x=ip)( command found on google search????

now xsane scanned and found the device and opened as expected

However after preview which looked ok I clicked SCAN. at the end of the scan xsane vanished, in terminal it simply posts segmentation fault. I did half dozen scans

when I plug in the usb canoscan, xsane scans and gives option for mfc685cw or cannon..I choose cannon and xsane opens as expected but the same occurs...segfault after scan

it does not matter if I select an alternative file format, jpg, pdf does not save...but does create several files likely the temp files and the unconverted scan in .ppm.

I feel lucky the wireless printer works and thought if the scanner did not I could use the usb one, as it worked on vector last time I tried it..beta or early rc..

any thoughts on what may be causing the segmentation fault??? perhaps I can remove the brscan driver or perhaps I missed a step..the directions were for redhat so no exactly usefull and the brscanconfig line was I think from an arch forum post
Title: Re: xsane segfault
Post by: roarde on June 29, 2015, 09:50:52 pm
I have to wonder if it might be the UI that's crashing.

Is anyone scanning succesfully with xsane on 32-bit?

How about 64-bit? Working or segfaulting?
Title: Re: xsane segfault
Post by: M0E-lnx on June 30, 2015, 06:08:08 am
We would have to wait for other users to confirm this.  Your driver installation and hardware is not something I own to be able to reproduce this.
Title: Re: xsane segfault
Post by: overthere on June 30, 2015, 06:29:23 pm
No worries
The reason I mentioned it is because the canoscan is simple usb and requires no special driver. with previous beta and rc that I tested it on it worked by simply plugging into the usb port and clicking xsane.

I did a reinstall of Vector std 32 to insure that no other apps or drivers cause the issue but the same segfault.

perhaps the gui so could try a different version perhaps..will check the depend list also when I have time
Title: Re: (SOLVED) xsane segfault
Post by: overthere on July 01, 2015, 04:40:36 pm
This has been solved..the default at the top of the window was set to viewer by default and I did not realize it needed to be set to save or other option. after setting to save the default was saved as the save settings on exit was checked in preferences. so it now appears to work as previously experienced. it still segfaults when set on viewer, but I do not know what the option implies...likely no viewer to show the scan? any case my bad for not seeing the obvious..will try the wireless again..thanks

btw was amazed how easy it was to set up the mfc
Title: Re: (SOLVED) xsane segfault
Post by: SmartDuck on August 06, 2015, 08:30:42 am
Got the same segfault here too. The Viewer option does not work. So this issue is not solved yet.
Scanning does works fine with the HP DeskJet 3050a network printer here.
The viewer is not found on the system. Preferences has a viewer setting in the fax settings.
ghostscript is installed and the gs command works, but not found from xsane? or a link missing?