VectorLinux

The nuts and bolts => Networking & Security => Topic started by: StrayBit on January 09, 2017, 04:49:16 pm

Title: IOGEAR USB Wireless
Post by: StrayBit on January 09, 2017, 04:49:16 pm
Used the network settings to set the ssid to my router.  Left the other spaces blank.  No connection!
lspci
02:00.0 Ethernet Controller Broadcom Corporation NetXtreme BCM5751 Gigabit Ethernet PCI Express (rev 01)
lsusb
Bus 001 Device 004: ID Bace:1215 ZyDAZ 2D1211B 802.11g
iwconfig
wlan0 IEEE 802.11bg ESSID:off/any
Mode:Managed Access Point:Not Associated Tx-Power=20dbm
retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off

The WAP is using Encryption (not the weak one)
This is happening in both 7.1 and 7.2b1.1.  What do I do now?
Title: Re: IOGEAR USB Wireless
Post by: bigpaws on January 09, 2017, 10:18:58 pm
It does not appear that the essid is set.
As root:

Try ifconfig to test if the interface is up more than likely wlan0
but there are other names it could be.

You can try below.

iwconfig essid "AP Name"

NOTE: remove the quotes and replace  AP Name with the essid.

Then try iwconfig and test.

If that works then set the key

iwconfig wlan0 enc <key>

NOTE: wlan0 should be replaced with the interface name and key should remove <> and replace key with the key

HTH

Bigpaws

Title: Re: IOGEAR USB Wireless
Post by: StrayBit on January 10, 2017, 12:00:59 pm
Thanks for your reply, Bigpaws.
I moved the device to another port and see that I made a couple of mistakes - couldn't read my own writing!
lsusb
Buss 001 Device 005: ID 0ace:1215 XyDAS 2D1211B 802.11g
ifcofig shows only wlan0 (other than lo and ethernet
iwconfig essid qwest5177
  Unknown command qwest5177
lwconfig  no change
Title: Re: IOGEAR USB Wireless
Post by: bigpaws on January 10, 2017, 02:41:07 pm
I screwed that up:

iwconfig wlan0 essid "AP Name"

Follow the notes.

See if that gets it going.

Bigpaws
Title: Re: IOGEAR USB Wireless
Post by: StrayBit on January 10, 2017, 05:28:40 pm
After transposing essid and wlan0, which didn't work so I tried the way you said.  The only difference:
iwconfig
wlan0 IEEE 802.11bg ESSID:"qwest5177"
Still no connection.  And somewhere it is supposed to ask for the pass phrase.
Title: Re: IOGEAR USB Wireless
Post by: bigpaws on January 11, 2017, 06:00:14 am
You will need wpa_supplicant to finish the connection.

This site should get you going.

http://linux.icydog.net/wpa.php (http://linux.icydog.net/wpa.php)

I do not know why the gui tools are having a problem.
This has been forwarded to the devs.

Bigpaws
Title: Re: IOGEAR USB Wireless
Post by: M0E-lnx on January 11, 2017, 06:34:16 am
Couple of questions.

post the output of
Code: [Select]
cat /etc/vector-versionpost the output of
Code: [Select]
uname -apost the output of
Code: [Select]
lsmod |grep -i wlan
Title: Re: IOGEAR USB Wireless
Post by: StrayBit on January 11, 2017, 09:54:28 am
bigpaws: I got everything to work except the last command:
Quote
Vector://home/bruce
root# dhclient -r
root# dhclient wlan0
and do I have to
Quote
root# wpa_supplicant -Dwext -iwlan0 -c/home/bruce/wpa.conf
every time I boot up?

MOE-lnx:
Quote
cat /etc/vector-version
7.2 STD B1.1 built on Dec-20-2016
#uname -a
Linux vector 4.4.39 SMP Mon Dec 19 15:21:26 CST 2016 i686 Intel(R) Pentium(R) 4 CPU 3.60 GHz GenuineIntel GNU/Linux
lsmod |grep -i wlan
Vector://home/bruce
root#
Title: Re: IOGEAR USB Wireless
Post by: bigpaws on January 11, 2017, 06:03:05 pm
Try dhcpcd -k
dhcpcd

See if that works.

dhclient is not a command in Vector or Slackware.

Bigpaws
Title: Re: IOGEAR USB Wireless
Post by: StrayBit on January 11, 2017, 08:20:12 pm
That worked.  Thanks.
Among other things it reported
Quote
No carrier
while iwlist scan shows my router and printer.
I start a 3 day conference tomorrow so won't be up.
Title: Re: IOGEAR USB Wireless
Post by: StrayBit on January 18, 2017, 06:15:37 pm
gave the following commands:
Quote
# iwconfig wlan0 essid qwest5177
# iwconfig
# iwconfig wlan0 enc bruceirving
# wpa_passphrase qwest5177 bruceirving
# wpa_suplicant –Dwext –iwlan0 –c/home/bruce/wpa.conf –B
   Successfully initialized wpa_suplicant
# dhcpcd –k
   dhcpcd not running
# dhcpcd wext
   wext: interface not found or invalid
   dhcpcd exiting
# dhcpcd wlan0
   all: IPv6 kernel autoconf disabled
   wlan0: adding address xxxx:: xxxx xxxx xxxx xxxx
   ifaddress6: Operation not supported
   wlan0: waiting for carrier
   timed out
   dhcpcd exited
vector://home/bruce
root:# iwconfig wlan0
     IEEE 802.11bg  ESSID:off/any
     Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
     Retry short limit:7   RTS thr:off   Fragment thr:off
     Encryption key:off
     Power Management:off
As you can see, still no access.
What now?
Title: Re: IOGEAR USB Wireless
Post by: bigpaws on January 19, 2017, 06:16:28 am
It appears the interface dies after dhcpcd -k.

Try using dhcpcd wlan0

Bigpaws
Title: Re: IOGEAR USB Wireless
Post by: StrayBit on January 19, 2017, 08:54:53 am
Yesterday it worked but today
Quote
# iwconfig wlan0 enc bruceirving
   Error for wireless request "Set Encode" (8B2A) :
       invalid argument "bruceirving".
Left out dhcpcd -k and get
Quote
dhcpcd wlan0
   all: IPv6 kernel autoconf disabled
   wlan0: adding address xxxx:: xxxx xxxx xxxx xxxx
   ifaddress6: Operation not supported
   wlan0: waiting for carrier
   timed out
   dhcpcd exited
Tried in Root terminal and as logging on as root - no difference.  It did help if I spelled suplicant with two p's  :-[