VectorLinux

The nuts and bolts => Technical General => Topic started by: frapelli on December 02, 2017, 12:23:00 pm

Title: GDM doe not start at boot
Post by: frapelli on December 02, 2017, 12:23:00 pm
I have installed V7.2 on an ald IBM Thinkpad A31 laptop, and I am quite happy with it.

I have a little problem (both with light and final VL installations.

Boot ends with a login request. After I type root login and password, I can either type "GDM" or "init 4" and I get GDM screen. I can also "startx" and enter (roor) desktop. From there everything is OK.

How can I boot straight to GDM?

/etc/rc.d/rc.X file is set to DISPLAY_MANAGER=GDM.

In another thread (http://forum.vectorlinux.com/index.php?topic=18794.msg105286#msg105286) I have seen that

"Can you boot to your text prompt by selecting the 'TUI' option on boot, then login as root and type 'init 4'"

solves the problem.

But I don't know how to "boot at my text prompt by selecting the TUI option".

Thanks
Title: Re: GDM doe not start at boot
Post by: nightflier on December 02, 2017, 01:21:13 pm
Did you choose to install boot manager when you set up VL, or are you multi-booting, using a boot manager from another distro?
Title: Re: GDM doe not start at boot
Post by: frapelli on December 02, 2017, 01:33:11 pm
Actually you are right. I forgot to inform.

Boot loader installed on VL partition, MBR boot loader is from another distro (SparkyLinux).
Title: Re: GDM doe not start at boot
Post by: nightflier on December 02, 2017, 02:33:34 pm
The folks at SparkyLinux's forum would be the authorities on configuring their boot loader, but here is my opinion:

Assuming GRUB, a quick and dirty hack/test is to edit /boot/grub/grub.cfg (from within SparkyLinux).
Find the code block for VL, and the line
linux /boot/linux root=/dev/sdX (where X is the partition that VL is installed to),
and append " 4", so it becomes
linux /boot/linux root=/dev/sdX 4

The above edit is frowned upon by GRUB devs. It will be overwritten by subsequent updates to GRUB.
When you have the syntax right, the proper way is to edit /etc/grub.d/41-custom (or similar), and add the code block for VL to that script.