VectorLinux

The nuts and bolts => Hardware & Drivers => Topic started by: SmartDuck on March 10, 2018, 08:01:18 am

Title: Wacom and Corsair keyboard not working
Post by: SmartDuck on March 10, 2018, 08:01:18 am
Hi there,

I installed VL 7.1 Light today on my backup DELL D505.
The Corsair keyboard and Wacom tablet are listed.
Did lsusb and checked if the xf86 input wacom package is installed.

dmesg:

[   40.863941] usbhid 3-1:1.1: can't add hid device: -110
[   40.863977] usbhid: probe of 3-1:1.1 failed with error -110
[   40.864185] usbhid 3-1:1.2: couldn't find an input interrupt endpoint
[   41.303983] input: Wacom HID Pen as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1:1.0/0003:056A:033B.0001/input/input9
[   41.305874] wacom 0003:056A:033B.0001: hidraw1: USB HID v1.10 Device [Wacom Co.,Ltd. Intuos PS] on usb-0000:00:1d.0-1/input0
[   41.306560] input: Wacom HID Pen as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1:1.1/0003:056A:033B.0002/input/input11
[   41.306943] wacom 0003:056A:033B.0002: hidraw2: USB HID v1.10 Device [Wacom Co.,Ltd. Intuos PS] on usb-0000:00:1d.0-1/input1
[   41.307737] input: Wacom HID Pen as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1:1.2/0003:056A:033B.0003/input/input13
[   41.308154] wacom 0003:056A:033B.0003: hidraw3: USB HID v1.10 Mouse [Wacom Co.,Ltd. Intuos PS] on usb-0000:00:1d.0-1/input2

Tips/suggestions are welcome.

Kind regards,

Marcel
Title: Re: Wacom and Corsair keyboard not working
Post by: SmartDuck on March 10, 2018, 01:55:13 pm
Extra info:

The keyboard is recognized but does not respond. Same with the wacom.
[ 5258.328099] usb 3-1: new full-speed USB device number 4 using uhci_hcd
[ 5258.492103] usb 3-1: New USB device found, idVendor=1b1c, idProduct=1b40
[ 5258.492113] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 5258.492119] usb 3-1: Product: Corsair Gaming K63 Keyboard
[ 5258.492124] usb 3-1: Manufacturer: Corsair
[ 5258.492130] usb 3-1: SerialNumber: 1902B01BAEC9110656AD3117F5001941
[ 5258.500414] input: Corsair Corsair Gaming K63 Keyboard as /devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.0/0003:1B1C:1B40.0007/input/input17
[ 5258.501569] hid-generic 0003:1B1C:1B40.0007: input,hidraw1: USB HID v1.11 Keyboard [Corsair Corsair Gaming K63 Keyboard] on usb-0000:00:1d.1-1/input0
[ 5283.509927] usbhid 3-1:1.1: can't add hid device: -110
[ 5283.509960] usbhid: probe of 3-1:1.1 failed with error -110
[ 5283.510161] usbhid 3-1:1.2: couldn't find an input interrupt endpoint
Title: Re: Wacom and Corsair keyboard not working
Post by: itsalex on March 13, 2018, 04:36:15 pm
Try using this steps and see if it will work.

1) Unplug the keyboard
2) Set the BIOS switch to the (1) position
3) Hold the ESC key and plug the USB with the keyboard logo into a USB 3.0 port
4) Release ESC after 5 secs

If it still won't work then try to contact the support team of Corsair.