VectorLinux

Cooking up the Treats => General Development => Topic started by: uelsk8s on March 05, 2007, 08:27:53 am

Title: Beryl Live Beta4 Bug report thread
Post by: uelsk8s on March 05, 2007, 08:27:53 am
please post any bugs you find in Beryl B4 here
Title: Re: Beryl Live Beta4 Bug report thread
Post by: nightflier on March 06, 2007, 06:01:45 am
Md5 Sums?
Title: Re: Beryl Live Beta4 Bug report thread
Post by: uelsk8s on March 06, 2007, 06:27:20 am
here it is,
979e0e42f53a81a75db23a8beba773fe  VL5.8-std-LIVE-beryl-B4.iso
Title: Re: Beryl Live Beta4 Bug report thread
Post by: M0E-lnx on March 06, 2007, 10:39:23 am
Overall performance: Great! ;)

Nice work. Beryl works out of the box (and 3d of course) on my laptop (Celerom M 1.46ghz Intel 950GM graphics card 512mb RAM)
Hardly any lag on the 3D effects.

Things that need to be taken care of:
When beryl is running, If I open a terminal, I get no text, the cursor gets stuck on the top-left corner of the terminal.
My wireless didn't work out of the box (although it does in SOHO A7 which uses the same kernel and modules).

The pink-ish default emerald theme should be changed...


BTW, Nice work with the graphics blurymind.
Great release

_EDIT_
Quickie hack to get the terminals going:
click the terminal button on the panel, you will see the buggy terminal, press CTRL+SHIFT+T
That will give you a new tab in the same terminal window, that one works
enjoe ;)

Title: Re: Beryl Live Beta4 Bug report thread
Post by: blurymind on March 06, 2007, 11:21:41 am
thanks,moe... well, i can create anotheremerald theme if you dont like stardust..maybe more simplistic one.With the previous i took too much advantage of the great engine of emerald..

Does this one cause trouble when installed? Do i need to apply the same fix as the previous for the first boot?
I am gonna test it as soon as i get some free time from uni.
Title: Re: Beryl Live Beta4 Bug report thread
Post by: M0E-lnx on March 06, 2007, 11:30:58 am
Haven't seen any problems, really, it's just that a pink theme does'nt really call my attn. But that's me..

I like the Adonis, and the Adonis_Mod themes, maybe those could be choices for defaults.
I also have a played with the Canopy, and came up with a kool variation, intead of the green titlebar, I made it a gladient blue...
Goes from light blue, to dark blue, (bottom-to-top)... It's awsome.

Or something that matches the blue-ish themes VL ships with ...
What can I say?.... I'm a sucker for blue themes.
Title: Re: Beryl Live Beta4 Bug report thread
Post by: tomh38 on March 07, 2007, 10:08:27 am
System: AMD Athlon 1.1 Ghz 512 RAM GeForce 5200 FX
When I ran the beta 4 live cd everything worked fine, including Beryl.  After installing to the hard drive, when I started Beryl, all I got was a white screen and a mouse cursor (I could move the cube around, but that's it).  After doing some googling, I found that a Fedora Core user had solved this problem by installing the nVidia 1.0-9746 driver from the official nVidia site.  I did that, and now everything, including Beryl, works fine.  I have no idea why this worked, or what was wrong in the first place but FWIW this did it for me.
I love Vector.  Even the betas rock!
Title: Re: Beryl Live Beta4 Bug report thread
Post by: M0E-lnx on March 07, 2007, 10:37:11 am
The installer still needs work IMO

I ran the installer from a terminal, gave me some weird error and it asked "Do you run x under installed GTK-x.x.x ?
I noticed CD and CPU activity so I let it do its's thing... no progress indicator of any kind
After a while, the CD and CPU activity stopped, nothing yet on the screen.
I rebooted (or course, it had not installed a boot manager)
I ran the configuration, no sound hardware was detected.... configured X, yet after a reboot, upon entering RL 4 it said in red letters
"WARNING: Recent X-Window was respawned too short."
No biggie, ran vxconf and reconfigured X, and voila!.

After the isntallation, it only mounts the root partition, no /home

Everything else seems fine after the install, exept for the sound
Title: Beryl Question
Post by: jimk on March 07, 2007, 04:58:16 pm
Hello all,
I am using beryl-beta4 installed to the hard drive.  All the other versions ran really slow on my gateway laptop (1.8Ghz, 512mb ram), then I started beryl just using "beryl" instead of starting beryl-manager, and the cube works great, but the title bar at the top of all windows is gone so there is no way to drag the windows around the desktop.  I know there must be an answer to this, but i couldn't find one in beryl-settings. 
Thanks,
Jim
Title: Re: Beryl Live Beta4 Bug report thread
Post by: JohnB316 on March 07, 2007, 07:31:30 pm
Jim,

I merged your beryl question into the Beryl Live bug report thread, as you may have found a bug.

Cheers,
John
Title: Re: Beryl Live Beta4 Bug report thread
Post by: jimk on March 08, 2007, 03:20:31 am
Now that I realize it may be a bug and not me...

The same thing happened to all the windows that open when I started beryl in beta1 and beta2.  If I closed out the windows and reopened them they would be fine, though. 

Also, when using beryl-beta4, i can see no text in the terminal, but if I hover over the terminal icon in the task bar, it does show text there.
Title: Re: Beryl Live Beta4 Bug report thread
Post by: jimk on March 08, 2007, 07:28:00 am
Ok,
I used beryl-settings-simple, and when I turned it up to 5 the title bars appeared.  It was working great for a while with the exception that the window with focus would have distortion around the outside of it.  It almost looked like it was nested within a terminal window.  After about 15 minutes of playing with it beryl will no longer display content within the window.  For example, if I open seamonkey, i will see the buttons at the top and the address bar, but nothing will be displayed where you view the web pages.  If you hover your mouse over the icon in the taskbar, you can see the content of the web page in the popup view.
Title: Re: Beryl Live Beta4 Bug report thread
Post by: M0E-lnx on March 09, 2007, 05:53:34 am
Jimk, Emerald is the one responsible for the title bars and window decorations...

Executing "emerald --replace" (without the quotes) in a terminal should give you window decorations ;)

To avoid doing that every time, I suggest kill xfwm4, so that emerald doesn't find another running window manager
Code: [Select]
killall xfwm4 && beryl-manager
The beta however does have that bug, where it doesnt display the content on some windows. And in some cases you're unable to make selections (ie, desktop settings)..

But we do appreciate you testing, and providing feedback...
Glad to know you got it going too.


EDIT:
I built KDE for it, here is a screenie of this release running the newly built KDE

 Beryl+KDE (http://allyoucanupload.webshots.com/v/2003779573641725090)

Title: Re: Beryl Live Beta4 Bug report thread
Post by: blurymind on March 10, 2007, 04:58:40 am
Jimk, Emerald is the one responsible for the title bars and window decorations...

Executing "emerald --replace" (without the quotes) in a terminal should give you window decorations ;)

To avoid doing that every time, I suggest kill xfwm4, so that emerald doesn't find another running window manager
Code: [Select]
killall xfwm4 && beryl-manager
The beta however does have that bug, where it doesnt display the content on some windows. And in some cases you're unable to make selections (ie, desktop settings)..

But we do appreciate you testing, and providing feedback...
Glad to know you got it going too.


EDIT:
I built KDE for it, here is a screenie of this release running the newly built KDE

 Beryl+KDE (http://allyoucanupload.webshots.com/v/2003779573641725090)


i wrote a little bash script that does exactly that. It kills xfwm4 and starts beryl when execyted while beryl is not workoing,and does the opposite if you execute it again-it kills beryl and starts xfwm4.I called it "beryl-switch on/off" script and added a link to it in my start menu:
http://img404.imageshack.us/img404/4139/vectorberylus2.jpg

download the script here:
www.garbagewars.com/ora/misc/tools/startberyl.sh
(and make it executable)

(it would be nice to include it in the live cd, or include something like it) ;)
Title: Re: Beryl Live Beta4 Bug report thread
Post by: M-ake on March 11, 2007, 03:57:54 am
Im running beryl beta 4 right now with intel 950gma graphics chip, the performance leap is BIG from beta 1 -> beta 4, in a good way I mean. Good job VL beryl team. However, there is a problem with vwifi. Heres what I got

Quote
root:# vwifi
checking ipw2100
removing ipw2100 module
checking ipw2200
removing ipw2200 module
checking ipw3945
ipw3945d - regulatory daemon
Copyright (C) 2005-2006 Intel Corporation. All rights reserved.
version: 1.7.18
2007-03-12 12:57:57: ERROR: opening /sys/bus/pci/drivers/ipw3945:
No such file or directory (2)
2007-03-12 12:57:57: ERROR: Could not find Intel PRO/Wireless 3945ABG Network Connection
removing ipw3945 module
checking zd1201
removing zd1201 module
checking ndiswrapper
removing ndiswrapper module
we dont seem to have a driver for your hardware sorry
would you like to try another module?
if you would like to try another module and you know its name
enter y anything else and we will exit
y
enter your module name
ipw3945
checking ipw3945
removing ipw3945 module
sorry that one doesnt seem to work either, bye

I know ipw3945 module works cause I use it daily on my standard VL. Keep up the good work.

Edit, I dont know if this is a much of a bug, anyways, here it goes

When I try to add audio files to my playlist in xmms it doesnt add them...
Title: Re: Beryl Live Beta4 Bug report thread
Post by: blurymind on March 11, 2007, 09:45:51 am


When I try to add audio files to my playlist in xmms it doesnt add them...

I had a simular problem with my xmms on beta 2 (and it didnt play mp3s too) .Reinstalling xmms fixed it.Just be careful not to degrade to x6.9 (uncheck it before "execute")
Title: Re: Beryl Live Beta4 Bug report thread
Post by: M0E-lnx on March 12, 2007, 08:25:27 am
If you're running Beta4, you should be able to install just the package, it should pick up your x11 version as 6.9.0 or better
In case it doesn't, try slapt-get --install xmms --no-dep
That should do the trick
Title: Re: Beryl Live Beta4 Bug report thread
Post by: boy91 on March 17, 2007, 12:27:52 pm
Can I boot VL-std-BETA4 under DOS?
I have copied all from .ISO on FAT32 partition, but \boot\dos\vector.bat does NOT work :)
I think that CONFIG file is bad, line "initrd=..\initrd.gz" is incorrect, because  does NOT exist file initrd.gz
Title: Re: Beryl Live Beta4 Bug report thread
Post by: uelsk8s on March 17, 2007, 02:20:21 pm
you are right the config file needs to be changed to this:
initrd=..\initrd     # this file gets loaded as 'initial ramdisk'

thanks for catching that one
Uelsk8s
Title: Re: Beryl Live Beta4 Bug report thread
Post by: boy91 on March 17, 2007, 03:33:33 pm
i've changed to "initrd=..\initrd" but it does not work too    >:(
after loading "vmlinuz" and "initrd" my computer is restarting
where is the problem?
thanks for any replay

Title: Re: Beryl Live Beta4 Bug report thread
Post by: blurymind on March 18, 2007, 08:22:30 am
wasnt sure where to report this,but the final 0.2 version of beryl was released.Beryl team switched from svn to git,so from now on we will have to use git to build beryl packages.
http://blog.beryl-project.org/?p=31

the creators of the *-look.org sites created a new website for themes,which is for beryl!
http://www.beryl-themes.org/
Title: Re: Beryl Live Beta4 Bug report thread
Post by: M0E-lnx on March 19, 2007, 06:56:34 am
wasnt sure where to report this,but the final 0.2 version of beryl was released.Beryl team switched from svn to git,so from now on we will have to use git to build beryl packages.
That is sweet!... but actually I looked in the releses section (tarballs) and I noticed they had 0.2.1 already up there, so I built it..
http://m0e.lnx.googlepages.com has VL packages for beryl-0.2.1
It just keeps getting better and better.

Title: Re: Beryl Live Beta4 Bug report thread
Post by: blurymind on March 19, 2007, 11:57:20 am
wasnt sure where to report this,but the final 0.2 version of beryl was released.Beryl team switched from svn to git,so from now on we will have to use git to build beryl packages.
That is sweet!... but actually I looked in the releses section (tarballs) and I noticed they had 0.2.1 already up there, so I built it..
http://m0e.lnx.googlepages.com has VL packages for beryl-0.2.1
It just keeps getting better and better.


Moe,YOU ROCK!
Sadly,i still dont have the latest beryl live cd (beta 2 here),because i need a spare pc with an nvidia card and the other laptop's hd died . :'(
But im gonna test these packages right now. :P
Title: Re: Beryl Live Beta4 Bug report thread
Post by: boy91 on March 19, 2007, 10:29:02 pm
to uelsk8s:

i've changed to "initrd=..\initrd" but it does not work too   
after loading "vmlinuz" and "initrd" my computer is restarting
where is the problem?
thanks for any replay

 
Title: Re: Beryl Live Beta4 Bug report thread
Post by: uelsk8s on March 19, 2007, 10:42:40 pm
boy91,
i will find a dos partition and give it a try and post back here my findings

Uelsk8s
Title: Re: Beryl Live Beta4 Bug report thread
Post by: jtouso on March 22, 2007, 04:59:41 am
Hi,
in live mode (beryl beta4) all works ok when I do beryl-manager.
The screens redraw fast and voila! beryl 3d cube works ideally.
I install this beta-4 to hd (vliveinstall), it installs well but when I try to run beryl-manager, the screen goes white, without any icon or something to clic over. The cube turns well but all white. I need to Ctrl+Alt+Backspace to re-run again the windows manager.
Why it works in live cd form and no in hd installation?
My pc is AMD athlon 1000, 512 ram and Nvidia 5500 FX
Thanks
Jose
   Report to moderator   83.33.87.84
jtouso
Member
*
Posts: 4


View Profile Email Personal Message (Online)
   
   
Re: beryl live beta4
« Reply #1 on: Today at 04:16:14 AM »
   Reply with quoteQuote Modify messageModify Remove messageRemove
Me again!
Solution: download nvidia*.run last driver from nvidia.com. Do Ctrl+Alt+F2 to console and enter as root. Do init 3 to stop X and run the file from nvidia (NVIDIA*.run). If you cant, do chmod +x to have permision. Wait until finish (because you have kernel-headers installed by default) and re-start again.
Beryl works ideally!!
But I dont know why live-beta 4 works well on live form and you need to do what I explain to work in hd installation.
By
Jose
Title: Re: Beryl Live Beta4 Bug report thread
Post by: uelsk8s on March 22, 2007, 09:52:43 am
jtouso
I think we found a fix for that we will be testing it here, and if all goes well it will be in next release

thanks,
Uelsk8s
Title: Re: Beryl Live Beta4 Bug report thread
Post by: M0E-lnx on March 23, 2007, 04:04:34 am
I just found out we made the list at http://wiki.beryl-project.org/wiki/

Vector Linux is listed for the "special beryl release"... Sweet!
Title: Re: Beryl Live Beta4 Bug report thread
Post by: blurymind on March 23, 2007, 05:13:34 am
I just found out we made the list at http://wiki.beryl-project.org/wiki/

Vector Linux is listed for the "special beryl release"... Sweet!
SWEEEEEEEEEEEEEEEEEEEEEEEEEEEEET   ;D ;D ;D

I wanted to add vl-beryl to this list however
http://www.beryl-project.org/distros.php

Now this might get us a flood of more new users for this live cd version.I will do my best to better the graphic design or beta test.
Title: Re: Beryl Live Beta4 Bug report thread
Post by: M0E-lnx on March 23, 2007, 08:01:05 am
Yeah.. We wont make that list until we release a final version w/beryl and start hosting beryl packages in the repos
Title: Re: Beryl Live Beta4 Bug report thread
Post by: hengehog on May 16, 2007, 09:40:47 am
Don't know if it's a bug or me being particularly stupid, but what re the username & password for getting into B4?
Title: Re: Beryl Live Beta4 Bug report thread
Post by: The Headacher on May 16, 2007, 09:42:39 am
Just answered that one elsewhere, please don't double post your questions. Thanks :).