VectorLinux

The nuts and bolts => Installation & Updates => Topic started by: carsten on June 26, 2007, 12:54:24 am

Title: Grub and Lilo issue
Post by: carsten on June 26, 2007, 12:54:24 am
Hello,
I want to find out the shortcomings of other distributions compared to Vector  ;D
To do so I want to install on an free partition of my hard drive Sidux. Sidux is Debian based and uses Grub as boot manager, but I do not like to replace Lilo in the MBR. So if I install Sidux and tell the installer to place Grub in the partition where Sidux resides instead of the MBR, will Lilo recognize this and start Sidux on demand?
Carsten
Title: Re: Grub and Lilo issue
Post by: lagagnon on June 26, 2007, 08:43:48 am
oh oh..another distro junkie in the making  ;)

If I were you, I would tell Sidux NOT to install GRUB (if that is an option. If it is not an option just install it to a floppy). Then you can either boot Sidux via the floppy or simply go into VL, mount the Sidux partition, edit your /etc/lilo.conf file to include the Sidux partition by adding another stanza such as:

# Partition 3: Sidux
image = /boot/vmlinuz
    root = /dev/hdb7
    label = sidux
    read-only

(you would obviously edit the partiton details above).

Then run "lilo -v" (as root in a terminal). All done. Piece of cake.
Title: Re: Grub and Lilo issue
Post by: MikeCindi on June 26, 2007, 10:30:27 am
As lagagnon has suggested manually editing lilo.conf is probably best but...if you are wanting to determine if lilo will detect your new OS then you could boot with the VL install CD and select the lilo repair option. (There is probably a better way to get lilo to redetect you partitions but I don't know it myself...yet.)
HTH,
Mike
Title: Re: Grub and Lilo issue
Post by: uelsk8s on June 26, 2007, 10:39:48 am
run "vliloconf " as root that is the same as booting with the vl-cd and choosing the lilo option
Title: Re: Grub and Lilo issue
Post by: carsten on June 26, 2007, 02:10:04 pm
Hy,
thanx to all.
I do not really understand Grub, but Lilo is transparent even for me  ;D
To bring the story to an end:
Install Sidux from Live CD: no problem (installer referred to the partion as sda8 instead hda8 but who cares)
Changing Lilo: no problem
Reboot: Sidux starts booting
 ??? Sidux claims file system hda7 (my Vector Home partiton) corrupt, offers to start root console for repair: NOOOOO
Booting goes on
Login starts
Desktop starts (looks nice, KDE is running on my box, AMD 1300+, fast enough)
Lots of entries in the various menus
No network???
netcardconfig tells me: no supported card recognized? (the Live CD did find one)
Summary: failed! I do not need a distribution that wont find standard hardware out of the box

Sidux Live CD for free, only used once. Please call 0049 4153 599489
Title: Re: Grub and Lilo issue
Post by: MikeCindi on June 26, 2007, 08:11:26 pm
No thanks, I have several live CDs of various distros  ::)
Perhaps editing the boot menu that you used for Sidux. It would seem to the casual observer (me) that redirecting which partition that Sidux points would be the simple fix...just a thought.

Thanks, Uelsk8s - I knew that, really.
Title: Re: Grub and Lilo issue
Post by: Triarius Fidelis on June 26, 2007, 09:34:35 pm
oh oh..another distro junkie in the making  ;)

If I were you, I would tell Sidux NOT to install GRUB (if that is an option. If it is not an option just install it to a floppy). Then you can either boot Sidux via the floppy or simply go into VL, mount the Sidux partition, edit your /etc/lilo.conf file to include the Sidux partition by adding another stanza such as:

# Partition 3: Sidux
image = /boot/vmlinuz
    root = /dev/hdb7
    label = sidux
    read-only

(you would obviously edit the partiton details above).

I wonder if Sidux would run with VL kernel. It may be necessary to copy the Sidux kernel into VL's /boot.