The nuts and bolts => X-Rated => Topic started by: pchristy on July 01, 2007, 01:53:51 am

Title: Xvidtune not working?
Post by: pchristy on July 01, 2007, 01:53:51 am
I've just installed Vec 5.8 gold standard on an old Asus P5A-B based machine. I've had to compile my own kernel (2.6.21) as the supplied one didn't work with my network card for some reason (Realtek 8139). Now I have two further problems! I can't install the legacy nvidia drivers, because they are designed for the stock kernel, and I can't get the NVidia drivers to build - they fail complaining they can't find linux/config.h, though everything appears to be in the correct place!

I wouldn't need to build the NVidia drivers if xvidtune worked, but it doesn't! My display is markedly offset, so I need to add a modeline to my xorg conf. When I try and run xvidtune, I get a message saying "install this program before attempting to run it"! But it IS installed, and all the permissions look correct!

I tried installing the version from Slackware, and got exactly the same error message!

Any suggestions, anyone?

Title: Re: Xvidtune not working?
Post by: easuter on July 01, 2007, 06:04:56 am
The nvidia legacy drivers don't build because some of the kernel's headers have changed since 2.6.18, so the solution is to simply create the header that the nvidia installer is trying to find.
Create a file in /usr/src/linux-2.6.21/include/linux called config.h and put this text in it:

Code: [Select]
/* This file is no longer in use and kept only for backward compatibility.
 * autoconf.h is now included via -imacros on the commandline
#include <linux/autoconf.h>


That should solve it (at least it did for me with the legacy drivers ;))
Title: Re: Xvidtune not working?
Post by: pchristy on July 01, 2007, 07:32:56 am
Yes, that makes sense! Thanks for the quick response!

In the meantime I loaded a live cd, ran xvidtune in that, and saved the modeline it generated. Now that I've pasted it into my xorg.conf file, I have a centred image. I've by-passed the problem!

Still don't understand why xvidtune doesn't work in Vec though!