VectorLinux

The nuts and bolts => Software General => Topic started by: demigaucher on July 18, 2007, 03:50:44 pm

Title: Problem with VASM: asks erroneously for lower-case username
Post by: demigaucher on July 18, 2007, 03:50:44 pm
Hi all

I tried to create a new user, using K > system > administration > VASM.

I choose "SUPER" and gave the root password.

Then I selected "USER" <OK> then "ADD" <OK> and was asked
a "Login name for the new user (lower case and digit)".

I typed "johnsmith" in lower case <OK> , and...error message:
"User johnsmith contains illegal characters (CAPITAL)"

??????? I checked the typing of johnsmith: it was correct. I tried
several times from the menu K itself, in case of some improbable
invisible character wrongly typed in: same result.

OK, no problem: back to good old console and useradd command,
but what the hell is occuring ?

Demigaucher
VL 5.8 soho on old P3@700 MHz & 320MB ram
Title: Re: Problem with VASM: asks erroneously for lower-case username
Post by: roseway on July 18, 2007, 11:44:06 pm
I can't answer your question, but I just did exactly the same thing and it worked fine.
Title: Re: Problem with VASM: asks erroneously for lower-case username /SOLVED
Post by: demigaucher on July 19, 2007, 02:22:18 pm
Hi Roseway, and thank you for your answer.

It took me some time (install a pristine VL on a test partition, and
apply one by one my personalizations till the symptom appears), but
I found what was wrong: in /etc/profile.d there are two files "lang.sh"
and "lang.csh" that I had modified to internationalize VL (changing
loacales, language, etc...). Apparently, changing  "lang.csh" did not
cause problems, but modifying "lang.sh" caused VASM to malfunction.

I re-installed the initial files, and everything runs smooth now... with
console in english.

Best regards to all

Demigaucher
VL5.8-soho on old P3@700 MHz and 320 MB ram



Title: Re: Problem with VASM: asks erroneously for lower-case username
Post by: metvas on July 19, 2007, 10:04:20 pm
Hello:
If I read you right you wanted to change to your native language?
If so go here http://vector.ecosq.com/ic/FAQs (http://vector.ecosq.com/ic/FAQs) goto FAQ page and #1.13 hanumizzle posted the solution.
regrads
Darrell
Title: Re: Problem with VASM: asks erroneously for lower-case username
Post by: demigaucher on July 20, 2007, 09:18:52 am
Thank you metvas, I go and have a look there immediately
(now, Open Office is in english again   ??? )

Best reagards to all readers.

Demigaucher
VL5.8-soho on old P3@700MHz & 320MB ram

Title: Re: Problem with VASM: asks erroneously for lower-case username /SOLVED
Post by: demigaucher on July 20, 2007, 09:36:07 am
Hi again

I followed the instructions, and everything runs smooth now:
VASM does not malfunction any longer, Open Office is in
french, etc...

Thanks to all the VL staff

Demigaucher
VL5.8-soho on old P3@700MHz & 320 MB ram
Title: Re: Problem with VASM: asks erroneously for lower-case username
Post by: metvas on July 20, 2007, 11:52:36 am
Very happy you up an running in your native language. Keep in touch.Happy Vectoring. Thanks hanumizzle good job.
Regards
Darrell