VectorLinux

Vectorbie Station => Vectorbie Questions => Topic started by: ErickElRojo on July 29, 2007, 11:41:59 pm

Title: [Solved] Help with my network's config , please !!!
Post by: ErickElRojo on July 29, 2007, 11:41:59 pm
Hi everybody !!, I'm novice in linux and I have a problem with the network's configuration, i get to configure my ip address, the dns address, and gateway ip address, but i can't to load any page in my browser.
I have a little LAN, connect with a switch....
my IP is 192.168.1.4
DNS 200.48.225.130
gateway 192.168.1.1

I use the VASM to start the connection like a static connection (with PROBE option), but nothing do...
what's wrong ?????? , i wait for answer ....  thx

P.d i use the standard edition Gold 5.8
Title: Re: Help with my network's config , please !!!
Post by: hata_ph on July 30, 2007, 03:47:32 am
can you ping other PC/system with your VL?
Title: Re: Help with my network's config , please !!!
Post by: bigpaws on July 30, 2007, 07:35:51 am
Open this file /etc/resolv.conf at the bottom look at
does it read nameserver 192.168.1.1 ? If not edit that
file save wait about 1 minute and try if no change reboot
to make sure the changes take effect.

HTH

Bigpaws
Title: Re: Help with my network's config , please !!!
Post by: ErickElRojo on July 30, 2007, 04:39:35 pm
can you ping other PC/system with your VL?

I can't ping to other PC. when i try said  "network is unreachable",
Title: Re: Help with my network's config , please !!!
Post by: ErickElRojo on July 30, 2007, 04:46:13 pm
Open this file /etc/resolv.conf at the bottom look at
does it read nameserver 192.168.1.1 ? If not edit that
file save wait about 1 minute and try if no change reboot
to make sure the changes take effect.

HTH

Bigpaws


OK i save the file with nameserver 192.168.1.1  and reboot, but when i load the VL, appeared a message window said "could not look up the internet" something there ...  my network configuration is

DEVICE = eth0
IPAADDR = 192.168.1.4
NETMASK = 255.255.255.0
GATEWAY 192.168.1.1
PROBE = YES

myhost.my .mynet = host.speedy.speedy

is there a problem with the hostname configuration? ... thnx
Title: Re: Help with my network's config , please !!!
Post by: bigpaws on July 30, 2007, 04:50:30 pm
Your network card does not appear to be working.

What is the name, make and model of your card?

Please look at ifconfig for an entry that says eth0 the Lo is
the loopback address.

Bigpaws
Title: Re: Help with my network's config , please !!!
Post by: ErickElRojo on July 30, 2007, 05:41:40 pm
Your network card does not appear to be working.

What is the name, make and model of your card?

Please look at ifconfig for an entry that says eth0 the Lo is
the loopback address.

Bigpaws

my network card is DAVICOM 9102/A PCI Fast ethernet Adapther.
is there difference between ethernet and fast ethernet configuration?



root:# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:D0:09:2C:F7:43
          inet addr:192.168.1.4  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:15 errors:120 dropped:0 overruns:0 frame:0
          TX packets:0 errors:2 dropped:0 overruns:0 carrier:2
          collisions:0 txqueuelen:1000
          RX bytes:1538 (1.5 KiB)  TX bytes:0 (0.0 b)
          Interrupt:10 Base address:0xcf80

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:24 errors:0 dropped:0 overruns:0 frame:0
          TX packets:24 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2376 (2.3 KiB)  TX bytes:2376 (2.3 KiB)
Title: Re: Help with my network's config , please !!!
Post by: hata_ph on July 30, 2007, 06:29:22 pm
try "lspci" and "lsmod" and post the result......
login in as TextUI as root, run VASM and try to auto-detect the NIC again.........
Title: Re: Help with my network's config , please !!!
Post by: ErickElRojo on July 30, 2007, 08:44:23 pm
try "lspci" and "lsmod" and post the result......
login in as TextUI as root, run VASM and try to auto-detect the NIC again.........

i tried to auto-detect and nothing ...
root:# lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 620 Host (rev 02)
00:00.1 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev d0)
00:01.0 ISA bridge: Silicon Integrated Systems [SiS] SiS85C503/5513 (LPC Bridge) (rev b1)
00:01.1 Class ff00: Silicon Integrated Systems [SiS] ACPI
00:01.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 11)
00:02.0 PCI bridge: Silicon Integrated Systems [SiS] Virtual PCI-to-PCI bridge (AGP)
00:0b.0 Ethernet controller: Davicom Semiconductor, Inc. 21x4x DEC-Tulip compatible 10/100 Ethernet (rev 10)
00:0f.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
00:0f.1 Communication controller: C-Media Electronics Inc CM8738 (rev 10)
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 530/620 PCI/AGP VGA Display Adapter (rev 2a)
Title: Re: Help with my network's config , please !!!
Post by: nubcnubdo on July 30, 2007, 08:51:16 pm
I'm a novice too. I wonder if your network could setup automatically using DHCP. Would make your configuration a lot easier. You really have to configure as a static connection?
Title: Re: Help with my network's config , please !!!
Post by: ErickElRojo on July 30, 2007, 08:59:36 pm
I'm a novice too. I wonder if your network could setup automatically using DHCP. Would make your configuration a lot easier. You really have to configure as a static connection?

i tried this, but there isn't result. 
Title: Re: Help with my network's config , please !!!
Post by: nubcnubdo on July 30, 2007, 11:21:14 pm
If you can, if you have one, substitute another ethernet card. Linksys, 3com, SMC, Realtek have good detection. Try DHCP with substitute card.

Be sure to unplug the computer power cord (mains) before you swap out the cards.
Title: Re: Help with my network's config , please !!!
Post by: jimwill on July 31, 2007, 03:27:15 am
Another possible problem could be the gateway 192.168.1.1 might not be working properly. Do you have another computer that you can use to check? Also, I would make sure the workgroups were the same.
Title: Re: Help with my network's config , please !!!
Post by: Cannoncreek on July 31, 2007, 06:50:04 am
00:0b.0 Ethernet controller: Davicom Semiconductor, Inc. 21x4x DEC-Tulip compatible 10/100 Ethernet (rev 10)

This card is really terrible for a lot of distros.

I''ve tried this card on a numer of distros and it seems to very problematic.

Distros I've tried that don't work with it OOTB:

SLAX (even the newest 5.1.8) and googling also came up that this NIC is very problematic with slackware based distros????
VL 5.8 SOHO

Oddly enough the NIC works under Puppy Linux 2.14, Ubuntu 6.06.1 LTS & DSL 3.2

IIRC, the problem seem to happen with when the NIC is identified incorrectly. Some distros identify it as a "tulip" and thus the tulip driver is loaded. A fix for this is to use "dmfe" driver instaed of tulip.  Don't remeber though how to do it. Maybe some of theVL gurus could help. :-)
Title: Re: Help with my network's config , please !!!
Post by: bigpaws on July 31, 2007, 01:22:44 pm
The output from lsmod is still needed to make sure the driver is
loaded.

Bigpaws
Title: Re: Help with my network's config , please !!!
Post by: Cannoncreek on July 31, 2007, 09:19:33 pm
I don't know how much of a help these are (googled them from other distros' forums):

How to fix problem with Davicom ethernet adapter.
http://ubuntuforums.org/showthread.php?t=186430

Fixing Davicom Ethernet Problem, Suse 10.1
http://www.suseforums.net/index.php?showtopic=20862
Title: Re: Help with my network's config , please !!!
Post by: ErickElRojo on August 06, 2007, 10:16:49 pm
the result of lsmod is :
root:# lsmod
Module                  Size  Used by
nfsd                  186032  1
exportfs                5248  1 nfsd
lockd                  50824  2 nfsd
sunrpc                121148  2 nfsd,lockd
xt_limit                3200  0
xt_pkttype              2688  0
ipt_REJECT              4864  1
xt_tcpudp               3968  4
ipt_LOG                 6144  0
xt_state                2816  7
iptable_mangle          3200  0
iptable_nat             6660  0
iptable_filter          3328  1
ip_conntrack_irc        6128  0
ip_nat_ftp              3584  0
ip_nat                 13868  2 iptable_nat,ip_nat_ftp
ip_conntrack_ftp        6640  1 ip_nat_ftp
ip_conntrack           37600  6 xt_state,iptable_nat,ip_conntrack_irc,ip_nat_ftp,ip_nat,ip_conntrack_ftp
ip_tables              12020  3 iptable_mangle,iptable_nat,iptable_filter
x_tables               11140  8 xt_limit,xt_pkttype,ipt_REJECT,xt_tcpudp,ipt_LOG,xt_state,iptable_nat,ip_tables
lp                     10120  0
parport_pc             23364  1
parport                29640  2 lp,parport_pc
cpufreq_conservative     6536  0
cpufreq_ondemand        5900  0
cpufreq_performance     2816  0
cpufreq_powersave       2560  0
speedstep_lib           4740  0
freq_table              4512  0
sg                     25500  0
ide_scsi               13572  0
fuse                   37780  0
snd_seq_dummy           3716  0
snd_seq_oss            27392  0
snd_seq_midi_event      6528  1 snd_seq_oss
snd_seq                42320  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_pcm_oss            37280  0
snd_mixer_oss          14080  3 snd_pcm_oss
shpchp                 29604  0
evdev                   8320  0
tulip                  43040  0
snd_cmipci             28576  2
serio_raw               6148  0
gameport               11912  1 snd_cmipci
pcspkr                  3456  0
i2c_sis5595             7044  0
i2c_sis630              7308  0
sis5595                12168  0
sis_agp                 6916  1
i2c_isa                 4608  1 sis5595
i2c_core               16256  4 i2c_sis5595,i2c_sis630,sis5595,i2c_isa
snd_pcm                61828  2 snd_pcm_oss,snd_cmipci
snd_page_alloc          8072  1 snd_pcm
snd_opl3_lib            8960  1 snd_cmipci
snd_timer              18692  3 snd_seq,snd_pcm,snd_opl3_lib
snd_hwdep               7428  1 snd_opl3_lib
snd_mpu401_uart         7040  1 snd_cmipci
snd_rawmidi            18592  1 snd_mpu401_uart
snd_seq_device          6924  5 snd_seq_dummy,snd_seq_oss,snd_seq,snd_opl3_lib,snd_rawmidi
snd                    39780  12 snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_cmipci,snd_pcm,snd_opl3_lib,snd_timer,snd_hwdep,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore               8032  3 snd
usblp                  11520  0
nls_iso8859_1           4992  1
nls_cp437               6656  1
vfat                   10240  1
fat                    41372  1 vfat


I supose that the problem is my network's card, because when i try to ping to 192.168.1.1 (my network gateway ip) the message is "network is unreachable" ... thx for help me to all  
Title: Re: Help with my network's config , please !!!
Post by: hata_ph on August 06, 2007, 11:11:27 pm
try this

http://lists.debian.org/debian-boot/2005/09/msg00085.html

but I am not sure the dmfe module can be found in VL 5.8 or not......

EDIT:

read this too......

http://www.davicom.com.tw/eng/faq.htm
Title: Re: Help with my network's config , please !!!
Post by: Pita on August 07, 2007, 12:10:59 am
I had the same problem with the same card and initially could not connect with slackware and then with VL. The problem was solved with

Code
modprobe dmfe and in my case
rmmod tulip

dmfe is found on VL-5.8.

With 4 other slack based distros I was never able to connect doing above.
Title: Re: Help with my network's config , please !!!
Post by: ErickElRojo on August 07, 2007, 03:06:21 pm
I had the same problem with the same card and initially could not connect with slackware and then with VL. The problem was solved with

Code
modprobe dmfe and in my case
rmmod tulip

dmfe is found on VL-5.8.

With 4 other slack based distros I was never able to connect doing above.

What's the code to put in the terminal ?

modprobe dmfe
rmmod tulip

anything else ?
Title: Re: Help with my network's config , please !!!
Post by: Joe1962 on August 07, 2007, 05:28:46 pm
You should add "blacklist tulip", without the quotes, to /etc/modprobe.d/blacklist. In most reports I've seen, dmfe should then autoload on boot. If not, then find the line: "#/sbin/modprobe dmfe" in the file /etc/rc.d/rc.modules and uncomment it (remove the "#"), then save the file and reboot.


EDIT: Just realized, VL has dmfe blacklisted in /etc/modprobe.d/blacklist, so you need to comment it out (add a "#" in front).
Title: Re: Help with my network's config , please !!!
Post by: ErickElRojo on August 07, 2007, 10:46:39 pm
You should add "blacklist tulip", without the quotes, to /etc/modprobe.d/blacklist. In most reports I've seen, dmfe should then autoload on boot. If not, then find the line: "#/sbin/modprobe dmfe" in the file /etc/rc.d/rc.modules and uncomment it (remove the "#"), then save the file and reboot.


EDIT: Just realized, VL has dmfe blacklisted in /etc/modprobe.d/blacklist, so you need to comment it out (add a "#" in front).

Thank you !!! my network's config is ready ... with these steps, Thanks to all !!!  :) ;D
Title: Re: Help with my network's config , please !!!
Post by: Joe1962 on August 07, 2007, 11:02:28 pm
Glad to hear that... :)