VectorLinux

The nuts and bolts => Technical General => Topic started by: mithion on August 10, 2007, 10:31:07 am

Title: Bootsplash text bug
Post by: mithion on August 10, 2007, 10:31:07 am
I have a bug related to the graphical bootsplash in VL 5.8 SOHO.  The text at the bottom doesn't seem to disappear.  With each new step in the boot process, the text just appears on top of the previous one.  Additionally, the progress bar is not working either.  Any suggestions on how to fix this?
Title: Re: Bootsplash text bug
Post by: lagagnon on August 10, 2007, 11:01:19 am
Was it always like that from the time you first did the install or did you do some sort of upgrade?
Title: Re: Bootsplash text bug
Post by: mithion on August 10, 2007, 11:02:45 am
That's a good question.  I believe this problem appeared after an upgrade.  But I don't know which packages are responsible for the look of the bootsplash.
Title: Re: Bootsplash text bug
Post by: mithion on August 14, 2007, 08:00:06 am
Does anybody else have this problem?
Title: Re: Bootsplash text bug
Post by: uelsk8s on August 14, 2007, 08:04:04 am
I think the problem is with the kde-custom package.
if you look in /etc/bootsplash/themes you should have a listing like this
Code: [Select]
uel:$ ls -la /etc/bootsplash/themes/
total 0
drwxr-xr-x 3 root root 104 2007-04-22 09:08 ./
drwxr-xr-x 3 root root  72 2007-01-27 19:17 ../
drwxr-xr-x 4 root root  96 2007-02-05 15:52 GlassLights-VL/
lrwxrwxrwx 1 root root  15 2007-08-13 19:01 current -> GlassLights-VL//

you are probably missing the GlassLights-VL folder
Title: Re: Bootsplash text bug
Post by: mithion on August 14, 2007, 11:08:29 am
Edit:  Please disregard this post.  I posted the output of the wrong operating system.  I will repost the proper output later today when I get home.
Title: Re: Bootsplash text bug
Post by: Freeman on August 14, 2007, 11:47:17 am
When I tried SOHO 5.8 I also had this problem after a while. Could have been after upgrading some stuff. Don't know what it was that triggered the event...
Title: Re: Bootsplash text bug
Post by: mithion on August 20, 2007, 07:01:11 pm
There is a package called "VL5.8" that got installed when I did an update.  I tried uninstalling this package to see what happened and it did remove the bootsplash entirely.  So I'm assuming the problem is related to this mysterious package.  How to revert back to the original settings... that, I do not know.
Title: Re: Bootsplash text bug
Post by: MikeCindi on August 20, 2007, 07:14:49 pm
I have VL5.8 and kde-custom blocked in gslapt. The problems they cause seem to be cosmetic though.
Title: Re: Bootsplash text bug
Post by: mithion on August 20, 2007, 08:26:22 pm
Ok, new update.  I did a fresh install of VL 5.8 Soho on my gf's computer.  I did a search for the bootsplash packages on her computer and found two packages.

bootsplash
bootsplash-VL

Both of these are installed on her computer.  On mine on the other hand, I only have the bootsplash-VL package (I uninstalled VL5.8).  I tried putting back the cdrom as a repository to install the original bootsplash (the one with no VL after it) package, but I can't seem to find it.  It's not listen in gslapt.  I think VL5.8 is an experimental replacement to bootsplash, and it completely overwrote it when I updated.  Where can I get the original bootsplash package?
Title: Re: Bootsplash text bug
Post by: jimwill on August 29, 2007, 01:52:00 am
Has anyone found a solution to this?
I'm also having the same problem, and yes it was after doing an update from SOHO 5.8b.
I did fix the missing glasslights splash, but not sure what to do about this problem.
Title: Re: Bootsplash text bug
Post by: mithion on November 12, 2007, 04:39:42 pm
Ok, I did some distro hoping for a while and decided to go back with VL.  Still have this problem.  Let's bump this topic and see what happens.
Title: Re: Bootsplash text bug
Post by: uelsk8s on November 12, 2007, 04:55:10 pm
can you post the output of  "ls -la /etc/bootsplash/themes/"

Thanks,
Uelsk8s
Title: Re: Bootsplash text bug
Post by: mithion on November 15, 2007, 08:34:22 am
Sorry for the delay.  Here's the output.

philippe:$ ls -la /etc/bootsplash/themes/
total 8
drwxr-xr-x 2 root root 4096 2007-11-12 07:36 ./
drwxr-xr-x 3 root root 4096 2007-01-27 18:17 ../
lrwxrwxrwx 1 root root   15 2007-11-12 06:33 current -> GlassLights-VL/
Title: Re: Bootsplash text bug
Post by: uelsk8s on November 15, 2007, 08:54:46 am
it looks like your missing this package: http://vectorlinux.osuosl.org/veclinux-5.8/packages/bootsplash/bootsplash-VL-Tux-noarch-4vl58.tlz
after you install it make sure the /etc/bootsplash/themes/current symlink points to /etc/bootsplash/themes/VectorLinux
like this
root:# ls -la etc/bootsplash/themes/
total 0
drwxr-xr-x 3 root root 104 2006-12-08 21:42 ./
drwxr-xr-x 3 root root  72 2006-12-08 21:42 ../
drwxr-xr-x 4 root root  96 2006-12-08 21:42 VectorLinux/
lrwxrwxrwx 1 root root  11 2007-10-15 14:38 current -> VectorLinux/
Title: Re: Bootsplash text bug
Post by: mithion on November 16, 2007, 07:45:51 am
Somehow, that package you speak of showed up as "installed" when searching for it using GSlapt.  I told myself "eh what the heck, might as well try reinstalling it" which I did.  It both fixed and didn't fix the problem.  Let me explain.  Now, the bootsplash works fine.  The text shows up correctly and the progress indicator, well.... indicated progress.  Unfortunately, the bootsplash theme is that of Vector Linux standard with the evergrowing penguins.  I would like to know if it's possible to get the GlassLights theme from VL SOHO back.  The folder that contained the theme seemed to have been deleted (without my consent) by the installation of other packages.  If not, I guess the bootsplash is currently working and its aesthetics aren't so important. 
Title: Re: Bootsplash text bug
Post by: uelsk8s on November 16, 2007, 08:07:13 am
let me track down the package you need for that and get a link for you.
sorry I rthought you were on 5.8 std

Uelsk8s
Title: Re: Bootsplash text bug
Post by: mithion on December 05, 2007, 02:30:31 pm
Hi, just want to check whether you have found the SOHO bootsplash package yet?
Title: Re: Bootsplash text bug
Post by: uelsk8s on December 05, 2007, 05:21:49 pm
you can download it here: http://vectorlinux.osuosl.org/veclinux-5.8/extra/bootsplash/bootsplash-GL-1.0-noarch-1vl59.tlz
sorry about the delay
Title: Re: Bootsplash text bug
Post by: mithion on December 06, 2007, 01:54:32 pm
Fantastic, I installed the package and now have a working bootsplash VL SOHO style!!!  Thank you for your help!
Title: Re: Bootsplash text bug
Post by: uelsk8s on December 06, 2007, 02:01:03 pm
You are welcome.
Thanks for being so patient  :)