VectorLinux

The nuts and bolts => Installation & Updates => Topic started by: Sperrit on September 01, 2007, 03:17:34 pm

Title: Help needed installing Tellico in VL 5.1
Post by: Sperrit on September 01, 2007, 03:17:34 pm
Hi all,

I've recently installed VL 5.1 in an old laptop (Celeron 600Mh, 64Mb), and I'm quite glad I can "normally" use a machine otherwise I couldn't use. Installation was ok, configuration was not so complicated, but I'm getting trouble to install Tellico 1.2.13, a newer version than the one in repositories.

I've got the package from here (http://www.slacky.eu/index.php?option=com_content&task=view&id=2548&Itemid=56), I use pkgtool to install it, and everything seems to go ok. But when I try to run it in XFCE, nothing happens. And when I try to run it from console, it gives me an error about libyaz.so.3: cannot open shared object file: No such file or directory.

I've also tried to compile if manually from sources, configure's ok, but when doing "make", I get an error related to openoffice...

I'd need a newer version of this software to keep on working with my old "new" laptot.

Any ideas?

Thanks ;)
Title: Re: Help needed installing Tellico in VL 5.1
Post by: uelsk8s on September 01, 2007, 04:56:56 pm
maybe you need yaz?
http://www.slacky.eu/index.php?option=com_content&task=view&id=2549&Itemid=56
Title: Re: Help needed installing Tellico in VL 5.1
Post by: Joe1962 on September 01, 2007, 06:03:37 pm
We have yaz packages in the repo. Probably not the latest, but I don't think that's a big issue.
Title: Re: Help needed installing Tellico in VL 5.1
Post by: Sperrit on September 02, 2007, 01:15:49 am
I have yaz 2.1.16 already installed in my machine  :-[
Title: Re: Help needed installing Tellico in VL 5.1
Post by: uelsk8s on September 02, 2007, 06:35:17 am
your error was for "libyaz.so.3:" so you probably need a newer yaz like the one i pointed to.
You could try symlinking libyaz.so.3 to your older libyaz.so.2 and see if it works that way
Title: Re: Help needed installing Tellico in VL 5.1
Post by: Joe1962 on September 02, 2007, 12:04:20 pm
Ah, I see you got a package from slacky, they tend to be a bit too bleeding edge with their lib deps. According to the Tellico site, it is now compatible with yaz 2 and 3, but it would depend on the version you build it with. I guess you need to build yaz3 (should be easy, if building yaz2 is any indication), or buid tellico with yaz2 (probably a lot harder). You could try the symlink uel mentioned first.