VectorLinux

Vectorbie Station => Vectorbie Questions => Topic started by: varaahan on September 18, 2007, 08:43:47 am

Title: Net connection problem
Post by: varaahan on September 18, 2007, 08:43:47 am
I am using pppoe-start for net connection .
This command does not work when initiated by an ordinary user though x permission has been given .

ls -l reveals this:
root:# ls -l /usr/sbin/pppoe-start
-rwxr-xr-x 1 root root 5607 2007-09-16 20:24 /usr/sbin/pppoe-start*

When invoked by user , it gives command not found error.

vector:/~
sridhar:$ pppoe-start
-bash: pppoe-start: command not found

And I tried to install tkpppoe and it is not working either.

May I know how to make this command executable by all ?

Title: Re: Net connection problem
Post by: stoichyu on September 18, 2007, 08:57:58 am
As user, you can type "/usr/sbin/pppoe-start"
OR
Add /usr/sbin to your path.
OR
Make a symlink in /usr/bin to /usr/sbin/pppoe-start
Title: Re: Net connection problem
Post by: newt on September 18, 2007, 10:31:45 am
Make a symlink in /usr/bin to /usr/sbin/pppoe-start

FWIW, I like stoichyu's last idea best:
In terminal as root, type
Code: [Select]
ln -s /usr/sbin/pppoe-start /usr/bin/pppoe-start
Title: Re: Net connection problem
Post by: bigpaws on September 18, 2007, 08:03:14 pm
To make this command useable by users, change the
the users group.

As root in the console "chgrp users /usr/sbin/pppoe-start"
do not use the quotes.

When as root you used pppoe-setup there is an option for
dial on demand (connect on demand) which if called will
automatically call the command.

Bigpaws
Title: Re: Net connection problem
Post by: varaahan on September 19, 2007, 05:39:48 am
To make this command useable by users, change the
the users group.

As root in the console "chgrp users /usr/sbin/pppoe-start"
do not use the quotes.

Bigpaws

But that didn't work out.

vector:/~
sridhar:$ /usr/sbin/pppoe-start
pppoe-start: You must be root to run this script


Make a symlink in /usr/bin to /usr/sbin/pppoe-start

FWIW, I like stoichyu's last idea best:
In terminal as root, type
Code:

ln -s /usr/sbin/pppoe-start /usr/bin/pppoe-start

And this too failed:


Title: Re: Net connection problem
Post by: stoichyu on September 19, 2007, 06:02:11 am
Well, like it says "You must be root to run this script." So you have to be root to run it. If you just want to autoconnect at computer startup, you can append "/usr/sbin/pppoe-start" to /etc/rc.d/rc.local

If you really want to run it as user, try to run "sudo /usr/sbin/pppoe-start" If it is already configured, you're good to go, otherwise you have to get it into your /etc/sudoers file.