VectorLinux

Cooking up the Treats => New Package Requests => Topic started by: oldos2er on September 29, 2007, 02:13:14 pm

Title: GNOME 2.20
Post by: oldos2er on September 29, 2007, 02:13:14 pm
 I'd really like to see the new GNOME 2.20 (http://www.gnome.org/start/2.20/notes/en/) available for Vector.

--
 Ann
Title: Re: GNOME 2.20
Post by: easuter on September 29, 2007, 04:29:53 pm
I don't have the time to make GNOME 2.20 for VL 5.8 right now. It will most probably be available for VL 5.9 when its closer to Release Candidate status, but not while there is still a lot of turmoil in the repositories (anyone else is free to do it if they like though  :D but it probably a good idea to let the dust settle first seeing as GNOME is comprised of so many packages).
Title: Re: GNOME 2.20
Post by: exeterdad on September 29, 2007, 07:22:51 pm
I'm going to have to pass on the challenge.  I have like 20 minutes experience with Gnome  :D.  Since it's such a vast job, I think it would be foolish for me to wing my way through it.
Anyone else?
Title: Re: GNOME 2.20
Post by: lagagnon on September 29, 2007, 07:28:21 pm
IMHO we do not have the number of volunteers necessary to maintain three major desktop environments: KDE, xfce and Gnome packagings. I believe that by doing that we will stretch ourselves too thin. I foresee numerous problems also because our Slackware base does not really support Gnome either....
Title: Re: GNOME 2.20
Post by: oldos2er on September 30, 2007, 11:24:18 am
 N00b question--could you clarify what you mean by "our Slackware base does not really support Gnome either...."?

 If I was a programmer, I'd love to work with Gnome for Vector, but unfortunately I'm not. I appreciate all the work you developers do; Vector is a wonderful distro. Anyway, thanks for listening.

--
 Ann
Title: Re: GNOME 2.20
Post by: newt on September 30, 2007, 11:50:50 am
N00b question--could you clarify what you mean by "our Slackware base does not really support Gnome either...."?

I was wondering the same thing so I started looking through the gnome project website which then lead me to the dropline gnome project which is tailored for slackware (VL's base distro).  Reading through there a bit provides a general understanding of the requirements that gnome needs from it's distro - far too much for me to fully understand but I got the idea that gnome is super-tricky.  Even though there is a dropline gnome for slackware, we are not _exactly_ slackware.  I think a VL user trying to install the vanilla dropline gnome would come across many obsticles, but it would probably be far less then trying to install strict gnome.  Though, if you are adventurous, dropline gnome would be a good starting point to begin "playing" ;D

Any way, you can read more about dropline gnome here: http://www.droplinegnome.org/?page_id=14

Hope this helps
Title: Re: GNOME 2.20
Post by: oldos2er on September 30, 2007, 02:04:35 pm
 Thank you.

--
 Ann
Title: Re: GNOME 2.20
Post by: Joe1962 on September 30, 2007, 02:29:36 pm
Unless things have changed a lot, Dropline wasn't the most "recommendable" Gnome compilation for VL or Slackware. It replaces too many of the base libraries, including X itself. There are other less intrusive compilations which have been mentioned in this Forum recently, like Freerock, for instance.
Title: Re: GNOME 2.20
Post by: Pita on November 25, 2007, 01:24:32 am
I installed dropline-gnome-2.20-Beta in VL5.9-RC1.7. It looks beautiful to me and I could not find any adverse effect for X in VL5.9. It seems some packages did not install like rythmbox which I do not use anyhow. All the packages I need and use for gnome are there and perform properly.

The dropline-installer will abort when a package will not install I therefore used installpkg *.tgz in /var/cache/dropline-installerl
Title: Re: GNOME 2.20
Post by: blurymind on November 25, 2007, 02:23:31 am
would be great if we had a build-latest-gnome mega buildscript... i am sure that would be very hard to do  ::) but it might save packagers lots of painful building procedures.
Title: Re: GNOME 2.20
Post by: easuter on November 25, 2007, 03:38:11 am
would be great if we had a build-latest-gnome mega buildscript... i am sure that would be very hard to do  ::) but it might save packagers lots of painful building procedures.

In theory it would be nice.
However, aside from GNOME's usual overall "pain-in-the-arse" build process, I'm going to have to uproot Mono runtimes that appear to have made their way into the default GNOME 2.20 distribution  >:(

Sorry, but I can't make any promises about GNOME 2.20 for either vl58 or vl59, not with the amount of spare time I have anyway.
Title: Re: GNOME 2.20
Post by: tomh38 on November 25, 2007, 09:06:46 am
The peeps over at www.slacky.eu have built GNOME 2.20 for Slackware 12.  I haven't tried it, since I don't really need anything GNOME has, but somebody might want to give it a try.  I've had good experiences with packages from slacky in the past, but I've never installed a whole desktop or even a window manager that they've built.

If somebody wants to give it a try, here's a link: http://www.slacky.eu/index.php?option=com_content&task=view&id=1582&Itemid=53 (http://www.slacky.eu/index.php?option=com_content&task=view&id=1582&Itemid=53)

Or here's a direct link to the ISO: http://85.42.95.227/mirror/gnomeslk/slackware12.0/
 (http://85.42.95.227/mirror/gnomeslk/slackware12.0/)

If anybody needs help with the Italian on the page, post a message here.
Title: Re: GNOME 2.20
Post by: Colonel Panic on November 25, 2007, 12:12:48 pm
IMHO we do not have the number of volunteers necessary to maintain three major desktop environments: KDE, xfce and Gnome packagings. I believe that by doing that we will stretch ourselves too thin. I foresee numerous problems also because our Slackware base does not really support Gnome either....

I agree and I also think people who want Gnome will head for Ubuntu or one of its derivatives like Linux Mint. I'm not even sure about KDE to be honest; I admit I'm no expert but I don't see anything it offers that can't be done without it. Absolute Linux is based on Slackware 12 and IceWM and it does pretty well.
Title: Re: GNOME 2.20
Post by: rbistolfi on November 25, 2007, 03:47:17 pm
The only things I see about kde and gnome is their apps. Some of them are great. I am very happy with xfce, but I like to have kde and gnome libs for compiling their apps.
Title: Re: GNOME 2.20
Post by: blurymind on November 26, 2007, 06:34:19 am
The only things I see about kde and gnome is their apps. Some of them are great. I am very happy with xfce, but I like to have kde and gnome libs for compiling their apps.
likewise  ;D
Title: Re: GNOME 2.20
Post by: oldos2er on December 30, 2007, 09:27:11 pm
The peeps over at www.slacky.eu have built GNOME 2.20 for Slackware 12.  I haven't tried it, since I don't really need anything GNOME has, but somebody might want to give it a try.

 I'm going to give it a try. In case anyone's interested, here's a torrent link: http://www.slacky.eu/gslacky/12.0/2.20.2/torrent/GSlacky-2.20.2-Compiz-Fusion.torrent
Title: Re: GNOME 2.20
Post by: Pita on December 31, 2007, 01:29:07 am
As I have reported under Distro Releases I have installed in VL5.9-STD dropline-gnome-2.20.2 and it is working fine. Since I grew-up with gnome using Linux I am just so used to some of its fine programs. As a desktop its fluxbox with a xfce4-panel all the way for me.

Regards
Title: Re: GNOME 2.20
Post by: Colonel Panic on December 31, 2007, 10:43:20 am

Thanks for that info. It mightn't be a bad idea for Vector users who are interested in Gnome to try out each of the Slackware-friendly Gnome packages such as Freerock, Dropline and that other one (GWR?) to see which one works best.