VectorLinux

The nuts and bolts => Web & Internet => Topic started by: dawnsboy on November 10, 2007, 09:10:18 am

Title: Flashplayer 9 won't install VL 5.8 Standard
Post by: dawnsboy on November 10, 2007, 09:10:18 am
I have the same problem that appears in a similar post regarding VL 5.8 SOHO:

Quote
greetings forum,
having a small amount of trouble installing flash player 9 on 5.8 soho. as you can see the glibc says older than 2.2 but gslapt says it is 2.3. i did not see an option to upgrade glibc in gslapt. also running as root

    * yields the same result.

dave:$ cd /home/dave/install_flash_player_9_linux
vector:/~/install_flash_player_9_linux
dave:$ ./flashplayer-installer
./flashplayer-installer: line 76: [: 11): integer expression expected

ERROR: Your glibc library is older than 2.2.
       Please update your glibc library.

This user stated that he resolved the issue:

Quote
i just updated plugins and the flashplayer was installed. so, no worries now.

My question is how?  ???

I downloaded the latest available version of the plugins package for VL 5.8 but continue to receive the same results when attempting to install flashplayer 9.0 for linux. 

I did successfully copy the two critical files; flashplayer.xpt and libflashplayer.so to the /usr/lib/mozilla/plugins folder manually as 'root'. 
Title: Re: Flashplayer 9 won't install VL 5.8 Standard
Post by: JohnB316 on November 11, 2007, 08:46:47 am
It seems that Adobe had a weird way of determining which glibc was installed on a box - thus, the error message about the age of the glibc. This is a known issue and seems to be solved just by manually putting the key files from the Flash Player installer into your global plugins folder at /usr/lib/mozilla/plugins

HTH,
John
Title: Re: Flashplayer 9 won't install VL 5.8 Standard
Post by: dawnsboy on November 11, 2007, 11:03:10 am
Thanks John!   ;D

As you read I did implement the work around but I like knowing why I need to use the work around.  I appreciate the information.
Title: Re: Flashplayer 9 won't install VL 5.8 Standard
Post by: exeterdad on November 11, 2007, 12:03:31 pm
You're right John.  I can't find the post any more, but I got down to the bottom of it helping a user.  The install script would attempt to find the glibc version by using the iconv version.  In our case will not work.
Title: Re: Flashplayer 9 won't install VL 5.8 Standard
Post by: Walt H on November 12, 2007, 09:07:07 pm
It seems that Adobe had a weird way of determining which glibc was installed on a box - thus, the error message about the age of the glibc. This is a known issue and seems to be solved just by manually putting the key files from the Flash Player installer into your global plugins folder at /usr/lib/mozilla/plugins

Just out of curiousity, what are the key files? Thanks.
Title: Re: Flashplayer 9 won't install VL 5.8 Standard
Post by: JohnB316 on November 13, 2007, 08:02:55 pm
It seems that Adobe had a weird way of determining which glibc was installed on a box - thus, the error message about the age of the glibc. This is a known issue and seems to be solved just by manually putting the key files from the Flash Player installer into your global plugins folder at /usr/lib/mozilla/plugins

Just out of curiousity, what are the key files? Thanks.

The key files for Flash are listed in the first post of the thread.

Cheers,
John
Title: Re: Flashplayer 9 won't install VL 5.8 Standard
Post by: Sivatheja on February 02, 2008, 04:17:47 am
I have same problem, but I'm using sea monkey. Also mozilla is installed on the system. I've tried copying files to /usr/lib/mozilla/plugins, but the xpt file is already present it that.

Where are the files to be copied now (for the plugin to be installed in sea monkey)?
Title: Re: Flashplayer 9 won't install VL 5.8 Standard
Post by: dawnsboy on February 02, 2008, 07:54:12 am
The files present in /usr/lib/mozilla/plugins are the ones in use by Flashplayer 7 which is installed with the OS.  It is ok to overwrite them.
Title: Re: Flashplayer 9 won't install VL 5.8 Standard
Post by: Sivatheja on February 02, 2008, 09:16:07 am
Will that reflect in SeaMonkey also?

EDIT: It  did reflect, now I have flash plugin.
Title: Re: Flashplayer 9 won't install VL 5.8 Standard
Post by: fuelinux on March 28, 2008, 03:12:13 am
replaced file:///usr/lib/mozilla/plugins/libflashplayer.so with new one. Still doesn't work. Neither on Opera not Mozilla nor SeaMonkey :(
Should I restart the machine?
Title: Re: Flashplayer 9 won't install VL 5.8 Standard
Post by: dawnsboy on March 31, 2008, 06:22:06 pm
Quote
replaced file:///usr/lib/mozilla/plugins/libflashplayer.so with new one. Still doesn't work. Neither on Opera not Mozilla nor SeaMonkey Sad
Should I restart the machine?

Don't forget to copy libflashplayer.so and flashplayer.xpt to /usr/lib/mozilla/plugins/  ;)
Title: Re: Flashplayer 9 won't install VL 5.8 Standard
Post by: shahgols on June 28, 2008, 10:29:34 am
Hi guys,

I don't see the two files in the tar.gz file that I downloaded.  When I untar, I only see the following in the newly created folder:

flashplayer-installer*  libflashplayer.so*

Title: Re: Flashplayer 9 won't install VL 5.8 Standard
Post by: shahgols on June 28, 2008, 10:29:40 am
Sorry, double post.
Title: Re: Flashplayer 9 won't install VL 5.8 Standard
Post by: shahgols on June 29, 2008, 09:57:29 am
Guys, I really need help.  It seems like the flash on some sites stopped working recently.  Perhaps they upgraded the flash software on their site.  I need to upgrade to the latest flash, but I can't find the right files.  I downloaded the flash file from here:

http://www.adobe.com/products/flashplayer/

But when I untar the file from that site, I don't see the two files that was mentioned in the first post.  Where do you guys get the flash player from?
Title: Re: Flashplayer 9 won't install VL 5.8 Standard
Post by: shahgols on June 29, 2008, 10:30:35 am
You know, I just placed the one file that was there (libflashplayer.so) in the /usr/lib/mozilla/plugins folder and now flash works again.  At least it's working for now, don't know what the other file's purpose is.
Title: Re: Flashplayer 9 won't install VL 5.8 Standard
Post by: dawnsboy on June 29, 2008, 03:55:28 pm
flashplayer.xpt is no longer included in the *tar.gz package in the latest updates of flashplayer 9.