VectorLinux

Vectorbie Station => Vectorbie Questions => Topic started by: kc1di on December 13, 2007, 06:07:41 pm

Title: Audacity
Post by: kc1di on December 13, 2007, 06:07:41 pm
Has anyone gotten Audacity installed and working on Vector 5.9 RC3?

I have it installed but get the following error message when I try to run it:

audacity: error while loading shared libraries: libtwolame.so.0: cannot open shared object file: No such file or directory

any help appreciated.
Title: Re: Audacity
Post by: Triarius Fidelis on December 13, 2007, 06:53:30 pm
Try 'slapt-get --install twolame', then '/sbin/ldconfig' if it still doesn't work.

Hmm

There appear to be two problems with the audacity package. It needs to add twolame as a dependency and requires an newer version of wxGTK than what that we have.
Title: Re: Audacity
Post by: jduped on December 13, 2007, 08:19:36 pm
I have audacity working in VL 5.9 RC3

I got the same error installed twolame, made sure I wasn't running any music software and ran it, and have run it since no issue as long as I dont' have something using my sound card.
Title: Re: Audacity
Post by: kc1di on December 14, 2007, 03:21:33 am
Try 'slapt-get --install twolame', then '/sbin/ldconfig' if it still doesn't work.

Hmm

There appear to be two problems with the audacity package. It needs to add twolame as a dependency and requires an newer version of wxGTK than what that we have.

Thank you wil try that today.
Title: Re: Audacity
Post by: jduped on December 14, 2007, 04:41:16 am
I only had to add twolame, and re-run the program. I did so with the terminal open and no error came up.
Title: Re: Audacity
Post by: saulgoode on December 14, 2007, 05:20:37 am
Try 'slapt-get --install twolame', then '/sbin/ldconfig' if it still doesn't work.

Shouldn't the package's doinst.sh be performing ldconfig? If not, I would be interested in learning more about the reasoning.
Title: Re: Audacity
Post by: exeterdad on December 14, 2007, 06:08:35 am
Try 'slapt-get --install twolame', then '/sbin/ldconfig' if it still doesn't work.

Hmm

There appear to be two problems with the audacity package. It needs to add twolame as a dependency and requires an newer version of wxGTK than what that we have.
Just a hunch, But I know the media bonus cd has a newer version of wxGTK, and I'd bet that audacity came from it as well since much of what is on the CD is in the repos as well.  I'm guessing the audacity package was built against that version of wxGTK.
Title: Re: Audacity
Post by: Triarius Fidelis on December 14, 2007, 06:11:06 am
Just a hunch, But I know the media bonus cd has a newer version of wxGTK, and I'd bet that audacity came from it as well since much of what is on the CD is in the repos as well.  I'm guessing the audacity package was built against that version of wxGTK.

That's what rbistolfi thought as well.
Title: Re: Audacity
Post by: kc1di on December 14, 2007, 11:36:20 am
I've install Twolame now get the following error message.. I have jack-audio installed.

audacity: error while loading shared libraries: libjack.so.0: cannot open shared object file: No such file or directory

Title: Re: Audacity
Post by: Triarius Fidelis on December 14, 2007, 10:32:52 pm
I've install Twolame now get the following error message.. I have jack-audio installed.

audacity: error while loading shared libraries: libjack.so.0: cannot open shared object file: No such file or directory

Damn... slapt-get --install jack I guess?
Title: Re: Audacity
Post by: jduped on December 14, 2007, 11:40:38 pm
I've got this kind of issue for other apps I have tried to add even though gslapt said they were installed...my most specific example I can recall is with ruby ripper, I'd heard good things about it, added the dependences I could via gslapt and when trying to install the check said they weren't present.  Same thing when I was trying to add VLC

I'm just saying I had the same problem although not with Audacity.

Does any one have suggestions to make installs more consistent and successful?
Title: Re: Audacity
Post by: kc1di on December 15, 2007, 03:22:56 am
I've install Twolame now get the following error message.. I have jack-audio installed.

audacity: error while loading shared libraries: libjack.so.0: cannot open shared object file: No such file or directory

Damn... slapt-get --install jack I guess?

I Already have Jack installed so must be something else that I'm missing just don't know what. Will keep trying.
Title: Re: Audacity
Post by: rbistolfi on December 15, 2007, 09:01:16 am
what says the output of ls -l /usr/lib/libjack* ?
Title: Re: Audacity
Post by: kc1di on December 16, 2007, 05:36:24 am
what says the output of ls -l /usr/lib/libjack* ?

Thank you I don't know why I did not check that before It showed that jack was not installed even thoug Gsplat said it was. re-installed with slapt-get and now Audacity is work.
Thanks,
Happy Holidays.
Dave
Title: Re: Audacity
Post by: Triarius Fidelis on December 16, 2007, 08:23:04 pm
The dependency data need to be fixed though...  :-\