VectorLinux

The nuts and bolts => Software General => Topic started by: InTheWoods on January 23, 2008, 05:47:00 pm

Title: K3B permisions
Post by: InTheWoods on January 23, 2008, 05:47:00 pm
I am using K3B on Vec 5.9 and cannot burn CDs as a normal user. Only as root. How do I change this?
Title: Re: K3B permisions
Post by: rbistolfi on January 23, 2008, 05:48:00 pm
Run k3bsetup as root once, it will set the proper permissions for you.
Title: Re: K3B permisions
Post by: InTheWoods on January 28, 2008, 05:37:12 pm
Thanks!
Title: Re: K3B permisions
Post by: Stokstaartje on January 29, 2008, 04:21:37 am
That solution doesn't do it for me. Still get a /dev/hdc not found or no write permissions. And even worse after using K3B my CD writer is not accessible anymore and I have to reboot to have it available again... What kind of permissions do I need to set?
Title: Re: K3B permisions
Post by: newt on January 29, 2008, 08:55:24 am
It's always worked for me to just run 'k3bsetup' and click apply when it fully loads.  That's it.
Title: Re: K3B permisions
Post by: nightflier on January 29, 2008, 09:45:35 am
For those with problems: Do you have more than one optical drive?
Title: Re: K3B permisions
Post by: InTheWoods on January 29, 2008, 02:43:32 pm
I actually had to try a few times. I was successful only after clicking "default" then "apply"
Title: Re: K3B permisions
Post by: Stokstaartje on January 29, 2008, 10:39:13 pm
Now there you go. Finally out of the woods! After a little trip as root and wielding the magic wand of Default/Apply it does work. Ripping and surfing as we speak.

Thanks...

(and just one optical drive, this is all on my (t)rusty Dell Latitude C600 laptop...)
Title: Re: K3B permisions
Post by: Stokstaartje on February 05, 2008, 01:27:41 am
Strange enough the permissions issues keep returning. All is well for a couple of days usage of K3b and then suddenly everything goes hay wire again. This time the above procedure does not result into the right permissions being set, leaving me with an /dev/hdc not found error when starting the actual ripping of a cd.

It is like the right settings get overwritten once in a while. The same goes for my wifi settings. But sofar resetting these to the correct values has been possible, restoring my wifi connection.

I guess this calls for further investigation...
Title: Re: K3B permisions
Post by: Andy Price on February 26, 2008, 07:47:18 am
Have you tried setting permissions from inside the program? Settings > Setup System Permissions, enter the root password, then set "use burning group" to users. Not sure if this is the best way, but it works for me.
Title: Re: K3B permisions
Post by: Stokstaartje on February 26, 2008, 02:36:20 pm
I'll have to be honest with you: I chickened out. I use VL for all stuff business related (mail, browsing, blogging, writing) and I use Dynebolic for everything multimedia related (podcasting, burning, ripping,...). Simply because Dynebolic is way more responsive when it comes to these tasks. K3b under VL is, apart from the issues above, is way too slow for my taste.

I do not mind switching between dedicated distro's. And in this case it is even more enjoyable as they both use Xfce by default.