VectorLinux

Vectorbie Station => Vectorbie Questions => Topic started by: Martin109 on May 05, 2008, 11:25:22 am

Title: Only USB Mouse Recognized
Post by: Martin109 on May 05, 2008, 11:25:22 am
Setting up VL 5.8 SOHO on a new HP laptop for a friend, it's not recognising the built-in pad and button, only a USB mouse.  I tried rebooting without the USB fitted, which didn't work.  I tried using VASM to reconfigure the system with the laptop-specific mouse option, but still no response from the built-in hardware.  Any ideas? :-\
Title: Re: Only USB Mouse Recognized
Post by: bigpaws on May 05, 2008, 07:32:47 pm
Change /etc/X11/xorg.conf to mouse IMPS/2

Bigpaws
Title: Re: Only USB Mouse Recognized
Post by: Martin109 on May 08, 2008, 10:56:52 am
Change /etc/X11/xorg.conf to mouse IMPS/2
Bigpaws

Thanks, Bigpaws

I've now had another look at the xorg.conf file, and the entry looks like this:

Section "InputDevice"
Identifier  "Mouse0"
Driver      "mouse"
Option       "Protocol" "auto"
Option       "Device" "/dev/mouse"
Option       "ZAxisMapping" "4 5"
EndSection


Which bit(s) should I change?  Tried changing Driver  "mouse" to  Driver "IMPS/2", but that didn't work.

Tried changing it via VASM, but that didn't work, even after reboot.
Title: Re: Only USB Mouse Recognized
Post by: Martin109 on May 09, 2008, 01:24:22 pm
Bump!
Title: Re: Only USB Mouse Recognized
Post by: bigpaws on May 09, 2008, 02:11:57 pm
"Protocol" "IMPS/2"

see if that works, you may also have to change /dev/mouse to
/dev/input/mice.

HTH

Bigpaws
Title: Re: Only USB Mouse Recognized
Post by: Martin109 on May 09, 2008, 02:51:15 pm
Thanks, Bigpaws.

I've made both those changes, but unfortunately still no change! :-\