VectorLinux

The nuts and bolts => Hardware & Drivers => Topic started by: RagingGoblin on June 09, 2008, 02:10:27 am

Title: Nics keep switching despite rules in /etc/udev/rules.d/network-devices
Post by: RagingGoblin on June 09, 2008, 02:10:27 am
Hello,
With VL 5.9 I have the switching problem. One NIC is a BroadCom 4318, a wireless pcmcia card, the other a onboard NIC I never use. The BIOS does not give me the possibility to switch of this one. I have set the rules in /etc/udev/rules.d/network-devices.rules so the built in NIC should be eth0, the BroadCom eth1. But it keeps switching. I even have a symlink /etc/udev/rules.d/75-network-devices.rules to this file representing the 'Slackware situation'. The only solution I see is to write a script that parses the output of iwconfig and sets a symlink to eth0 or eth1 and use this. I do not have the knowledge about bash to do this, so I will have to learn this. Anyone with another idea?
Title: Re: Nics keep switching despite rules in /etc/udev/rules.d/network-devices
Post by: rbistolfi on June 09, 2008, 07:04:17 am
Please take a look at this: http://www.vectorlinux.com/forum2/index.php?topic=979.0
Let us know if that works for you.
Title: Re: Nics keep switching despite rules in /etc/udev/rules.d/network-devices
Post by: RagingGoblin on June 09, 2008, 07:20:10 am
I have set the rules in /etc/udev/rules.d/network-devices.rules so the built in NIC should be eth0, the BroadCom eth1. But it keeps switching. I even have a symlink /etc/udev/rules.d/75-network-devices.rules to this file representing the 'Slackware situation'. T

No this did not work
Title: Re: Nics keep switching despite rules in /etc/udev/rules.d/network-devices
Post by: uelsk8s on June 09, 2008, 07:37:37 am
IMO the easiest way to do this would be to copy the script /sbin/VLwifi and take out the user prompts and replace them with your essid and such then have it run at boot
Title: Re: Nics keep switching despite rules in /etc/udev/rules.d/network-devices
Post by: RagingGoblin on June 19, 2008, 05:58:01 am
Solved, Setting the rules in /etc/udev/rules.d/network-devices.rules behaves strange:

Setting only the onboard card to eth0 -> switching
Setting the onboard to eth0, the pcmcia to eth1 -> switching
Setting only the pcmcia card to eth1 -> no switching !!

 ???

Anyway problem solved