VectorLinux

General Announcements => VL package news and Updates => Topic started by: exeterdad on June 09, 2008, 06:21:55 am

Title: 080609 gnutls-2.2.2 [VL59]
Post by: exeterdad on June 09, 2008, 06:21:55 am
kc1di has packaged gnutls-2.2.2 for VL59

Package: gnutls-2.2.2-i486-1.tlz
MD5: 6578bf64d97644a04a1d2f07f19bedd7
Package Size: 1,294 KIB (1.26 MB)
Installed size: 3,130 KIB (3.06 MB)

Sources: http://vectorlinux.osuosl.org/veclinux-5.9/source/testing/x-dev/gnutls
Quote
gnutls: gnutls (GNU TLS library)
gnutls:
gnutls: This is a TLS (Transport Layer Security) 1.0 and SSL (Secure Sockets
gnutls: Layer) 3.0 implementation.  In brief, GnuTLS can be described as a
gnutls: library which offers an API to access secure communication protocols.
gnutls: These protocols provide privacy over insecure lines, and were designed
gnutls: to prevent eavesdropping, tampering, or message forgery.
gnutls:
gnutls: Homepage: http://www.gnu.org/software/gnutls/
gnutls:
gnutls:

After testing this package, please take a moment and come back to this thread to let us know how it works for you.
Title: Re: 080609 gnutls-2.2.2 [VL59]
Post by: rbistolfi on June 09, 2008, 08:03:49 am
The upgrade of gnutls broke some other transferring programs. Attempted some symlinks but still complains about functions missing so looks like is a good idea to keep the old one. I can't connect to sftp services with the new one.
Anyone else with same results?
Title: Re: 080609 gnutls-2.2.2 [VL59]
Post by: kc1di on June 10, 2008, 08:29:40 am
The upgrade of gnutls broke some other transferring programs. Attempted some symlinks but still complains about functions missing so looks like is a good idea to keep the old one. I can't connect to sftp services with the new one.
Anyone else with same results?

I'm not noticing that problem here. using 5.9 std gold. can connect to via ssh to the vector contrib no problem with both gftp and filezilla.  there is a setup script in filezilla you have to run to test your server though.

Don't know what the problem could be .  Just tried a transfer using filezilla workd fine here.

Dave
Title: Re: 080609 gnutls-2.2.2 [VL59]
Post by: rbistolfi on June 10, 2008, 11:33:00 am
Thanks Dave I will check in a few hours back in home. I didn't try gFtp, I usually use lftp, may be is just something specifically attached to lftp.
Title: Re: 080609 gnutls-2.2.2 [VL59]
Post by: exeterdad on June 24, 2008, 06:15:05 am
This package has been removed from testing.
Although the package was well built, testing has shown that too much has changed with gnutls since our original package was created.  Too many important applications that we are using are not compatible with this newer version.  Those that have installed this package, please downgrade to the original version.

Thanks to those who have tested. :)
Title: Re: 080609 gnutls-2.2.2 [VL59]
Post by: wcs on August 01, 2008, 03:56:08 pm
Only found this now.
To me, it gave me problems with printing. No printing in xfce or kde applications.
Downgraded and it is fine.

Thanks.
Title: Re: 080609 gnutls-2.2.2 [VL59]
Post by: rbistolfi on August 01, 2008, 04:04:06 pm
Only found this now.
To me, it gave me problems with printing. No printing in xfce or kde applications.
Downgraded and it is fine.

Thanks.

Wcs, the 2.x branch is not compatible with the 1.x branch and apps compiled against one branch wont work with the other one. If you want to give it a try, there is a gnutls-1.6.3 which is a security patch for our old package and it should work fine with cups, pidgin, and the rest of network related apps. Afaik the 1.x series will be still maintained for a while.
Title: Re: 080609 gnutls-2.2.2 [VL59]
Post by: wcs on August 02, 2008, 01:43:49 am
Quote
Wcs, the 2.x branch is not compatible with the 1.x branch and apps compiled against one branch wont work with the other one.

Thanks. Would it be possible to have both installed, then, so that all apps would work?
In principle, I mean, as I guess the repo doesn't have packages compiled against the 2.x branch.

Quote
there is a gnutls-1.6.3 which is a security patch for our old package

That's the one I downgraded to. A slack package, right?
Thanks!
Title: Re: 080609 gnutls-2.2.2 [VL59]
Post by: rbistolfi on August 02, 2008, 08:05:19 am
Quote
Wcs, the 2.x branch is not compatible with the 1.x branch and apps compiled against one branch wont work with the other one.

Thanks. Would it be possible to have both installed, then, so that all apps would work?
In principle, I mean, as I guess the repo doesn't have packages compiled against the 2.x branch.

Well, I did try that during testing filezilla, packaged by Dave, it needs 2.x version to work. It worked for me, tested ftp programs like filezilla, gftp and lftp, and messaging programs like pidgin. For some reason I was not comfortable with that, and as I do not need apps that need 2.x to work, I removed it. The repo has not 2.x apps compiled with gnutls 2.x dynamically linked, but filezilla does have gnutls-2.x statically linked. If you need 2.x for a 5.9 package that is a solution, to compile gnutls-2.x with --enable-static (or --disable-shared I dont remember :))

Quote
Quote
there is a gnutls-1.6.3 which is a security patch for our old package

That's the one I downgraded to. A slack package, right?
Thanks!
[/quote]

Right, gnu-tls is part of the core that VL uses from Slackware.
Title: Re: 080609 gnutls-2.2.2 [VL59]
Post by: wcs on August 02, 2008, 08:09:00 am
great... thanksa lot for the info!
Title: Re: 080609 gnutls-2.2.2 [VL59]
Post by: kc1di on August 02, 2008, 04:14:21 pm
Quote

Well, I did try that during testing filezilla, packaged by Dave, it needs 2.x version to work. It worked for me, tested ftp programs like filezilla, gftp and lftp, and messaging programs like pidgin. For some reason I was not comfortable with that, and as I do not need apps that need 2.x to work, I removed it. The repo has not 2.x apps compiled with gnutls 2.x dynamically linked, but filezilla does have gnutls-2.x statically linked. If you need 2.x for a 5.9 package that is a solution, to compile gnutls-2.x with --enable-static (or --disable-shared I dont remember :))

configure it with --enable-static --disable--shared will do the trick.