VectorLinux

The nuts and bolts => Networking & Security => Topic started by: Jerry on September 24, 2008, 12:56:08 pm

Title: "FATAL module ndiswrapper not found"
Post by: Jerry on September 24, 2008, 12:56:08 pm
I just purchased the download of the 5.9.1 soho and am having the same problem
I've had with all distros attempted on this Toshiba Satellite laptop:  no wireless.

This time, though, the problem is that after getting the Realtek 8187b driver installed
into ndiswrapper, I get the error message (on modprobe nidswrapper) that it does
not exist (that nidswrapper does not exist, lsusb shows my wireless device). 

And, of course, I get "no wireless devices found" when attempting Vwifi.

I am happy to support Vector and other distros, but at some point I would like to
be able to use Vector on this laptop on the internet. 

The steps leading up to the "FATAL module ndiswrapper not found" all went well as
if ndiswrapper was loaded and working fine.  But as soon as I attempted to load
ndiswrapper I got that fatal message.

Can anybody help with this?
Title: Re: "FATAL module ndiswrapper not found"
Post by: newt on September 24, 2008, 01:10:34 pm
Probably just a typo in your post, but I noticed that you spelled ndiswrapper incorrectly in your modprobe command (i.e. nidswrapper).  If you think you may have mispelled ndiswrapper in the terminal then try loading the module again with the correct spelling.  If you just mispelled it in your post then we're back to the initial problem. ;D

Good luck!
Title: Re: "FATAL module ndiswrapper not found"
Post by: Jerry on September 24, 2008, 01:14:07 pm
Probably just a typo in your post, but I noticed that you spelled ndiswrapper incorrectly in your modprobe command (i.e. nidswrapper).  If you think you may have mispelled ndiswrapper in the terminal then try loading the module again with the correct spelling.  If you just mispelled it in your post then we're back to the initial problem. ;D

Good luck!

lol  .. I have done that, misspelled on commands in terminal.  Not this time though.   ;)  Quadruple checked..   etc.. 
When a misspelling happens in terminal, the word, "FATAL" is not seen, just something like "command not known"
or whatever, I believe.

I am wondering if the kernel needs to be recompiled for ndiswrapper in this version of Vector.   I just wish that for
once I could have linux on this laptop.
Title: Re: "FATAL module ndiswrapper not found"
Post by: lagagnon on September 24, 2008, 01:56:24 pm
I get the error message (on modprobe nidswrapper) that it does
not exist (that nidswrapper does not exist, lsusb shows my wireless device). 

Would it be that you mispelled it as you did above (it is "ndiswrapper", not "nidswrapper")?
Title: Re: "FATAL module ndiswrapper not found"
Post by: Jerry on September 24, 2008, 02:15:38 pm
I get the error message (on modprobe nidswrapper) that it does
not exist (that nidswrapper does not exist, lsusb shows my wireless device). 

Would it be that you mispelled it as you did above (it is "ndiswrapper", not "nidswrapper")?

http://forum.vectorlinux.com/index.php?topic=7379.msg50443#msg50443
Title: Re: "FATAL module ndiswrapper not found"
Post by: MikeCindi on September 25, 2008, 01:11:10 pm
This is not a typo by jerrybasham as I have gotten the same "FATAL" error when running VLwifi. The spelling is automated. I have tried installing ndiswrapper 1.53 but get the same error. So something has changed from SOHO 5.9 to 5.9.1. I hope to get that figured out soon.
Title: Re: "FATAL module ndiswrapper not found"
Post by: caitlyn on September 25, 2008, 01:14:17 pm
There was an error in the kernel build for VL 5.9.1 and ndiswrapper wasn't included.  There is a new ndiswrapper package that solves this problem in the patches repository.  Please enable patches in gslapt or in you /etc/slapt-get/slapt-getrc file if you prefer the command line.  It wasn't enabled by default (and yes, it should have been).  Once you've done that you can install the ndiswrapper package for VL 5.9.1.
Title: Re: "FATAL module ndiswrapper not found"
Post by: MikeCindi on September 25, 2008, 01:19:04 pm
Well, that makes it easy for me; I'll give it a shot tonight. Thank you.
Title: Re: "FATAL module ndiswrapper not found"
Post by: ElEdwards on September 26, 2008, 12:42:08 pm
Is there a way to download ndiswrapper in WinXP, then reboot to Vector and install it there?

XP is the only method I currently have for getting things until I can get wireless working in Vector.

El
Title: Re: "FATAL module ndiswrapper not found"
Post by: caitlyn on September 26, 2008, 12:49:05 pm
Navigate with your browser to:

http://vectorlinux.osuosl.org/veclinux-5.9/patches/kernel/

Download the ndiswrapper package with the .tlz extension.
Title: Re: "FATAL module ndiswrapper not found"
Post by: newt on September 26, 2008, 01:07:29 pm
To add to cait's post:

Once you've downloaded the package in WinXP, reboot to VL.

You need to make sure the bolded portions below are accurate for your system. 

Mount your WinXP partition (as root, mount -t ntfs /dev/hda1 /mnt/win)
---You can find out the correct device by issuing: fdisk -l | grep ntfs
---This should return a single line (hopefully) that begins with '/dev/...', and that should be the correct device to mount.

Copy the package from your WinXP partition to your home directory (as root, cp /mnt/win/path/to/package/in/windows/ndiswrapper-1.53_2.6.25.7-i586_vectorlinux-1vl59.tlz ~/)

Install the package (as root, installpkg ~/ndiswrapper-1.53_2.6.25.7-i586_vectorlinux-1vl59.tlz)

Hope this helps
Title: Re: "FATAL module ndiswrapper not found"
Post by: Jerry on September 27, 2008, 05:44:14 am
Navigate with your browser to:

http://vectorlinux.osuosl.org/veclinux-5.9/patches/kernel/

Download the ndiswrapper package with the .tlz extension.

Yay!  (to say the least!)   ;D