VectorLinux

The nuts and bolts => Migrating to VectorLinux => Topic started by: StrayBit on October 05, 2008, 06:45:57 am

Title: At long last!
Post by: StrayBit on October 05, 2008, 06:45:57 am
I've been trying for over 10 years to get Linux (usually Slackware) working on my old windows boxes.  Finally got a reply from Pat saying "Yes, while this version (4 or earlier?) would run in 8MB ram, it needs a bit more to setup." 

Occasionally could get one installed but couldn't figure out how to work it! (I migrated from CP/M-MSDOS-Win95-Win98.)  Started trying LiveCDs (DSL, Puppy, Slack 7, Ubantu, VL4).  Some of them found my Wireless Broadband connection.  Then I couldn't download VL5.9 Standard iso though I could get VL4 to get as much as 520MB).

Yesterday, I had a friend download the iso and create a cd.  After a couple of false starts with my partitioning, it installed on this PII(I) 500MHz box the first time and got me onto the internet.   

Unfortunately, When I try to access the HOWTOs from the Vector-Docs icon, I get the following message:
"Forbidden"
"You don't have permission to access /vectorlinux/forum/viewforum.php"
Apache/2 Server at www.ibiblio.org Port 80"
Do I have to be logged in with root privileges?  Or is there something else that I have done wrong?

Sorry this is solooooong!
Title: Re: At long last!
Post by: lagagnon on October 05, 2008, 07:10:34 am
Unfortunately, When I try to access the HOWTOs from the Vector-Docs icon, I get the following message:
"Forbidden"
"You don't have permission to access /vectorlinux/forum/viewforum.php"
Apache/2 Server at www.ibiblio.org Port 80"

Welcome to the VL Forums! Please show us the link you are attempting to access where you get that message...
Title: Re: At long last!
Post by: StrayBit on October 05, 2008, 08:26:54 am
It happens on several of the links -- just to pick one "installing Opera and BitTorrent":
  http://ibiblio.org/vectorlinux/forum/viewtopic.php?t=2627
Title: Re: At long last!
Post by: nightflier on October 05, 2008, 06:40:32 pm
That is an old link to a non-functioning message board. The document (from VL4?) is out of date.  :(
Title: Re: At long last!
Post by: StrayBit on October 06, 2008, 06:44:36 am
But this is from the desktop of the 5.9 fresh installation! 

I only used VL4 to attempt to download 5.9 and it was unsuccessful.

VL5.9 was downloaded on a Vista system and the cd created on that machine.
Title: Re: At long last!
Post by: lagagnon on October 06, 2008, 07:03:53 am
OK, but as nightflier says those are old links from an old no longer existing forum. The latest docs are already pre-loaded on your 5.9 box ( there should have been an icon to them).

For the latest HOWTO's go here:
http://forum.vectorlinux.com/index.php?board=10.0

For latest online docs go here:
http://vectorlinux.osuosl.org/docs/vl59/index.html
Title: Re: At long last!
Post by: StrayBit on October 06, 2008, 10:07:47 am
Thanks.  I had already found, and bookmarked, these links.

I still don't understand how I would have the invalid links as VL4 was run as a live cd (and didn't seem to have any persistence from on session to the next) and hda was partitioned and reformatted on insertion of the new VL5.9 cd.  Unless, it put something on hdc which is my old Win98 drive. Opps!  On one of my earlier installation tries with another distro, I had formatted my Zip drive as a swap partition!  Perhaps I should remove that disk, erase hda and start over?  (hda1 is swap - 100-200MB, hda - nearly 4GB is / )

This is off the subject but, I just purchased an NIC but I have to compile the module for it (they provided the source).  So far, I've gotten thoroughly confused trying to figure out how to use gcc on it. (I did some light C programming in DOS).  So far, I haven't seen any thing like compiling a module in the forums - though there a few I have yet to check out.  Could you direct me to the proper place?
Title: Re: At long last!
Post by: newt on October 06, 2008, 10:16:26 am
Most times nics are pretty well supported by VL, however you may need to enable the module (driver).  Can you provide the NICs brand/model/interface and we'll help you get it working properly?

If you have it already installed then you can probably find it's device information via the commands: 'lspci' or 'lsusb'

Cheers!
Title: Re: At long last!
Post by: StrayBit on October 06, 2008, 10:42:04 am
The new NIC is a D-Link DFE-530TX+ Fast Ethernet Desktop PCI Adapter.  The cd that came with it provided drivers for windows and the source code for Linux. 

I have the NIC installed in the machine but VL hasn't recognized it so I figured that I had to make the module for it.

#paste
root:# lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 635 Host (rev 11)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] Virtual PCI-to-PCI bridge (AGP)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS85C503/5513 (LPC Bridge)
00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
00:02.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 07)
00:02.3 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 07)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev d0)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
00:09.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 315PRO PCI/AGP VGA Display Adapter
vector://temp/src
root:# lsusb
Bus 2 Device 1: ID 0000:0000 
Bus 1 Device 1: ID 0000:0000
Title: Re: At long last!
Post by: StrayBit on October 06, 2008, 10:45:01 am
PS
I don't know if it is needed but the hardware revision is F2.

Now, how do I get of SU? Close the terminal window?

Thanks
Title: Re: At long last!
Post by: newt on October 06, 2008, 10:55:09 am
To get out of 'su' you can just type 'exit' ENTER and you'll be dropped back to your normal user.

It looks like your NIC has been identified: 00:09.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
Likely, this is the chipset used on the D-Link card, which should make it fairly easy to add to the system.

The module should be 8139too, so (as root) you can try loading this module by typing: modprobe 8139too

Then check with 'lsmod' to make sure this module is loaded, and then check with 'ifconfig -a' to see if eth0 has been added.
Title: Re: At long last!
Post by: StrayBit on October 06, 2008, 11:16:03 am
Thanks for helping with SU - just like I got out of the command prompt in Windows.

The RealTek 8139 is the NIC used to connect to my Wireless BroadBand so I can post to this forum.  (Funny - or as usual! - I didn't notice the RealTek when I posted that list!

The D-Link will be used to connect to my other PCs.

Title: Re: At long last!
Post by: newt on October 06, 2008, 01:37:22 pm
Well, it looks as though your D-Link NIC adapter will use the same driver according to D-Link's driver download webpage.  I would start by putting the card in your system and then running lspci, and ifconfig -a.  You may find this whole process to be easier that first expected - if so, then that's always welcome :D
Title: Re: At long last!
Post by: StrayBit on October 06, 2008, 09:06:25 pm
I had the card in the machine while we were conversing but after about 6 hours, I lost internet.

I looked at ifconfig (without -a) once before I lost internet and it only listed the the RTL8139.  It wasn't until after losing internet that I discovered using the -a option which listed eth0 and eth1 but no ip address.  Removing the D-Link card restored internet and ifconfig (with or without -a listed my ip.  Inserting the D-Link card in another PCI slot resumed the prior non-working status.

I downloaded the driver from D-Link and, with 2 exceptions, it appears the same as provided on the cd.  The cd version is named rhinefet.tgz  and only went to 2.6.18 (uname -r yields 2.6.22.14) and contains 3 more files;  I don't see that restriction on the downloaded driver dlkfet-4.39.tar.gz which doesn't have osdep.h, rhine_hw.c, or rhine_hw.h.


Which still leaves stuck at the following instruction:
   5) Compile the driver source files and it will generate rhinefet.o, and
       copy it to correct driver installation path (The installation directory
       is different in different kernel versions. In 2.4.x/2.6.x kernel, the path
       is /lib/modules/KERNEL_VERSION/kernel/drivers/net/, ...
How do I compile?  Opps!  I discovered if I right-click on rhinefet.tgz (from the cd), it would offer to install.  The download file is dlkfet-4.39.tar.gz and right click allows extraction but no installation.

Ugh! It's past my bedtime. Try some more tomorrow.
Title: Re: At long last!
Post by: caitlyn on October 06, 2008, 09:21:31 pm
I honestly don't think you need to compile that driver.  From what you've posted it really looks like Vector Linux already has that driver in the kernl and is already recognizing your NIC.  It's just a matter of configuring it in vasm if I'm right.  Please post the output of

/sbin/ifconfig -a

and let's go from there.  I suspect you're trying to reinvent the wheel when it just isn't necessary.  ;D
Title: Re: At long last!
Post by: StrayBit on October 07, 2008, 05:22:34 am
# The D-Link NIC was physically installed Monday morning.
  But 3 - 4 hours later I lost internet
# with D-Link NIC:
vector:/~
root:# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:21:91:21:CF:AB 
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:120 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:9343 (9.1 KiB)  TX bytes:4720 (4.6 KiB)
          Interrupt:11 Base address:0x2e00

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1562 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1562 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:79828 (77.9 KiB)  TX bytes:79828 (77.9 KiB)

vector:/~
root:# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:21:91:21:CF:AB 
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:120 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:9343 (9.1 KiB)  TX bytes:4720 (4.6 KiB)
          Interrupt:11 Base address:0x2e00
#NOTE: No IP address, no Internet

eth1      Link encap:Ethernet  HWaddr 00:03:B3:00:66:DB 
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:11 Base address:0xd400

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1562 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1562 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:79828 (77.9 KiB)  TX bytes:79828 (77.9 KiB)

vector:/~

# after removing D-Link NIC:
vector://home/bruce
root:# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:03:B3:00:66:DB 
          inet addr:75.94.15.38  Bcast:75.94.63.255  Mask:255.255.192.0
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3116 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1665 errors:0 dropped:0 overruns:0 carrier:0
          collisions:9 txqueuelen:1000
          RX bytes:1952341 (1.8 MiB)  TX bytes:354460 (346.1 KiB)
          Interrupt:11 Base address:0xd400
#NOTE: IP address, Internet

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:54 errors:0 dropped:0 overruns:0 frame:0
          TX packets:54 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:4428 (4.3 KiB)  TX bytes:4428 (4.3 KiB)

vector://home/bruce
root:# ifconfig -a
# same as above
Title: Re: At long last!
Post by: caitlyn on October 07, 2008, 10:10:59 am
As expected, your DLink NIC is correctly detected by the OS and is assigned eth1.  You don't need to compile the drive because it's already there.  All you need to do is configure it using vasm or vasmCC.  Those are the GUI admin tools in Vector Linux.  Take a look there and see if you understand how to configure your card.  Based on your posts so far I expect you won't have much trouble.
Title: Re: At long last!
Post by: StrayBit on October 07, 2008, 01:57:16 pm
Thanks, Caitlyn,

VASM and VASMCC only reportrd eth0 on my previous tries.  I'll put the card back in and try it and report back in a few minutes.

I'm enjoying reading other posts.  It is great that there are no flame wars here.  The one time I thought I was seeing one, it turned out to be MY mis-reading the post.

Back in a few.
Title: Re: At long last!
Post by: StrayBit on October 07, 2008, 02:41:52 pm
vector:/~
root:# lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 635 Host (rev 11)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] Virtual PCI-to-PCI bridge (AGP)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS85C503/5513 (LPC Bridge)
00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
00:02.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 07)
00:02.3 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 07)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev d0)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
00:09.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
00:0b.0 Ethernet controller: VIA Technologies, Inc. VT6105 [Rhine-III] (rev 86)
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 315PRO PCI/AGP VGA Display Adapter
   It is showing the D-Link (VIA) controller!  It didn't when I did this before!

vector:/~
root:# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:21:91:21:CF:AB     #Note: No IP address!
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:10 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:696 (696.0 b)  TX bytes:3540 (3.4 KiB)
          Interrupt:11 Base address:0xee00

eth1      Link encap:Ethernet  HWaddr 00:03:B3:00:66:DB
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:11 Base address:0xd400

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:54 errors:0 dropped:0 overruns:0 frame:0
          TX packets:54 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:4428 (4.3 KiB)  TX bytes:4428 (4.3 KiB)

vector:/~

vector:/~
root:# vasm
$DCMD --backtitle "$BACKTITLE" --title "$TITLE" --menu "$TEXT" $DIMENSION \
inet1 "DEVICE=eth0, DHCP" \
inet2 "DEVICE=, DHCP" \      # I had set this to eth1 with static ip
inetd "DEVICE=, DHCP" \
2> $freply

This last command cleared the entry for this machine in /etc/hosts

Title: Re: At long last!
Post by: caitlyn on October 07, 2008, 03:52:12 pm
You need to define inet1 as eth1, assign an IP address (or DHCP), and start the interface.  That's all you need to do.
Title: Re: At long last!
Post by: StrayBit on October 07, 2008, 04:17:06 pm
I tried that with VASM but it doesn't take AND it removes the entry for this machine from /etc/hosts!  Or am I trying in the wrong place?
Title: Re: At long last!
Post by: caitlyn on October 08, 2008, 12:13:12 pm
You're doing something wrong.  It certainly works for me and most everyone else.  If you could post specific information about what you are doing then maybe someone can help you.

You can also do it at the command line with netconfig.
Title: Re: At long last!
Post by: bigpaws on October 08, 2008, 01:43:17 pm
I see that you have two NIC cards in this machine,
are you using both? Are both cards connected to the
same router or switch?

In order to get this sorted can you explain this setup
a little more clear.

For example I use the VIA NIC for the network and forward
traffic to the router using the D-Link NIC.

A pic is ok to:

Internet <---> router <---> Dlink <use card name here> < --- > Via NIC <---> rest of network

or

Internet <---> router <---> Dlink <use card name here> and nothing else.


Bigpaws
                                                                                             
Title: Re: At long last!
Post by: StrayBit on October 08, 2008, 04:39:13 pm
OK!
L8139 is connected directly to Clearwire modem (wireless broadband) Should be DHCP
D-Link | VIA goes to intranet switch (local lan).  While I want to use this pc as whatever to assign the ip address, for now I'll continue using static ip with this machine as 192.168.0.1

Since my last post:
Tested the 2 cards with DSL Live:  It found both cards but I couldn't figure out how to talk to my Win2000 machine nor could it find the internet.

Tested the 2 cards with VL4 Live:  It found both cards but I couldn't figure out how to talk to my Win2000 machine nor could it find the internet.

Fdisk HDC: hda1 swap ~256MB, hda2 \ ~20000MB, hda3 /home ~20000.  (Old Win98 is HDC1 but is not bootable) Prior installation only had hdc1 & 2.  Reinstalled VL5.9 with both NIC cards installed.   It found both cards but I couldn't figure out how to talk to my Win2000 machine nor could it find the internet.  Removed RTL8139, couldn't figure out how to talk to my Win2000 machine.

Remove the VIA card and reinstalled RTL8139 to get on the internet.

This machine is a PIII 751MHz.  I don't remember for sure but I think it has 256MB RAM.
Here is ifconfig as I type this:
eth0      Link encap:Ethernet  HWaddr 00:03:B3:00:66:DB 
          inet addr:75.94.15.38  Bcast:75.94.63.255  Mask:255.255.192.0
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:13976 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2255 errors:0 dropped:0 overruns:0 carrier:0
          collisions:42 txqueuelen:1000
          RX bytes:5689312 (5.4 MiB)  TX bytes:394750 (385.4 KiB)
          Interrupt:11 Base address:0xd400

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

and this is when both nics were attached:
eth0      Link encap:Ethernet  HWaddr 00:21:91:21:CF:AB 
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:1180 (1.1 KiB)
          Interrupt:11 Base address:0x2e00

eth1      Link encap:Ethernet  HWaddr 00:03:B3:00:66:DB 
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:11 Base address:0xd400

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

PS: I have BIOS to set NumLock on but all linux that I've tried turn it back off.  Can I change that behavior?
Title: Re: At long last!
Post by: newt on October 08, 2008, 05:47:06 pm
I notice your onboard switches from eth0 to eth1 when you have your D-Link inserted in the system.  Since your onboard is likely not going anywhere I would make some udev rules to have them reversed (onboard is eth0, d-link is eth1).  I _think_ that this will (at least) solve you internet connectivety loss when your d-link is in the system.  To make the udev rules follow Joe's first post in this thread: http://forum.vectorlinux.com/index.php?topic=979.0 .  You will need to create the network-devices.rules file yourself, paste his code, and adjust for your hardware.  Do this and reboot with both devices in your system. Then check ifconfig -a to make sure they are reversed from your previous post (onboard is eth0, d-link is eth1).

Once we can get your onboard nic working properly with the d-link in the system then we can move on to the next step - making the d-link work for all local network traffic.
Title: Re: At long last!
Post by: StrayBit on October 08, 2008, 08:46:11 pm
Thank you for catching that, Newtor.

When I went to /etc/udev/rules.d I found there was NO file named network-devices.rules.

This is a list of files in that directory:
10-vl-hot.rules.disabled  60-pcmcia.rules         90-hal.rules
30-libgphoto2.rules       64-device-mapper.rules  99-fuse.rules
50-udev.rules             80-libpisock.rules     
60-bluetooth.rules        80-libsane.rules

and I didn't see anything in any of them dealing with PCI or etfx.  Actually, in the referenced post he does say "(NOTE: this is actually not provided by default)."

Searching the forum, I found 2 other mentions of this file.  In one of them, the respondent says "so i just create the file
/etc/udev/rules.d/network-devices.rules and add this line in it (if i use only one of the two eths)"  Of course, I'll put both lines in mine.

The only problem:  I have no idea what to prefix the name with.  I'll create the file without a prefix until I hear otherwise,
Title: Re: At long last!
Post by: newt on October 08, 2008, 09:02:23 pm
IIRC, VL5.8 didn't have the prefix number system.  However, that should not be a problem.  Those rules are run in their numeric order so I would _guess_ that this rule in not a PRIORITY_1 rule so I would set it towards the bottom - keep in mind that you cannot go higher than 99.  In other words, I would name the file: 98_network-devices.rules, reboot and see how your network devices line out in ifconfig.

HTH!
Title: Re: At long last!
Post by: StrayBit on October 08, 2008, 09:09:44 pm
...:AB still got switched.  I'll try 98- as a prefix.
Title: Re: At long last!
Post by: newt on October 08, 2008, 09:12:57 pm
Based on your ifconfig data your /etc/udev/rules.d/98-network-devices.rules file should look identical to this:
Code: [Select]
KERNEL=="eth?", SYSFS{address}=="00:03:B3:00:66:DB", NAME="eth0"
KERNEL=="eth?", SYSFS{address}=="00:21:91:21:CF:AB", NAME="eth1"
Title: Re: At long last!
Post by: StrayBit on October 08, 2008, 09:39:38 pm
Just for verification my /etc/udev/rules.d/98-network-devices.rules file is:
KERNEL=="eth?", SYSFS{address}=="00:03:B3:00:66:DB", NAME="eth0"
KERNEL=="eth?", SYSFS{address}=="00:21:91:21:CF:AB", NAME="eth1"

Still can't get the internet with both installed.
Title: Re: At long last!
Post by: newt on October 08, 2008, 10:05:26 pm
After a bit more research I found out that udev is case sensitive and all letters need to be lowercase - doh!!  Please edit your rule and make all letters lowercase, and another reboot.
Code: [Select]
KERNEL=="eth?", SYSFS{address}=="00:03:b3:00:66:db", NAME="eth0"
KERNEL=="eth?", SYSFS{address}=="00:21:91:21:cf:ab", NAME="eth1"
Title: Re: At long last!
Post by: StrayBit on October 09, 2008, 05:08:12 am
We are making progress!  Changed to lower case, put both NICs in and I'm on the internet.

The only problem, the second NIC doesn't show-up in ifconfig -a???
Title: Re: At long last!
Post by: newt on October 09, 2008, 08:34:52 am
Very strange. Does it show in lspci?
Title: Re: At long last!
Post by: StrayBit on October 09, 2008, 08:40:31 am
Yes:
00:09.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
00:0b.0 Ethernet controller: VIA Technologies, Inc. VT6105 [Rhine-III] (rev 86)
root:# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:03:B3:00:66:DB 
          inet addr:75.94.15.38  Bcast:75.94.63.255  Mask:255.255.192.0
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:64102 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7315 errors:0 dropped:0 overruns:0 carrier:0
          collisions:104 txqueuelen:1000
          RX bytes:23190502 (22.1 MiB)  TX bytes:1436756 (1.3 MiB)
          Interrupt:11 Base address:0xd400

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

Title: Re: At long last!
Post by: newt on October 09, 2008, 09:07:31 am
perhaps it's just not up.  Does 'ifconfig eth1 up' bring it up?
Title: Re: At long last!
Post by: StrayBit on October 09, 2008, 09:45:08 am
root:# ifconfig eth1 up
eth1: ERROR while getting interface flags: No such device
Title: Re: At long last!
Post by: StrayBit on October 09, 2008, 09:47:20 am
and the card has power indicating it is hooked to the switch
Title: Re: At long last!
Post by: newt on October 09, 2008, 10:09:22 am
Is it possible that you made a typo when you adjusted the letters to lowercase?  Or maybe added an extra space somewhere it shouldn't be?

Can you post the output from: cat /etc/udev/rules.d/98-network-devices.rules ?
Title: Re: At long last!
Post by: StrayBit on October 09, 2008, 10:34:33 am
KERNEL=="eth?", SYSFS{address}=="00:03:b3:00:66:db", NAME="eth0"
KERNEL=="eth?", SYSFS{address}=="00:21:91:21:cf:ab", NAME="eth1"
Title: Re: At long last!
Post by: newt on October 09, 2008, 12:02:47 pm
I wanted to test this process myself so I added another ethernet device to my system and perform the udev rules to make them switch places.  It worked as expected; what was once eth0 became eth1 and vice-versa.

This leads me to believe that perhaps some of your previous changes (maybe via VASM) changed _something_ that's causing this udev/rules method to not work quite as expected.  My suggestion is to (if possible) undo changes you've made in the past, excluding the udev rules that you just made and whatever changes you made to make your internet work (leave those couple changes as-is).  Any changes in vasm, any configuration file changes, hosts changes, etc - undo those and reboot.

The other opton is to hope someone else reads this thread with clear vision that can see exactly where you need to go in order to get both devices working effectively.

I can assure you that once you get both devices working correctly you won't be needing to monkey with them anymore - in fact, over time, you'll forget all the necessary steps to get them working correctly ;D.  So.... once you get it figured out be sure to write down the necessary steps.

Cheers!
Title: Re: At long last!
Post by: StrayBit on October 09, 2008, 02:12:42 pm
I appreciate you working with me on this,  As I said in my first post, I've been trying for over ten years to get Linux going.  On this machine, it even powers off on shut-down.  The old windows just rebooted!

What I'll do is save the udev rules file, and reinstall the whole system again.  That way, I don't have to ask how to change the browser .  I tried Seamonkey the first time and tried Opera this time.  Seamonkey works better for me.  Just wish I could figure out how to have the NumLock on when Linux starts.
Title: Re: At long last!
Post by: StrayBit on October 09, 2008, 04:18:33 pm
VL5.9 has been reinstalled.  /etc/udev/rules.d/98-network-devices.rules has been restored.  eth0 with DHCP now connects to the internet but I cannot get eth1 set to static 192.168.0.1 using vasm from terminal, when I try to ping 192.168.0.1, the return is
   "PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.
     From 209.63.202.53 icmp_seq=1 Destination Host Unreachable"
the same result with ping 192.168.0.2 (the other machine on the local net).
netstat -i returns:
  "Kernel Interface table
    Iface   MTU Met   RX-OK RX-ERR RX-DRP RX-OVR    TX-OK TX-ERR TX-DRP TX-OVR Flg
    eth0   1500 0     14975      0      0      0      981      0      0      0 BMNRU
    lo    16436 0         2      0      0      0        2      0      0      0 LRU"
Should I start SAMBA (the other machine is Win2000)?  Or, am I missing another step?
Title: Re: At long last!
Post by: newt on October 09, 2008, 05:34:07 pm
I assume that both ethernet devices are showing correctly with ifconfig, correct?  If so, and eth0 is behaving properly then I _think_ the next step is to set up a persistent route for eth1 to handle all local network connections.  In other words, route all local network connections (192.168.0.x) to the router which will handle appropriate routing from there.  This should be able to be done via the 'route' command.  I've never had to use this command so I'm basing the syntax on the help file.  You should issue 'route' as a command to view the routing table before you start.

Example)
route add -net 192.168.0.0 netmask 255.255.255.0 dev eth1

To me, this translates as:
Add a rule to the system to route all local network (192.168.0.x) connections through device eth1.

But, again, I've never needed to use this command and cannot guarantee that it will work.  If your router does not use DHCP then you will need to set a static IP for eth1, however if your router used DHCP then you can set eth1 up like you did eth0.

edit:
I also want to comment on your not being able to set eth1 to 192.168.0.1.  Generally the first IP address in a local network is assigned to the router.  So, perhaps, if you're trying to set eth1 to 192.168.0.1 you're running into trouble because that IP address is already on the network (i.e. 192.168.0.1 is probably your router).  Of course, your network can be as customized as you want so this may not be the case.
Title: Re: At long last!
Post by: StrayBit on October 09, 2008, 07:50:20 pm
Eureka!  I'm not quite sure what I did.  But I can now ping 192.168.0.2 through eth1 AND get on the internet through eth0.

I ran the command that you gave and recieved "Network not running" or something like that. (The notes that I was keeping did NOT get saved before the crash!)  After trying some other commands, I tried switch the cables between the modem and the switch.  The result was that neither the mouse nor the keyboard would work!  I wound up hitting the reset button!!! :-{  Booted into TUI changed the settings in vasm and was able to ping nt2k (the win2000 machine).  Unfortunately, eth1 (now to the modem) wouldn't show up in vasm (although it did in ifdonfig and lspci).

Shut down the machine, switched the cables back where they belonged, booted to TUI to change the settings, startx, restored /etc/hosts, was able to get on the internet AND
root:# ping -c 3 -I eth1 192.168.0.2
PING 192.168.0.2 (192.168.0.2) from 192.168.0.1 eth1: 56(84) bytes of data.
64 bytes from 192.168.0.2: icmp_seq=1 ttl=128 time=0.434 ms
64 bytes from 192.168.0.2: icmp_seq=2 ttl=128 time=0.265 ms
64 bytes from 192.168.0.2: icmp_seq=3 ttl=128 time=0.271 ms

--- 192.168.0.2 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 1999ms

In regard to your comment, and I regret that I lost my notes as I had described my network in it.  Try again

router vector  10/100 switch  workstations
         []---------[]-------------[]
         |            \------------[]
modem    []

The switch doesn't do anything with the ip address.  This machine will be the router as soon as I get SAMBA running so that the workstations (Linux|Windows) can use shared data space, printer, and internet.  The workstations are currently Win95 - Win2000 but I'll start switching the newer ones to Linux.  I think I'm stuck with Win95 on the older ones as there isn't enough ram and they're not upgradable.

Now to figure out how to get the NumLock to stay on!

A big thank you to the whole team, not only helping me with this new operating system, guiding me while I learned some of the commands (big difference from DOS), your EXTREME patience, and keeping me motivated to "keep on keeping on!"

I have been looking at several distributions, always favoring Slackware, got a few to install, or run as the case may be.  I was attempting to download Slack 12 when I found VL4 Live better suited to my 18 years of Windows and 5.9 fits even better!

We can mark this case closed and I thank you all again.
Title: Re: At long last!
Post by: StrayBit on October 10, 2008, 08:20:24 am
PS:  I did have one anomaly that I have corrected.  I turned off the pc last night after posting the preceding.  When I turned it on this morning, it failed to get the IP address from the DHCP.  I found the solution in VASM by removing Link1 and Link2 (Static and DHCP) the adding the DHCP connection first then the static one.  All is well.