The nuts and bolts => Hardware & Drivers => Topic started by: jklslvch on October 31, 2008, 03:09:41 pm

Title: arris touchstone cable modem not working (SOLVED!!! yippeeeee)
Post by: jklslvch on October 31, 2008, 03:09:41 pm
hey i cant get my arris touchstone to connect to the internet i already tried: 

modprobe cdc_ether
modprobe usbnet
modprobe rndis_host

rndis_host didnt work though.... In gentoo after doing this it would recognize the hardware (ifconfig eth0 up) let me connect to the internet could someone help me out
Title: Re: arris touchstone cable modem not working
Post by: bigpaws on October 31, 2008, 08:41:36 pm
Please include more information.

After Googling this device, it is a cable modem. Do you
need to do some type of authentication? If so what protocol?

What Vector version?

Your mention of ifconfig up has nothing to do with the cable modem.

What is the make and model of your NIC card? Have you checked ifconfig
to see if the ethernet card is up and getting an address? Have you checked
lsmod to see if your NIC card module is loaded?

After these are answered then an answer would be possible.

Title: Re: arris touchstone cable modem not working
Post by: jklslvch on October 31, 2008, 10:06:50 pm
ok this is gonna take a lil but what i do know...

vector linux soho 5.9
ifconfig doesnt bring up any devices
authentication? what exactly does this mean... user+ password?.. if so no, usually just fire up a distro and it works

im gona need some help answering the rest....

kinfocenter> usb devices:


Manufacturer: ARRIS RNDIS Adapter

USB Version

Vendor ID
(Arris Interactive LLC)
Product ID

12 Mbit/s
Max. Packet Size


kinfocenter> network interfaces
it only has "lo"


root:# lsmod
Module                  Size  Used by
apm                    19036  2
freq_table              4640  0
snd_seq_midi            7072  0
snd_opl3_synth         12548  0
snd_seq_midi_emul       6784  1 snd_opl3_synth
snd_seq_dummy           3588  0
snd_seq_oss            29824  0
snd_seq_midi_event      7040  2 snd_seq_midi,snd_seq_oss
snd_seq                47856  8 snd_seq_midi,snd_opl3_synth,snd_seq_midi_emul,snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_pcm_oss            37920  0
snd_mixer_oss          14720  1 snd_pcm_oss
fuse                   42780  4
snd_cmipci             32256  0
nvidia               3925608  12
gameport               11404  1 snd_cmipci
snd_pcm                67204  2 snd_pcm_oss,snd_cmipci
snd_page_alloc          8456  1 snd_pcm
snd_opl3_lib           10112  2 snd_opl3_synth,snd_cmipci
snd_timer              20104  3 snd_seq,snd_pcm,snd_opl3_lib
snd_hwdep               7556  1 snd_opl3_lib
snd_mpu401_uart         7424  1 snd_cmipci
snd_rawmidi            19744  2 snd_seq_midi,snd_mpu401_uart
snd_seq_device          7180  7 snd_seq_midi,snd_opl3_synth,snd_seq_dummy,snd_seq_oss,snd_seq,snd_opl3_lib,snd_rawmidi
snd                    44708  13 snd_opl3_synth,snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_cmipci,snd_pcm,snd_opl3_lib,snd_timer,snd_hwdep,snd_mpu401_uart,snd_rawmidi,snd_seq_device
i2c_piix4               8588  0
serio_raw               6020  0
shpchp                 29972  0
soundcore               6880  1 snd
i2c_core               19860  1 i2c_piix4
pci_hotplug            27044  1 shpchp
intel_agp              23868  1
pata_acpi               5504  0
agpgart                28232  2 nvidia,intel_agp
evdev                   9728  0


root:# ifconfig
lo        Link encap:Local Loopback
          inet addr:  Mask:
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:72 errors:0 dropped:0 overruns:0 frame:0
          TX packets:72 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:6396 (6.2 KiB)  TX bytes:6396 (6.2 KiB)


root:# dmesg
Linux version ( (gcc version 4.1.2) #1 SMP PREEMPT Tue Jun 17 22:41:50 MDT 2008
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009f800 (usable)
 BIOS-e820: 000000000009f800 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000e7000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 00000000040fd800 (usable)
 BIOS-e820: 00000000040fd800 - 00000000040ff800 (ACPI data)
 BIOS-e820: 00000000040ff800 - 00000000040ffc00 (ACPI NVS)
 BIOS-e820: 00000000040ffc00 - 0000000018000000 (usable)
 BIOS-e820: 00000000fffe7000 - 0000000100000000 (reserved)
0MB HIGHMEM available.
384MB LOWMEM available.
Scan SMP from c0000000 for 1024 bytes.
Scan SMP from c009fc00 for 1024 bytes.
Scan SMP from c00f0000 for 65536 bytes.
Scan SMP from c009f800 for 1024 bytes.
Entering add_active_range(0, 0, 98304) 0 entries of 256 used
Zone PFN ranges:
  DMA             0 ->     4096
  Normal       4096 ->    98304
  HighMem     98304 ->    98304
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
    0:        0 ->    98304
On node 0 totalpages: 98304
  DMA zone: 32 pages used for memmap
  DMA zone: 0 pages reserved
  DMA zone: 4064 pages, LIFO batch:0
  Normal zone: 736 pages used for memmap
  Normal zone: 93472 pages, LIFO batch:31
  HighMem zone: 0 pages used for memmap
  Movable zone: 0 pages used for memmap
DMI 2.1 present.
Allocating PCI resources starting at 20000000 (gap: 18000000:e7fe7000)
PM: Registered nosave memory: 000000000009f000 - 00000000000a0000
PM: Registered nosave memory: 00000000000a0000 - 00000000000e7000
PM: Registered nosave memory: 00000000000e7000 - 0000000000100000
PM: Registered nosave memory: 00000000040fd000 - 00000000040fe000
PM: Registered nosave memory: 00000000040fe000 - 00000000040ff000
PM: Registered nosave memory: 00000000040ff000 - 0000000004100000
PM: Registered nosave memory: 00000000040ff000 - 0000000004100000
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 97536
Kernel command line: BOOT_IMAGE=Vectorlinux ro root=1646 splash=silent acpi=off
bootsplash: silent mode.
Local APIC disabled by BIOS -- you can enable it with "lapic"
mapped APIC to ffffb000 (0130c000)
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Initializing CPU#0
PID hash table entries: 2048 (order: 11, 8192 bytes)
Detected 597.416 MHz processor.
Console: colour dummy device 80x25
console [tty0] enabled
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Memory: 379292k/393216k available (5431k kernel code, 13344k reserved, 2404k data, 408k init, 0k highmem)
virtual kernel memory layout:
    fixmap  : 0xfff4c000 - 0xfffff000   ( 716 kB)
    pkmap   : 0xff800000 - 0xffc00000   (4096 kB)
    vmalloc : 0xd8800000 - 0xff7fe000   ( 623 MB)
    lowmem  : 0xc0000000 - 0xd8000000   ( 384 MB)
      .init : 0xc08af000 - 0xc0915000   ( 408 kB)
      .data : 0xc064dd38 - 0xc08a6fa0   (2404 kB)
      .text : 0xc0100000 - 0xc064dd38   (5431 kB)
Checking if this processor honours the WP bit even in supervisor mode...Ok.
CPA: page pool initialized 1 of 1 pages preallocated
Calibrating delay using timer specific routine.. 1195.56 BogoMIPS (lpj=597783)
Security Framework initialized
Capability LSM initialized
Mount-cache hash table entries: 512
CPU: L1 I cache: 16K, L1 D cache: 16K
CPU: L2 cache: 512K
CPU serial number disabled.
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
Compat vDSO mapped to ffffe000.
Checking 'hlt' instruction... OK.
SMP alternatives: switching to UP code
Freeing SMP alternatives: 18k freed
CPU0: Intel Pentium III (Katmai) stepping 03
SMP motherboard not detected.
Local APIC not detected. Using dummy APIC emulation.
Brought up 1 CPUs
net_namespace: 448 bytes
xor: automatically using best checksumming function: pIII_sse
   pIII_sse  :  1168.000 MB/sec
xor: using function: pIII_sse (1168.000 MB/sec)
NET: Registered protocol family 16
ACPI Exception (utmutex-0263): AE_BAD_PARAMETER, Thread D7C21630 could not acquire Mutex [1] [20070126]
No dock devices found.
PCI: PCI BIOS revision 2.10 entry at 0xfd983, last bus=1
PCI: Using configuration type 1
Setting up standard PCI resources
ACPI: Interpreter disabled.
Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI: disabled
SCSI subsystem initialized
libata version 3.00 loaded.
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
PCI: Probing PCI hardware
PCI: Probing PCI hardware (bus 00)
* Found PM-Timer Bug on the chipset. Due to workarounds for a bug,
* this clock source is slow. Consider trying other clock sources
pci 0000:00:07.3: quirk: region 8000-803f claimed by PIIX4 ACPI
pci 0000:00:07.3: quirk: region 7000-700f claimed by PIIX4 SMB
PCI: Using IRQ router PIIX/ICH [8086/7110] at 0000:00:07.0
PCI: Failed to allocate mem resource #6:10000@f8000000 for 0000:01:00.0
PCI: Bridge: 0000:00:01.0
  IO window: disabled.
  MEM window: 0xf4000000-0xf4ffffff
  PREFETCH window: 0x00000000f6000000-0x00000000f7ffffff
NET: Registered protocol family 2
IP route cache hash table entries: 4096 (order: 2, 16384 bytes)
TCP established hash table entries: 16384 (order: 5, 131072 bytes)
TCP bind hash table entries: 16384 (order: 5, 131072 bytes)
TCP: Hash tables configured (established 16384 bind 16384)
TCP reno registered
checking if image is isn't (bad gzip magic numbers); looks like an initrd
Freeing initrd memory: 1144k freed
scx200: NatSemi SCx200 Driver
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
NTFS driver 2.1.29 [Flags: R/W].
JFS: nTxBlock = 2973, nTxLock = 23789
SGI XFS with ACLs, security attributes, realtime, no debug enabled
SGI XFS Quota Management subsystem
async_tx: api initialized (async)
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered (default)
pci 0000:00:00.0: Limiting direct PCI/PCI transfers
pci 0000:01:00.0: Boot video device
vesafb: framebuffer at 0xf6000000, mapped to 0xd8a00000, using 4096k, total 4096k
vesafb: mode is 1280x1024x16, linelength=2560, pages=0
vesafb: protected mode interface info at c000:02e5
vesafb: pmi: set display start = c00c031e, set palette = c00c0394
vesafb: pmi: ports = 3b4 3b5 3ba 3c0 3c1 3c4 3c5 3c6 3c7 3c8 3c9 3cc 3ce 3cf 3d0 3d1 3d2 3d3 3d4 3d5 3da
vesafb: scrolling: redraw
vesafb: Truecolor: size=0:5:6:5, shift=0:11:5:0
bootsplash 3.1.6-2004/03/31: looking for picture...<6> silentjpeg size 293943 bytes,<6> does not fit into framebuffer.
...found (1280x1024, 256191 bytes, v3).
Console: switching to colour frame buffer device 137x46
fb0: VESA VGA frame buffer device
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Real Time Clock Driver v1.12ac
Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
brd: module loaded
loop: module loaded
Compaq SMART2 Driver (v 2.6.0)
HP CISS Driver (v 3.6.20)
input: Macintosh mouse button emulation as /class/input/input0
Uniform Multi-Platform E-IDE driver
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
PIIX4: IDE controller (0x8086:0x7111 rev 0x01) at  PCI slot 0000:00:07.1
PIIX4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0x1000-0x1007, BIOS settings: hda:DMA, hdb:PIO
    ide1: BM-DMA at 0x1008-0x100f, BIOS settings: hdc:PIO, hdd:DMA
Probing IDE interface ide0...
hda: host max PIO4 wanted PIO255(auto-tune) selected PIO4
hda: MWDMA2 mode selected
Probing IDE interface ide1...
hdc: SAMSUNG SP0802N, ATA DISK drive
hdd: WDC WD400BB-00JKA0, ATA DISK drive
hdc: host max PIO4 wanted PIO255(auto-tune) selected PIO4
hdc: UDMA/33 mode selected
hdd: host max PIO4 wanted PIO255(auto-tune) selected PIO4
hdd: UDMA/33 mode selected
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hdc: max request size: 512KiB
hdc: 156368016 sectors (80060 MB) w/2048KiB Cache, CHS=16383/255/63
hdc: cache flushes supported
 hdc: hdc1 hdc2 < hdc5 >
hdd: max request size: 128KiB
hdd: 78165360 sectors (40020 MB) w/2048KiB Cache, CHS=65535/16/63
hdd: cache flushes supported
 hdd: hdd1 hdd2 < hdd5 hdd6 >
hda: ATAPI 40X DVD-ROM drive, 512kB Cache
Uniform CD-ROM driver Revision: 3.20
ide-floppy driver 1.00
Loading iSCSI transport class v2.0-869.
Loading Adaptec I2O RAID: Version 2.4 Build 5go
Detecting Adaptec I2O RAID controllers...
Adaptec aacraid driver 1.1-5[2455]-ms
aic94xx: Adaptec aic94xx SAS/SATA driver version 1.0.3 loaded
scsi: <fdomain> Detection failed (no card)
NCR53c406a: no available ports found
sym53c416.c: Version 1.0.0-ac
qlogicfas: no cards were found, please specify I/O address and IRQ using iobase= and irq= options<6>QLogic Fibre Channel HBA Driver
iscsi: registered transport (qla4xxx)
QLogic iSCSI HBA Driver
Emulex LightPulse Fibre Channel SCSI driver 8.2.5
Copyright(c) 2004-2008 Emulex.  All rights reserved.
Failed initialization of WD-7000 SCSI card!
Clocksource tsc unstable (delta = 553895180 ns)
DC390: clustering now enabled by default. If you get problems load
        with "disable_clustering=1" and report to maintainers
megaraid cmm: (Release Date: Sun Jul 16 00:01:03 EST 2006)
megaraid: (Release Date: Thu Nov 16 15:32:35 EST 2006)
megasas: Thu. Nov. 07 10:09:32 PDT 2007
GDT-HA: Storage RAID Controller Driver. Version: 3.05
GDT-HA: Found 0 PCI Storage RAID Controllers
3ware Storage Controller device driver for Linux v1.26.02.002.
3ware 9000 Storage Controller device driver for Linux v2.26.02.010.
nsp32: loading...
ipr: IBM Power RAID SCSI Device Driver version: 2.4.1 (April 24, 2007)
RocketRAID 3xxx/4xxx Controller driver v1.3 (071203)
stex: Promise SuperTrak EX Driver version: 3.6.0000.1
Driver 'sd' needs updating - please use bus_type methods
Driver 'sr' needs updating - please use bus_type methods
Intel ISA PCIC probe: not found.
Databook TCIC-2 PCMCIA probe: not found.
usbmon: debugfs is not available
116x: driver isp116x-hcd, 03 Nov 2005
ohci_hcd: 2006 August 04 USB 1.1 'Open' Host Controller (OHCI) Driver
USB Universal Host Controller Interface driver v3.0
PCI: setting IRQ 9 as level-triggered
PCI: Found IRQ 9 for device 0000:00:07.2
uhci_hcd 0000:00:07.2: UHCI Host Controller
uhci_hcd 0000:00:07.2: new USB bus registered, assigned bus number 1
uhci_hcd 0000:00:07.2: irq 9, io base 0x00001020
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
sl811: driver sl811-hcd, 19 May 2005
Initializing USB Mass Storage driver...
usb 1-2: new full speed USB device using uhci_hcd and address 2
usb 1-2: no configuration chosen from 1 choice
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usbcore: registered new interface driver libusual
PNP: No PS/2 controller found. Probing ports directly.
serio: i8042 KBD port at 0x60,0x64 irq 1
serio: i8042 AUX port at 0x60,0x64 irq 12
mice: PS/2 mouse device common for all mice
input: AT Translated Set 2 keyboard as /class/input/input1
md: linear personality registered for level -1
md: raid0 personality registered for level 0
md: raid1 personality registered for level 1
md: raid10 personality registered for level 10
raid6: int32x1    132 MB/s
raid6: int32x2    117 MB/s
raid6: int32x4    140 MB/s
raid6: int32x8    140 MB/s
raid6: mmxx1      320 MB/s
raid6: mmxx2      386 MB/s
raid6: sse1x1      97 MB/s
raid6: sse1x2     277 MB/s
raid6: using algorithm sse1x2 (277 MB/s)
md: raid6 personality registered for level 6
md: raid5 personality registered for level 5
md: raid4 personality registered for level 4
device-mapper: ioctl: 4.13.0-ioctl (2007-10-18) initialised:
cpuidle: using governor ladder
sdhci: Secure Digital Host Controller Interface driver
sdhci: Copyright(c) Pierre Ossman
wbsd: Winbond W83L51xD SD/MMC card interface driver
wbsd: Copyright(c) Pierre Ossman
usbcore: registered new interface driver hiddev
usbcore: registered new interface driver usbhid
drivers/hid/usbhid/hid-core.c: v2.6:USB HID core driver
TCP cubic registered
Initializing XFRM netlink socket
NET: Registered protocol family 1
NET: Registered protocol family 17
Using IPI No-Shortcut mode
input: ImPS/2 Generic Wheel Mouse as /class/input/input2
md: Autodetecting RAID arrays.
md: Scanned 0 and added 0 devices.
md: autorun ...
md: ... autorun DONE.
RAMDISK: Couldn't find valid RAM disk image starting at 0.
XFS mounting filesystem hdd6
Ending clean XFS mount for filesystem: hdd6
VFS: Mounted root (xfs filesystem) readonly.
Freeing unused kernel memory: 408k freed
Linux agpgart interface v0.103
agpgart: Detected an Intel 440BX Chipset.
agpgart: AGP aperture is 64M @ 0xf8000000
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
piix4_smbus 0000:00:07.3: Found 0000:00:07.3 device
nvidia: module license 'NVIDIA' taints kernel.
PCI: setting IRQ 11 as level-triggered
PCI: Found IRQ 11 for device 0000:01:00.0
NVRM: loading NVIDIA Linux x86 Kernel Module  71.86.04  Mon Jan 21 11:22:18 PST 2008
PCI: Enabling device 0000:00:11.0 (0104 -> 0105)
PCI: setting IRQ 5 as level-triggered
PCI: Found IRQ 5 for device 0000:00:11.0
Adding 522104k swap on /dev/hdd5.  Priority:-1 extents:1 across:522104k
fuse init (API version 7.9)
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16ac)
agpgart: Found an AGP 1.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V2 device at 0000:00:00.0 into 2x mode
agpgart: Putting AGP V2 device at 0000:01:00.0 into 2x mode
agpgart: Found an AGP 1.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V2 device at 0000:00:00.0 into 2x mode
agpgart: Putting AGP V2 device at 0000:01:00.0 into 2x mode
spurious 8259A interrupt: IRQ7.
Title: Re: arris touchstone cable modem not working
Post by: bigpaws on November 01, 2008, 11:30:08 am
So this is a USB device?

If so lspci sure won't show it, however lsusb should.
Please post the output of the above command.

Check in /boot for the kernel config file.

You need the following options in your kernel config:


If not you will need to compile a new kernel in order to use
the device.

Title: Re: arris touchstone cable modem not working
Post by: jklslvch on November 01, 2008, 01:12:03 pm
root:# lsusb
Bus 001 Device 002: ID 09c1:1337 Arris Interactive LLC
Bus 001 Device 001: ID 1d6b:0001
Bus 1 Device 2: ID 09c1:1337 Arris Interactive LLC
Bus 1 Device 1: ID 1d6b:0001


in "/boot/config-"


Does that mean I have to recompile the kernel because of RNDIS_HOST?
Title: Re: arris touchstone cable modem not working
Post by: bigpaws on November 01, 2008, 03:52:23 pm

Title: Re: arris touchstone cable modem not working
Post by: jklslvch on November 01, 2008, 06:34:36 pm
Mr. Paws I compiled the drivers from the default kernel in VL SOHO5.9.1 ( and modprobed rndis_host but it still doesn't pick it up with ifconfig... WTF?! Took me like 3 hrs.... anyway what now?? Try with the latest version of the kernel? And if so can I just compile the directory that has rndis_host.c or do i have to do the whooole kernel?
Title: Re: arris touchstone cable modem not working
Post by: bigpaws on November 01, 2008, 08:14:31 pm
I checked the knowledge base and here is the quote:

If your computer is running any Linux or Unix operating systems, you can access the Internet via the ethernet socket only. Please make sure to enable the proper hardware drivers, TCP/IP, and DHCP in your Linux or Unix kernel.

Is there a reason why you are not using the ethernet port?

Title: Re: arris touchstone cable modem not working
Post by: jklslvch on November 02, 2008, 09:08:43 am
Ive tried connecting the ethernet cable in Win Vista and in Linux Mint but neither would work in vista it wouldnt connect and in Mint well it wouldnt either....
Title: Re: arris touchstone cable modem not working
Post by: bigpaws on November 02, 2008, 10:30:37 am
From your lspci I do not see any ethernet devices.

The modem should be able to connect. it is really no
different than a router. I would believe that is why it is
mentioned to work only by using ethernet.

I have googled this modem for about 2 hours and have not
found anything really relevant. Perhaps the link for Gentoo
may help.

After looking at the kernel spots for rndis it appears to be more
for things like phones and PDA's.

Any information that you have will save more hours of trying to
get your hardware running.

Did the other kernel modules load? Being that you have not mentioned
wether they are showing up in lsmod.

For a kernel compile it will take awhile. My 1.2 Celeron takes about 1.5 hours
so your time sounds about right.

Title: Re: arris touchstone cable modem not working
Post by: jklslvch on November 02, 2008, 10:44:43 am
I forgot this computer doesnt have a network card i was thinking of my laptop  :P..... thats why i use the USB port.

Well I dont know im gonna try to recompile the latest kernel to see if  it supports the modem so ill post back in a day or 2 because this is a Pentium 3 600MHz but ill try to see if I can compile it on my laptop wich is an AMD athlon x2 1.8Ghz to save time

EDIT: Where does slackware well VL have the file to put extra modules to load on boot? because I only tried loading the modules with modprobe
Title: Re: arris touchstone cable modem not working
Post by: bigpaws on November 02, 2008, 01:08:39 pm
Try /etc/rc.d/rc.modules

Good Luck,

Title: Re: arris touchstone cable modem not working
Post by: rbistolfi on November 02, 2008, 03:26:01 pm
Looks like you need the cdc_ether, usbnet, and rndis_host. The VL kernel has the first two but rndis* modules are missing.
Should be relatively easy to install the sources of your kernel from and use the vectorlinux kernel config and add the rndis* module to it.

Good luck
Title: Re: arris touchstone cable modem not working
Post by: jklslvch on November 02, 2008, 09:17:17 pm
Well I recompiled the kernel and it took about 3 or 4 hours but it finally works... Besides not having the pretty bootscreen it looks like a slackware install, I only have one problem now... the NVIDIA drivers (legacy) arent working... Im using the nv drivers right now but when i try to compile the drivers it gives me an error....

EDIT: The main part in the kernel config that I changed  was under Device Drivers>Network device support>USB Network Adapters.........and well wasnt really sure but made sure all the suboptions in there were compiled into the kernel

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Sun Nov  2 23:40:49 2008

option status:
  license pre-accepted    : true
  update                  : false
  force update            : false
  expert                  : false
  uninstall               : false
  driver info             : false
  precompiled interfaces  : false
  no ncurses color        : false
  query latest version    : false
  OpenGL header files     : true
  no questions            : true
  silent                  : false
  no recursion            : false
  no backup               : false
  kernel module only      : false
  sanity                  : false
  add this kernel         : false
  no runlevel check       : true
  no network              : true
  no ABI note             : false
  no RPMs                 : true
  no kernel module        : false
  force SELinux           : default
  no X server check       : true
  force tls               : (not specified)
  X install prefix        : (not specified)
  X library install path  : (not specified)
  X module install path   : (not specified)
  OpenGL install prefix   : (not specified)
  OpenGL install libdir   : (not specified)
  utility install prefix  : (not specified)
  utility install libdir  : (not specified)
  doc install prefix      : (not specified)
  kernel name             : (not specified)
  kernel include path     : (not specified)
  kernel source path      : (not specified)
  kernel output path      : (not specified)
  kernel install path     : (not specified)
  proc mount point        : /proc
  ui                      : (not specified)
  tmpdir                  : /tmp
  ftp mirror              :
  RPM file list           : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted by command line option.
-> Skipping check for conflicting rpms.
-> There appears to already be a driver installed on your system (version: 71.8
   6.04).  As part of installing this driver (version: 71.86.04), the existing
   driver will be uninstalled.  Are you sure you want to continue? ('no' will a
   bort installation) (Answer: Yes)
-> Not probing for precompiled kernel interfaces.
-> Performing CC sanity check with CC="cc".
-> Performing CC version check with CC="cc".
-> Kernel source path: '/lib/modules/2.6.27/source'
-> Kernel output path: '/lib/modules/2.6.27/build'
-> Performing rivafb check.
-> Performing nvidiafb check.
-> Performing Xen check.
-> Cleaning kernel module build directory.
   executing: 'cd ./usr/src/nv; make clean'...
-> Building kernel module:
   executing: 'cd ./usr/src/nv; make module SYSSRC=/lib/modules/2.6.27/source S
   NVIDIA: calling KBUILD...
   make CC=cc KBUILD_OUTPUT=/lib/modules/2.6.27/build KBUILD_VERBOSE=1 -C /lib/
   modules/2.6.27/source SUBDIRS=/usr/src/vl-pkgs/NVIDIA-71.86.04/usr/src/nv mo
   make -C /lib/modules/2.6.27/build \
      KBUILD_SRC=/usr/src/linux-2.6.27 \
      KBUILD_EXTMOD="/usr/src/vl-pkgs/NVIDIA-71.86.04/usr/src/nv" -f /usr/src/lin
   ux-2.6.27/Makefile \
   test -e include/linux/autoconf.h -a -e include/config/auto.conf || (      \
      echo;                        \
      echo "  ERROR: Kernel configuration is invalid.";      \
      echo "         include/linux/autoconf.h or include/config/auto.conf are mis
   sing.";   \
      echo "         Run 'make oldconfig && make prepare' on kernel src to fix it
   .";   \
      echo;                        \
   mkdir -p /usr/src/vl-pkgs/NVIDIA-71.86.04/usr/src/nv/.tmp_versions ; rm -f /
   make -f /usr/src/linux-2.6.27/scripts/ obj=/usr/src/vl-pkgs/NV
     cc -Wp,-MD,/usr/src/vl-pkgs/NVIDIA-71.86.04/usr/src/nv/.nv.o.d  -nostdinc
   -isystem /usr/lib/gcc/i486-slackware-linux/4.1.2/include -D__KERNEL__ -Iincl
   ude -Iinclude2 -I/usr/src/linux-2.6.27/include -I/usr/src/linux-2.6.27/arch/
   x86/include -include include/linux/autoconf.h  -I/usr/src/vl-pkgs/NVIDIA-71.
   86.04/usr/src/nv -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-stric
   t-aliasing -fno-common -Werror-implicit-function-declaration -O2 -m32 -msoft
   -float -mregparm=3 -freg-struct-return -mpreferred-stack-boundary=2 -march=i
   686 -mtune=pentium3 -mtune=i686 -ffreestanding -DCONFIG_AS_CFI=1 -DCONFIG_AS
   _CFI_SIGNAL_FRAME=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables
   -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -I/usr/src/linux-2.6.27/include/asm-x
   86/mach-default -Iinclude/asm-x86/mach-default -fno-stack-protector -fomit-f
   rame-pointer -Wdeclaration-after-statement -Wno-pointer-sign  -I/usr/src/vl-
   pkgs/NVIDIA-71.86.04/usr/src/nv -Wall -Wimplicit -Wreturn-type -Wswitch -Wfo
   rmat -Wchar-subscripts -Wparentheses -Wpointer-arith -Wno-multichar -Werror
   -MD -Wsign-compare -Wno-cast-qual -Wno-error -
   _STR(nvidia)" -c -o /usr/src/vl-pkgs/NVIDIA-71.86.04/usr/src/nv/nv.o /usr/sr
   In file included from include/linux/bitops.h:17,
                    from include/linux/kernel.h:15,
                    from include/linux/sched.h:52,
                    from include/linux/utsname.h:35,
                    from /usr/src/vl-pkgs/NVIDIA-71.86.04/usr/src/nv/nv-linux.h
                    from /usr/src/vl-pkgs/NVIDIA-71.86.04/usr/src/nv/nv.c:14:
   include/asm/bitops.h: In function 'set_bit':
   include/asm/bitops.h:60: warning: pointer of type 'void *' used in arithmeti
   include/asm/bitops.h: In function 'clear_bit':
   include/asm/bitops.h:97: warning: pointer of type 'void *' used in arithmeti
   In file included from include/linux/list.h:6,
                    from include/linux/preempt.h:11,
                    from include/linux/spinlock.h:50,
                    from include/linux/seqlock.h:29,
                    from include/linux/time.h:8,
                    from include/linux/timex.h:57,
                    from include/linux/sched.h:54,
                    from include/linux/utsname.h:35,
                    from /usr/src/vl-pkgs/NVIDIA-71.86.04/usr/src/nv/nv-linux.h
                    from /usr/src/vl-pkgs/NVIDIA-71.86.04/usr/src/nv/nv.c:14:
   include/linux/prefetch.h: In function 'prefetch_range':
   include/linux/prefetch.h:57: warning: pointer of type 'void *' used in arith
   In file included from include/linux/utsname.h:35,
                    from /usr/src/vl-pkgs/NVIDIA-71.86.04/usr/src/nv/nv-linux.h
                    from /usr/src/vl-pkgs/NVIDIA-71.86.04/usr/src/nv/nv.c:14:
   include/linux/sched.h: In function 'object_is_on_stack':
   include/linux/sched.h:1969: warning: pointer of type 'void *' used in arithm
   In file included from include/asm/dma-mapping.h:9,
                    from include/linux/dma-mapping.h:52,
                    from include/asm-generic/pci-dma-compat.h:7,
                    from include/asm/pci.h:94,
                    from include/linux/pci.h:983,
                    from /usr/src/vl-pkgs/NVIDIA-71.86.04/usr/src/nv/nv-linux.h
                    from /usr/src/vl-pkgs/NVIDIA-71.86.04/usr/src/nv/nv.c:14:
   include/linux/scatterlist.h: In function 'sg_virt':
   include/linux/scatterlist.h:199: warning: pointer of type 'void *' used in a
   In file included from /usr/src/vl-pkgs/NVIDIA-71.86.04/usr/src/nv/nv.c:14:
   /usr/src/vl-pkgs/NVIDIA-71.86.04/usr/src/nv/nv-linux.h:104:27: error: asm/se
   maphore.h: No such file or directory
   In file included from /usr/src/vl-pkgs/NVIDIA-71.86.04/usr/src/nv/nv-linux.h
                    from /usr/src/vl-pkgs/NVIDIA-71.86.04/usr/src/nv/nv.c:14:
   include/linux/highmem.h: In function 'zero_user_segments':
   include/linux/highmem.h:134: warning: pointer of type 'void *' used in arith
   include/linux/highmem.h:134: warning: pointer of type 'void *' used in arith
   include/linux/highmem.h:134: warning: pointer of type 'void *' used in arith
   include/linux/highmem.h:134: warning: pointer of type 'void *' used in arith
   include/linux/highmem.h:137: warning: pointer of type 'void *' used in arith
   include/linux/highmem.h:137: warning: pointer of type 'void *' used in arith
   include/linux/highmem.h:137: warning: pointer of type 'void *' used in arith
   include/linux/highmem.h:137: warning: pointer of type 'void *' used in arith
   /usr/src/vl-pkgs/NVIDIA-71.86.04/usr/src/nv/nv.c: In function 'nvos_proc_cre
   /usr/src/vl-pkgs/NVIDIA-71.86.04/usr/src/nv/nv.c:562: error: 'proc_root_driv
   er' undeclared (first use in this function)
   /usr/src/vl-pkgs/NVIDIA-71.86.04/usr/src/nv/nv.c:562: error: (Each undeclare
   d identifier is reported only once
   /usr/src/vl-pkgs/NVIDIA-71.86.04/usr/src/nv/nv.c:562: error: for each functi
   on it appears in.)
   /usr/src/vl-pkgs/NVIDIA-71.86.04/usr/src/nv/nv.c: In function 'nv_kern_vma_n
   /usr/src/vl-pkgs/NVIDIA-71.86.04/usr/src/nv/nv.c:1736: error: 'NOPAGE_SIGBUS
   ' undeclared (first use in this function)
   /usr/src/vl-pkgs/NVIDIA-71.86.04/usr/src/nv/nv.c: At top level:
   /usr/src/vl-pkgs/NVIDIA-71.86.04/usr/src/nv/nv.c:1743: error: unknown field
   'nopage' specified in initializer
   /usr/src/vl-pkgs/NVIDIA-71.86.04/usr/src/nv/nv.c:1743: warning: initializati
   on from incompatible pointer type
   make[4]: *** [/usr/src/vl-pkgs/NVIDIA-71.86.04/usr/src/nv/nv.o] Error 1
   make[3]: *** [_module_/usr/src/vl-pkgs/NVIDIA-71.86.04/usr/src/nv] Error 2
   make[2]: *** [sub-make] Error 2
   nvidia.ko failed to build!
   make[1]: *** [module] Error 1
   make: *** [module] Error 2
-> Error.
ERROR: Unable to build the NVIDIA kernel module.
ERROR: Installation has failed.  Please see the file
       '/var/log/nvidia-installer.log' for details.  You may find suggestions
       on fixing installation problems in the README available on the Linux
       driver download page at

I know this isn't part of the subject but if you guys cant help me out where on the forums should I ask?