VectorLinux

Cooking up the Treats => New Package Requests => Topic started by: Andy Price on January 29, 2009, 01:21:54 am

Title: Midori web browser
Post by: Andy Price on January 29, 2009, 01:21:54 am
Any chance of an update to the Midori web browser? The latest version on their web site is 0.012 whereas the one in the reps is 0.0.18. It seems like development is continuing and this is a very fast little browser which shows a lot of promise. It opens in a second or so and renders pages very well.

Thanks
Andy
Title: Re: Midori web browser
Post by: tomh38 on January 30, 2009, 09:52:52 am
I would like to see the newest Midori also.  It looks very promising.  I've been trying to compile it myself, but I keep getting errors having to do with not having the latest WebKit.  A package for 6.0 would be fine; I have it installed but I'm not using it right now.

Thanks,
Tom
Title: Re: Midori web browser
Post by: caitlyn on January 30, 2009, 11:34:04 am
I'm going to package it for VL 6.0.  I don't have a 5.9.x box so I can't do a package for that series of VL releases.
Title: Re: Midori web browser
Post by: Andy Price on January 31, 2009, 07:14:37 am
Thanks Caitlyn, that'll be one more small reason for me to upgrade when the final release comes out, though right now I'm pretty happy with 5.9 Gold...
Title: Re: Midori web browser
Post by: tomh38 on January 31, 2009, 11:03:17 am
Thanks Caitlyn, as always.

Tom
Title: Re: Midori web browser
Post by: caitlyn on February 02, 2009, 02:37:36 pm
Well... this is one package I won't be able to do.  Midori depends on WebKit.  I successfully built all the dependencies but the compilation failed on WebKit itself, r40471.  It's a Java error and I have no Java expertise.  In addition, the WebKit code is simply huge (>300MB) and I don't have either the time or the inclination to try and figure this one out.

Sorry, folks.