VectorLinux

The nuts and bolts => Installation & Updates => Topic started by: StrayBit on January 30, 2009, 09:53:06 pm

Title: [Solved]Getting mouse wheel to work
Post by: StrayBit on January 30, 2009, 09:53:06 pm
I've installed VL5.9 several times and usually the wheel works.  The last two installations, however, it didn't.  I had read in the forum sometime ago about switching mouse0 and mouse1.  Then, I didn't need it.  Now that I do, I can't.  And the only thing I found on my search in the forum referred to x???.conf which didn't define mouse0 and mouse1 but did have a setting which I changed from mouse1 to mouse0 - it didn't help!

Could someone please advise me of the file I'm looking for.  (I miss not being able to search for files containing some text.)
Title: Re: Getting mouse wheel to work
Post by: bigpaws on January 31, 2009, 07:07:52 am
cat /etc/X11/xorg.conf | grep mouse

The output should be:

 Option         "Device" "/dev/input/mice"

Change to the above line see if that helps.

For scrolling you will also need to add:

Option ZAxisMapping  "4 5"

add below the mouse lines.

HTH

Bigpaws
Title: Re: Getting mouse wheel to work
Post by: Windozer on January 31, 2009, 08:12:50 am
Quote
cat /etc/X11/xorg.conf | grep mouse

 /etc/X11/xorg.conf | grep mice

 ;D

- H
Title: Re: Getting mouse wheel to work
Post by: StrayBit on January 31, 2009, 08:34:52 am
Thanks Windoze. I found it before I read your post.

I made the following change
Code: [Select]
#    Option "Device"      "/dev/mouse"
Option         "Device" "/dev/input/mice"
#For scrolling you will also need to add:
#Option ZAxisMapping  "4 5"
Logging out made no difference.  Restarting, x refused to start until I commented out the ZAxisMapping option.  The error pointed to "4 5" saying something about 1 or 2 quotes were need and it was an invalid keyword.  Wished I could have copy/paste in tui!

I still don't have wheel.

I did verify that I had "/dev/input/mice" before I made the change.
Title: Re: Getting mouse wheel to work
Post by: Sengir on January 31, 2009, 10:01:40 am
IIRC ZAxisMapping needs quotes as well, so that might be the problem


Mine reads:
Code: [Select]
Option      "ZAxisMapping" "4 5"
Title: Re: Getting mouse wheel to work
Post by: StrayBit on January 31, 2009, 10:39:02 am
Thanks Sengir.  I just looked on my other VL5.9 installation and it does have it quoted as you say.. 

Unfortunately, I'm in the process of removing and reinstalling VL5.9 on the offending machine as it had way too many problems,  Once I get it working, I'll try 6.0-RC4 again,
Title: Re: Getting mouse wheel to work
Post by: StrayBit on January 31, 2009, 01:41:16 pm
New install solved this issue.  Thanks for your help.

But how do I mark this Solved?
Title: Re: Getting mouse wheel to work
Post by: caitlyn on January 31, 2009, 02:16:24 pm
Go into this thread again.  If you look at your original post which started this thread you'll see that it has a Modify icon.  Click that and you can make the changes.

FYI:  only the original poster and the moderator(s) for a given section of the forum can modify a post.
Title: Re: [Solved]Getting mouse wheel to work
Post by: StrayBit on January 31, 2009, 04:53:32 pm
Thanks, Caitlyn.

I thought there was some way but I sure couldn't find it.  And I had already guessed that the "owner" or "Root" could modify it.  Hey! I think some of this Linux stuff is rubbing off on me  ;D