VectorLinux

The nuts and bolts => Software General => Topic started by: wahfun on February 02, 2009, 09:59:09 am

Title: No Audio CD sound - VLRC4
Post by: wahfun on February 02, 2009, 09:59:09 am
 DVD video plays fine with sound. I get no sound from a Music CD however. Xmms sees the cd and looks as though it is playing but there is no sound. This seems strange to me since the video sound works, but I am a linux noob.

System info: Running VL6 RC4 in latest version of Virtualbox on an xp machine (AMD dual core running at 2Mhz; 2 GB ram (960 mb allocated to VL))
Audio Controller: Intel 82801AA AC'97

Steps taken so far: re-installed VL6

Your help would be appreciated.

Thx
Title: Re: No Audio CD sound - VLRC4
Post by: bigpaws on February 02, 2009, 10:33:03 am
Did you enable sound in Virtualbox?

Select the particular VM in the VirtualBox window, hit Settings, then go
to the Audio section. Check off "Enable Audio," and select ALSA Audio
Driver from the dropdown box.

See if that helps.

Bigpaws
Title: Re: No Audio CD sound - VLRC4
Post by: Joe1962 on February 02, 2009, 11:17:14 am
It's running on XP, no ALSA there, I think... ;)  Also, does Virtualbox support audio CD play?
Title: Re: No Audio CD sound - VLRC4
Post by: GrannyGeek on February 02, 2009, 04:24:25 pm
From my limited experience with virtual machines, I'd say you need to find out what sound card VirtualBox emulates. It is probably not the same as the "real" sound card or chip. Then you need to make sure that VL in the virtual machine installs the Alsa driver for the VB emulated sound (which looks to the OS in the container [virtual machine] like the real sound chip).

I don't know if this will work, though.
--GrannyGeek
Title: Re: No Audio CD sound - VLRC4
Post by: stretchedthin on February 02, 2009, 04:36:44 pm
Try this...
launch xmms,  the letters 0AIDV run vertically along the left hand side. Click on the 'O' this will open a menu click preferences.
Click Cd Audio Player ~
Click Configure
Under Playmode select the digital audio extraction checkbox. Click OK on that window, OK on the prefereces window.  Shut down xmms. Put your cd back in and see if you get a different result.
Ken
Title: Re: No Audio CD sound - VLRC4
Post by: GeneralError324 on February 03, 2009, 05:51:08 pm
I had the same issue(Not in a virtual machine), Your solution worked perfectly for me,

Thanks!
Title: Re: No Audio CD sound - VLRC4
Post by: Windozer on February 04, 2009, 04:12:50 pm
It's running on XP, no ALSA there, I think... ;)  Also, does Virtualbox support audio CD play?

Yes ... Virtual Box wrappers everything - so the ALSA driver --- and any driver for that matter --- thinks it's running on Linux.  A tad off thread here: Although it seems like a mental excercise, you can do some pretty strange and interesting things with V.box. I've had two versions of VL running at the same time on one XP machine in V.Box --- all talking to each other via V.box ethernet "TAP adapters."  Samba on one, NIS on the other, and SMB on the XP box ... they all thought they were different machines.

Great way to test new and network stuff, if the machine has enough mem. I even do this on my laptop!

cheers.

And if you can't get enough of VL, I say, why not run two or more at once?!  ;D ;D

cheers
- Howard
~~~~~~
Title: Re: No Audio CD sound - VLRC4
Post by: Joe1962 on February 05, 2009, 12:22:56 pm
It's running on XP, no ALSA there, I think... ;)  Also, does Virtualbox support audio CD play?
Yes ... Virtual Box wrappers everything - so the ALSA driver --- and any driver for that matter --- thinks it's running on Linux.

Not sure what you mean here, the Linux guest thinks it's running on pure hardware, of course, so it will use alsa, etc, but the vmware app itself runs on Windows in this case, so I don't think it will show alsa as a Host audio driver option to use for itself. I may be be wrong, since I haven't actually run it on Windows, just applying a little logic here.
Title: Re: No Audio CD sound - VLRC4
Post by: Windozer on February 05, 2009, 06:34:51 pm
Quote
[...] but the vmware app itself runs on Windows in this case, so I don't think it will show alsa as a Host audio driver option to use for itself. [...]

Joe, maybe I've misunderstood your earlier post - right, the guest thinks it has the hardware to itself. Virtual Box, to my knowledge, doesn't directly present an output to itself - you need a guest OS to get at the card through the VM.

Oh, well, if we are still confusing each other here, (and it's likely my fault, not yours :-[) then shall we just move on  to bigger and better problems? ???  ;D

cheers
- Howard
Title: Re: No Audio CD sound - VLRC4
Post by: GrannyGeek on February 05, 2009, 07:39:33 pm
When I've used virtual machines, they emulate or virtualize one or two common sound cards. To the guest OS, the virtual machine's emulated sound card looks like an *actual* sound card. So the guest OS uses a driver for the emulated sound card, not the actual hardware on the real computer. As far as the guest OS is concerned, the virtual hardware IS the actual hardware. The virtual machine software takes care of translating between the virtual sound card in the virtual machine and the actual sound card in the physical computer. The Alsa driver in the guest OS should be the one for the virtualized sound card, not the sound used by the host OS.

Maybe we're all saying the same thing.
--GrannyGeek
Title: Re: No Audio CD sound - VLRC4
Post by: Joe1962 on February 06, 2009, 06:09:26 am
LOL, let's see if I can clear this up a bit... ;D  On Linux, you need to configure each vm to tell VB which real Host audio interface to use: Null Audio, OSS, ALSA, or PulseAudio, on my VL6. Maybe on Windows, there is no choice at all, though I can imagine at least a few possible choices: Null Audio, DirectX audio, and whatever is considered default.
Title: Re: No Audio CD sound - VLRC4
Post by: Windozer on February 06, 2009, 09:31:26 am
Quote from: GrannyGeek
[...]Maybe we're all saying the same thing.

Quote from: Joe1962
LOL, let's see if I can clear this up a bit... ;D 

LOL !

This thread is starting to look like the Virtual Audio Device Driver Tower of Babel !

( BTW that's:  מגדל בבל or برج بابل‎ )

:P ;D

I'll look at V.Box on XP - and get back to you all ... but, for clarity, I'm going to post the results in Ancient Phoenician.

* The story of the Babel Audio Driver is preserved in the "Enmerkar and the Lord of Aratta."
Title: Re: No Audio CD sound - VLRC4
Post by: Joe1962 on February 06, 2009, 09:51:29 am
LMAO... ;D ;D ;D
Title: Re: No Audio CD sound - VLRC4
Post by: wahfun on February 09, 2009, 05:09:58 am
Hello and thanks to all who have responded. I have been away from my desktop location for a few days and am just now getting back to this audio problem.

When I first installed the program, I had already done the things suggested in VB as well as the xmms settings. I did confirm that your suggested settings were in fact what I had originally set. They were, yet still no sound from the audio cd.

If anyone has any other ideas, I will try them. I still say that it is strange that VL plays dvd's with sound and not play an audio cd.
Title: Re: No Audio CD sound - VLRC4
Post by: Joe1962 on February 11, 2009, 12:48:33 pm
I still say that it is strange that VL plays dvd's with sound and not play an audio cd.
DVD audio is in the form of digital files, not digital recorded analog info like AudioCDs. After I posted above, I have been searching a bit and have yet to find any info that even mentions that virtualbox supports reading audioCDs the analog way.