VectorLinux

The nuts and bolts => Networking & Security => Topic started by: sledgehammer on February 26, 2009, 11:20:39 pm

Title: question re wicd with ndiswrapper
Post by: sledgehammer on February 26, 2009, 11:20:39 pm
Before putting 6.0 on my t42, I decided to get comfortable with it by loading it on an older, seldom used desktop machine.

I had to do some weird stuff to get my WG311v3 wireless card to work on that machine, a Compaq Presario 6000.

modprobe ndiswrapper would not work.  So, I added a new folder (2.6.27.7) in /lib/modules and copied over all the stuff from 2.6.27.12.  Then ran modprobe -f ndiswrapper and that worked.  Changed the /etc/rc.d/rc.local to force load of ndiswrapper on reboot by adding modprobe -f ndiswrapper.  Took a while and some help from my son to do this.

Then VLwifi worked fine.

However, WICD does not work. I use wep. I can see my wireless router (WICD calls it a network) as well as some others. I can get online with WICD to one of the "others" that is unencrypted.  But I can't get onto my wep network.  WICD says it is seeking authorization or some such and never goes past that point..  The little bar keeps moving back and forth but nothing connects.  I think the problem might be in the way I put in the password.  It insists on a password in wep(hex), passphrase and wep restricted.  Won't let me erase all the info in those spaces and start from scratch.

When I get on the internet with wifi radar, it works fine and wicd shows it connected.  But when I disconnect, wicd won't reconnect.

Any thoughts?
Title: Re: question re wicd with ndiswrapper
Post by: GrannyGeek on February 26, 2009, 11:50:53 pm
I had the same experience with VL 6 RC4. Wicd was never able to get me connected with wireless. I was also using ndiswrapper around an XP driver for the Realtek 8185 wireless chip in my laptop. I use WPA and fixed IP addresses. I could get connected with VLwifi, but wicd was useless.

Wicd didn't work for me with VL6 Deluxe,  but once I got set up and connected with VLwifi, my wireless connection has been up and ready to go as soon as I log in. Also, I didn't have to use ndiswrapper on VL 6 Deluxe. The kernel support for rtl8180 seems to be doing it this time.

Just so you know you're not alone...
--GrannyGeek
Title: Re: question re wicd with ndiswrapper
Post by: sledgehammer on March 27, 2009, 12:27:26 am
I never did get it to work reliably. I solved my WG311v3 problem by going to Wal Mart and buying a Linksys something or other.  VL automatically recognized the linksys on reboot and my problem was solved.  I then sent the Netgear off to a company in Iraq that uses Netgear products for target practice.
Title: Re: question re wicd with ndiswrapper
Post by: GrannyGeek on March 27, 2009, 10:58:20 am
Wicd has been working for me quite well. I was surprised because right after the installation of VL6 Standard Deluxe I had to use vlwifi to get my fixed IP, WPA wireless going. But once that was done, Wicd has been able to get my wireless started or reconnected. Nearly always the wireless is ready to go as soon as VL starts, but when it isn't for some reason, I can connect with Wicd.
--GrannyGeek