VectorLinux

Vectorbie Station => Vectorbie Questions => Topic started by: Dani Filth on March 12, 2009, 12:09:38 am

Title: VL-Hot mounting & LXDE [SOLVED]
Post by: Dani Filth on March 12, 2009, 12:09:38 am
Hello folks,

I'm new to Vector (but I do have some experience with other distros, though). I've installed VectorLinux Standard 6.0 on my laptop (Fujitsu S2020 Series, 4+ years old) and I kinda like it. I installed both XFCE & LXDE because in the first installation I tried to install only LXDE and unchecked XFCE thus it caused the system malfunctioned (X didn't work, some weird error messages etc). Plus, when I plugged in an external HDD/thumbdrive (I chose VL-HOT for mounting), both VL-HOT & unmount VL-HOT icons appeared on the screen, but when I double clicked on the VL-HOT icon, it acted like execute file/application and said something like "cannot execute" rather than an external HDD has been mounted and never opened a new window for me. However, this same HDD/thumbdrive is mounted and works just fine when I switch to XFCE.

So, is there a way to get this solved in LXDE?
And is there a way to have only LXDE on my laptop instead of having both XFCE & LXDE as well?

Thanks in advance :)
Title: Re: VL-Hot mounting & LXDE
Post by: nightflier on March 12, 2009, 05:54:54 am
@ Dani,  Your vl-hot issue is because pcmanfm handles the icons that pop up on your desktop differently from how XFCE does it. Work is in progress to address the issue. In the mean time, if you'd like an unofficial hack for it, send me a PM.
Title: Re: VL-Hot mounting & LXDE
Post by: lagagnon on March 12, 2009, 08:58:27 am
In LXDE when you open the file manager with the uppermost left icon on the desktop and with your external drive connected do you not see it in the leftmost panel of the file manager?
Title: Re: VL-Hot mounting & LXDE
Post by: nightflier on March 12, 2009, 10:14:04 am
In LXDE when you open the file manager with the uppermost left icon on the desktop and with your external drive connected do you not see it in the leftmost panel of the file manager?

That is when using HAL instead of vl-hot, I believe.
Title: Re: VL-Hot mounting & LXDE
Post by: Dani Filth on March 12, 2009, 06:12:55 pm
Thanks nightflier & lagagnon  ;D

I don't mind waiting for the official bug fix as I still can switch to XFCE to deal with this, but in the mean time, is there a way to mount external HDD/thumbdrive in LXDE other than having to "mount /dev/sdbx" to a temporary folder? Doing this in CLI is quite inconvenient.

Cheers
Title: Re: VL-Hot mounting & LXDE
Post by: nightflier on March 12, 2009, 11:33:13 pm
Your thumb drive does get mounted by vl-hot no matter what desktop environment you use. It doesn't even need X-windows. Navigate to /mnt/vl-hot and you will see it there.
Title: Re: VL-Hot mounting & LXDE [SOLVED]
Post by: Dani Filth on March 13, 2009, 01:04:05 am
Thank you very much nightflier  ;D