VectorLinux

Vectorbie Station => Vectorbie Questions => Topic started by: chatan on March 14, 2009, 06:53:51 am

Title: Forum search function screwy?
Post by: chatan on March 14, 2009, 06:53:51 am
I've been trying to find out if I'm doing something wrong ???, but the search function on this forum doesn't seem to work very well.  I'm always getting a bunch of results that don't match.

For example search for "samba" yields the results in the attached screenshot.   A few hits, but most threads don't contain "samba"

Am I doing someting wrong?

Thanks!
Title: Re: Forum search function screwy?
Post by: rbistolfi on March 14, 2009, 07:30:27 am
Yeah, known issue, you are not doing anything wrong. We are currently accepting suggestions about how to fix it (i.e. I dont known how to fix it ;D)
Title: Re: Forum search function screwy?
Post by: chatan on March 14, 2009, 07:52:31 am
Ouch!   That sure makes trying to find stuff harder, but at least I feel better.
This is the first forum I've run into that.

Anyway, Thanks for the info!
Title: Re: Forum search function screwy?
Post by: rbistolfi on March 14, 2009, 08:44:08 am
It got messed when we had to migrate the forum because the previous hosting was being cracked all the time.
Some fellows had better luck using the Search link at top left than the input at top right.
Title: Re: Forum search function screwy?
Post by: GrannyGeek on March 14, 2009, 04:19:43 pm
You could try searching with Google or a search engine of your choice. In Google's Advanced Search you can limit the searching to forum.vectorlinux.com. I just tried it and got lots of relevant hits from our forums.
--GrannyGeek
Title: Re: Forum search function screwy?
Post by: nightflier on March 15, 2009, 06:33:23 am
Maybe there is a way to configure the forum to use google instead of an internal search engine?
Title: Re: Forum search function screwy?
Post by: chatan on March 16, 2009, 02:38:13 am
You could try searching with Google or a search engine of your choice. In Google's Advanced Search you can limit the searching to forum.vectorlinux.com. I just tried it and got lots of relevant hits from our forums.
--GrannyGeek
Entering this into regular google search seems to work OK.

samba site:forum.vectorlinux.com

Thanks...
Title: Re: Forum search function screwy?
Post by: no2thesame on March 29, 2009, 12:20:11 am
This problem continues, and probably turns newcomers away. If it can't be fixed maybe we should just take the search functionality off the site.
Title: Re: Forum search function screwy?
Post by: Windozer on March 29, 2009, 01:15:57 pm
This problem continues, and probably turns newcomers away. If it can't be fixed maybe we should just take the search functionality off the site.

But if we do that, then PLEASE let's put in a google search as nightflier suggests.

It got messed when we had to migrate the forum

Rodrigo, is it the underlying data that's dorked from hacking, or the search engine routine itself that's been hacked?

- H
Title: Re: Forum search function screwy?
Post by: rbistolfi on March 29, 2009, 06:54:58 pm
The data is alright, the server has been compromised and was migrated to another phisical machine, since then, the search function is ruined.
I guess we could put a google search just editing the code for the form.
Title: Re: Forum search function screwy?
Post by: chatan on March 30, 2009, 01:22:23 am
FWIW: I had went ahead and made a vector linux custom google search and made it a bookmark in firefox:
http://www.google.com/coop/cse?cx=006523555979744360225:94-nviozrda

The EeePC user forums has a google custom search on their page (see the upper right on this page):
http://forum.eeeuser.com/

Cheers
Title: Re: Forum search function screwy?
Post by: sqijeff on May 13, 2009, 04:20:37 pm
Try the "samba" search now. We just integrated the Apache Org search engine code named Lucene. This is a full function search. Attached is the graphic for the simple samba search.

Note: this search will retur results across the VL support ticketing system, teh VL Knowlwdge Center and tis Forum.

Title: Re: Forum search function screwy?
Post by: no2thesame on May 13, 2009, 07:48:37 pm
Try the "samba" search now. We just integrated the Apache Org search engine code named Lucene. This is a full function search. Attached is the graphic for the simple samba search.

Note: this search will retur results across the VL support ticketing system, teh VL Knowlwdge Center and tis Forum.



Not pretty but it works very well. Thanks sqijeff

I like the knowledge center integration.

I know you've worked hard already but how about integrating stretchedthin's Video Tutorials too (mark it unofficial). http://www.opensourcebistro.com/
Title: Re: Forum search function screwy?
Post by: sqijeff on May 13, 2009, 09:22:06 pm
Thanks no2thesame. Yes, I am very interested in working to get the video tutorials integrated into the VL knowledge environment.  A search on an issue needs to list any tutorials available. I have a couple of ideas on this.

Also, do you have any ideas on how to enhance to look of the search results? Google's are also plain, but I am open to any input on the presentation that improves the communications of the results.
Title: Re: Forum search function screwy?
Post by: rbistolfi on May 14, 2009, 12:11:45 am
I dunno if its any better, but I thought I could show it anyways as an example of what could be done:

(http://img382.imageshack.us/img382/752/kdsearch.th.png) (http://img382.imageshack.us/img382/752/kdsearch.png)

I agreed with Jeff about a plain view on this one, I thought that in my example we could make clearer the difference between both sections in the results page. Google does this with a simple br but they do want the sponsored results to look like simple results :)
A bigger search box and switch to a cleaner font makes the rest of my proposition. I am thinking now that the results are needing a bigger font... oh well this is a never ending job :D
The implementation might be hard, maybe not if we can hack the mackup a bit... I dont know, as Jeff pointed, google is the perfect example of success with simplicity, and maybe we should follow that approach more often :)

Awesome work as usual, thanks guys
Title: Re: Forum search function screwy?
Post by: no2thesame on May 14, 2009, 03:24:54 am
switch to a cleaner font 
I agree there, the problem is mainly the fuzzy font. Not a big thing though.
Bruce
Title: Re: Forum search function screwy?
Post by: Leo Scott on May 14, 2009, 11:11:25 am
Thanks for the feedback, rbistolfi. Your styling looked awesome, so we have changed the style similar to what you have suggested. Please take a look. It looks much cleaner now.

-Steve at SQI
Title: Re: Forum search function screwy?
Post by: rbistolfi on May 14, 2009, 12:48:59 pm
Thanks for the feedback, rbistolfi. Your styling looked awesome, so we have changed the style similar to what you have suggested. Please take a look. It looks much cleaner now.

-Steve at SQI

Wow, tyvm. Firebug FTW! ;D
Title: Re: Forum search function screwy?
Post by: no2thesame on May 14, 2009, 04:06:21 pm
It looks much better.

Thanks Steve and Jeff.