VectorLinux

The nuts and bolts => Hardware & Drivers => Topic started by: gacl on March 29, 2009, 01:12:50 pm

Title: max_cstate: No such file of directory
Post by: gacl on March 29, 2009, 01:12:50 pm
Hey, guys, the new Vector looks awesome. Good job!

I have this question: How can i set the max_cstate?

I used to do echo $1 > /sys/module/processor/parameters/max_cstate before but now it gives me No such file or directory.

Thanks.

Gus
Title: Re: max_cstate: No such file of directory
Post by: lagagnon on March 29, 2009, 03:36:19 pm
Are you doing that as root?
Title: Re: max_cstate: No such file of directory
Post by: gacl on March 29, 2009, 06:05:34 pm
Quote
Are you doing that as root?

Yes. And the max_cstate file doesn't exist either.
Title: Re: max_cstate: No such file of directory
Post by: gacl on March 29, 2009, 06:26:56 pm
I looked at /proc/acpi/processor/CPU0/power and active state is set to C0. With 5.9 it was usually set to something and there would be an asterisk next to the corresponding state at the bottom.
Title: Re: max_cstate: No such file of directory
Post by: gacl on March 29, 2009, 07:42:03 pm
I just tested the system with 5.9 Live and it works fine. Active state reports C4 (and it gets the asterisk in the list) and i can freely toggle the states with echo (Minus the number sign. My mistake).

So what's different? The kernel? Oh, no.
Title: Re: max_cstate: No such file of directory
Post by: gacl on March 29, 2009, 08:36:18 pm
I found something else:

http://74.125.93.104/search?q=cache:V0FPPWKNfWQJ:lkml.org/lkml/2007/11/30/281+%22max_cstate%22+deprecated&cd=6&hl=en&ct=clnk&gl=us (http://74.125.93.104/search?q=cache:V0FPPWKNfWQJ:lkml.org/lkml/2007/11/30/281+%22max_cstate%22+deprecated&cd=6&hl=en&ct=clnk&gl=us)

If i'm not mistaken what the post says is that some old stuff, including max_cstate, is being replaced. But the post doesn't mention how can the C-states be set now. Anybody knows?


Edit: This search (http://www.google.com/#hl=en&q=max_cstate+tsc&btnG=Google+Search&aq=f&oq=max_cstate+tsc&fp=1&cad=b) explains better the problem (kernel bug), and provides a temporary solution which i'm trying to understand. The latest version (http://www.kernel.org/pub/linux/kernel/v2.6/testing/ChangeLog-2.6.30-rc7) of the kernel seems to be addressing the issue. . . ?
Title: Re: max_cstate: No such file of directory
Post by: gacl on May 29, 2009, 09:31:24 am
I tried adding processor max_cstate=2 and processor max_cstate=1 to /etc/modprobe.conf but it did nothing. I tried rebooting.

Some people report having luck with processor.max_cstate=2 as a "boot option" or "kernel parameter". Does anybody have any idea of what are they talking about?

Gus
Title: Re: max_cstate: No such file of directory
Post by: Daniel on May 29, 2009, 07:51:34 pm
The "boot options" or "kernel parameter" (maybe both) can be set up by running vliloconf (as root). The last question it asks you is something about setting one or both of those options.
Title: Re: max_cstate: No such file of directory
Post by: gacl on May 30, 2009, 10:21:50 am
Thanks, Daniel, that was what i was looking for. Finally i can have some peace and quiet. *takes earplugs off*