VectorLinux

The nuts and bolts => X-Rated => Topic started by: Lyn on April 23, 2009, 11:29:12 pm

Title: Adding Icewm
Post by: Lyn on April 23, 2009, 11:29:12 pm
As regular readers will know I am fond of icewm.  However when I try to install the meta package icewmvmods on VL6 Deluxe I get the following error:

xterm: Depends: libxcb >= 1.1-i586-1vl60

If I ignore it the packages install but when I try to launch via the GDM screen it bombs out and I am returned to the GDM log on screen

Any clues?
Title: Re: Adding Icewm
Post by: nightflier on April 24, 2009, 04:24:19 am
The package was only tested on VL Standard  :(

I have seen that unsatisfied dependency with other packages, though. Looks like Std has xterm-232-i486-1 installed. I see xterm-241-i486-1slack12.1 in repo, and it lists libxcb >= 1.1-i586-1vl60 as a dep, whereas only 1.0-i486-2 is available.

If you boot to TUI, use vxwmset to choose icewm, will startx bring it up then?
Title: Re: Adding Icewm
Post by: rbistolfi on April 24, 2009, 10:55:16 am
I will check the dependencies of xterm-241-i486-1slack12.1 as soon as I get home.
Title: Re: Adding Icewm
Post by: Lyn on April 24, 2009, 12:21:35 pm
No it doesn't unfortunately... it brings up Xfce!